Welcome to osx86.net

If you need help with your Hackintosh we have all the drivers, kexts and bootloaders and other stuff that you hadn't figured out you needed yet. Register now to get access to all of the files and forums.


All-in-one kext for Realtek chip Wireless USB adapters. 1827.4.05142015 / 2.3.11


1 Screenshot


About This File

Universal driver for Mac OS X 10.x.x.

Only one drive for many Wireless USB Adapters on the chip Realtek

The list of supported devices and chips:

"ASUS_USB-AC56"

"ASUS_USB-N10"

"ASUS_USB-N10E"

"ASUS_USB-N13"

"AboCom_8178"

"AboCom_8189"

"Abocom_0811"

"Abocom_88EU"

"Abocom_AC"

"Amigo"

"AzureWave"

"Belkin_1004"

"Belkin_1102"

"Belkin_2102"

"Belkin_2103"

"Belkin_F9L1106_v2"

"Belkin_F9L1106v2"

"Buffallo_25D"

"Buffallo_433DM"

"Compare-8010"

"Compare-8011"

"Corega"

"D-Link_DWA-131"

"D-Link_DWA-131E"

"DLINK_DWA123"

"DLINK_DWA125"

"DLINK_GO_USB_N150"

"DLink-DWA121"

"DLink-DWA123"

"DLink-DWA131B1"

"DLink-DWA132"

"DLink-DWA133"

"DLink-DWA135"

"Dlink_DWA-171"

"Dlink_DWA-172"

"Dlink_DWA-180"

"Dlink_DWA-182"

"Dlink_DWA-182_B1"

"Dlink_DWA-183"

"ELECOM WDC-150SU2M"

"ELECOM WDC-300SU2S"

"ELECOM_WDC-433DU2"

"Edimax_7811"

"Edimax_7822"

"Edimax_AC600"

"Edimax_EW-7811UAC"

"Edimax_EW-7822UAC"

"Edimax_GLP"

"EnGenius_AC"

"Feixun_90"

"Feixun_91"

"HP"

"Hawking_8811AU"

"Hawking_8812AU"

"Hawking_HW7ACU"

"Hawking_HWDN3"

"Hawking_HWUN4"

"Hercules_HWUm300"

"Hercules_HWUp150"

"IO_DATA"

"IO_DATA_AC433"

"IO_DATA_AC433UM"

"IO_DATA_WN-AC867U"

"Linksys_WUSB6300"

"Logitec"

"Logitec_LAN-W866ACU3"

"Loopcomm_ACA1"

"Netgear_A6100"

"Netgear_N300MA"

"Netgear_WNA1000M"

"Netgear_WNA3100M"

"NetweeN_91"

"PCI_BT-Micro3H2X"

"PCI_GW-300S"

"PCI_GW_USEco300"

"PCI_GW_USLight"

"PCI_GW_USNano2"

"PCI_GW_USValue_EZ"

"PCI_SW_WF02-AD15"

"Planex_GW-450S"

"Planex_GW-900D"

"RTL8188CTV"

"RTL8188CTV_0A8A"

"RTL8188CTV_8011"

"RTL8188CU"

"RTL8188CUS_1E1E"

"RTL8188CUS_2E2E"

"RTL8188CUS_5088"

"RTL8188CUS_Combo"

"RTL8188CUS_Combo_AFF8"

"RTL8188CUS_Combo_AFFB"

"RTL8188CUS_Combo_AFFC"

"RTL8188CUS_Solo"

"RTL8188CUS_VL"

"RTL8188CUS_solo_AFF7"

"RTL8188CUS_solo_AFF9"

"RTL8188CUS_solo_AFFA"

"RTL8188EU"

"RTL8188EU_ETV"

"RTL8188EU_VAU"

"RTL8188RU"

"RTL8188RU_Netcore"

"RTL8192CU"

"RTL8192CU_8177"

"RTL8192CU_8178"

"RTL8192EU"

"RTL8192EU-2"

"RTL8811AU"

"RTL8812AU"

"RTL8812AU-VL"

"RTL8812AU-VN"

"RTL8812AU-VS"

"Sitecom WLA-1100"

"Sitecom WLA-2100"

"Sitecom_WL365"

"Sitecom_WLA-2104"

"Sitecom_WLA1001v1"

"Sitecom_WLA2102"

"Sitecom_WLA4001"

"Sitecom_WLA7100"

"TEW_804UB"

"TEW_805UB"

"TPLink_8812"

"TP_Link"

"TrendNet_804B"

"TrendNet_805B"

"Trendnet_624D"

"Trendnet_648B"

"Western_AC"

"ZyXEL"

"ZyXEL_AC"

The package includes:

1.RtWlanU.kext

2.Wireless Network Utility

3.Icon app in the status bar

and a separate utility to delete old files.

INSTRUCTIONS:

1. Extract.

2. Remove Old Files First(kext and Wireless Network Utility).

3. Install.

4. Select standard installation.

5. Restart.

6. Insert the adapter into the usb port.

7. Select your network and connect.

95d9728f273f.jpg69e261780add.jpg

Install:

e45c2a700743.jpg

Status bar:

8b5819a5753e.jpg

Tested on TP-Link TL-WN725N-V2 OSX Yosemite 10.10.2,it’s worked!

Add new driver and new utility!

14.05.15 Compatible with 10.6.-10.8 Mountain Lion and 10.9-10.10 Yosemite.


What's New in Version 1827.4.05142015 / 2.3.11   See changelog

Released

  • Add new driver (1827.4.05142015) and new utility (2.3.11)! 14.05.2015

pedrolent, Leachz, SamclouD and 3 others like this



User Feedback



It looks old...IMHO
?

I have a problem with university wifi: if I want connect to it, I have to insert username and password, but in wireless network utility I can write only the password. How can I send both to university AP?

Share this comment


Link to comment

Works great so far on Yosemite 10.10.3, Without this i wasn't able to use this cheap USB Wifi dongle i got off eBay, the dongle uses the chip?RTL8188CTV so thank you (:

Share this comment


Link to comment

I'm using it with a?TP-Link TL-WN725N-V3?on my Surface Pro 1 running 10.10.3. I originally tried the 4in1 driver, but the utility would freeze. I just tried this one, and the utility works a lot better, without freezing on me. It will now let me eject the wifi adapter, and put in a pen drive, and then put the wifi adapter back in without any issues. (As long as I "Turn Radio Off" first)


I'm still having one issues though. The adapter will not work through a hub. It will say connected, but Network in System Preferences says no ip.


Share this comment


Link to comment

Yosemite 10.10.3 on HP 850G1: it works, even with sleep mode. A good job, thank you.

?

How do you do that? I installed latest one(ver 16.03.2015), but sleep is getting worse. Before I installed the recent ver, sleep was like freezing black screen for a couple of minutes then restart itself, but if I unplug it before sleep it would sleep normally(although the consequences are not being able to plug it back and all usb port is frozen). But now sleep freezes forever and I must force shutdown from power button, and even though the adapter isn't plugged at all from boot the sleep behaviour remains and I need to press the power button again(which is bad).

?

Anyone can help?

Share this comment


Link to comment

How do you do that? I installed latest one(ver 16.03.2015), but sleep is getting worse. Before I installed the recent ver, sleep was like freezing black screen for a couple of minutes then restart itself, but if I unplug it before sleep it would sleep normally(although the consequences are not being able to plug it back and all usb port is frozen). But now sleep freezes forever and I must force shutdown from power button, and even though the adapter isn't plugged at all from boot the sleep behaviour remains and I need to press the power button again(which is bad).

?

Anyone can help?

Test new version (14.05.15)

Share this comment


Link to comment

Test new version (14.05.15)

Still stuck and need to force shutdown, machine successfully hibernated though(with the 1st ver. in didn't hibernate). But when I choose the hibernated one everything goes wrong like brightness gone and wireless mouse error(can't hover, only click).

Share this comment


Link to comment

@vbin do you know where does the Wireless Network Utility store the network profiles?

See the profilesList.plist file within the app

Share this comment


Link to comment

This installer didn't work for me. I was using a D-Link DWA-121 on El Capitan and had no luck. Tried numerous times.?How can I uninstall this app??I can uninstall the wireless utility, but the status bar icon still stays there. Plus are there any kexts that need to get rid of it?

Edited by soundbase

Share this comment


Link to comment

Hey there
I do not speak English,
excuse me any inconsistency in my words
I have a wireless card:
Realtek RTL8187 Wireless 802.11b / g 54Mbps USB 2.0 Network Adapter
It is a very old but with high performance card, allows good connectivity over long distances depending on the antenna used, far exceeding the new ones as distance is concerned. That is why I ask as a favor to include in its Driver Pack for 10.11 El Capitan (All-in-one chip kext for Realtek Wireless USB adapters) I assure you that is the request of many.
Thank you and congratulations on the New Year

Mac OS X Leopard likes this

Share this comment


Link to comment

Hi there!

 

Thanks for helping out with this issue. 

 

I'm a dummy, but everyone needs to start somewhere..... :-)

 

I have a hackintosh and a real one. The hack has a much stronger wlan card, so for the air I use a ASUS AC56. But it's not working with El Capitan.....

 

Just to get it right:

1. I uninstall the not working utility with the version from 10.2.15

2. I install R2 10

3. I make the update with the version from 16.3.15 

 

Is that correct this way?

 

Sorry, for this simple stuff but I don't want to mess up things on my Mac, because I'm not that good in fixing things afterwards

 

Cheerio

Share this comment


Link to comment

Can you help me ?

I have osx sierra ( 10.12.1 ) with NETGEAR A6100 WiFi USB Mini Adapter - AC600 Dual Band - chipset: Realtek RTL8811AU

now I try to install all drivers but it doesn't work...

Please help me!

Best Regards

Edited by otq09398

Share this comment


Link to comment

Version 14.05.15 installed and working perfectly on my older 10.7 system using a Linksys AC1200 adapter! Installation and functionality working just as advertised in the description. I didn't think I had any chance of getting this little bugger to work. What a life saver! Thank you so much for the work and time you put into this!

Share this comment


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now