Jump to content


Always up to date!

Do you want to be kept up to date with new versions of files and / or news? Follow us on Twitter and Facebook! Make sure you are updated with new file versions!

Photo

Dell M90 And OS X Lion

- - - - -

  • Please log in to reply
24 replies to this topic

#1
blackxp14

blackxp14

    Junior Member

  • Members
  • Pip
  • 1 posts
I have been successful in installing OS X Lion on the Dell M90 using iATKOS L2, it runs very smooth and Graphics are enabled aswell, But before I get into how good it is, lets start off with how I installed it.


Specs are as follows
Intel Core 2 Duo T7200 @ 2.00GHz
4GB RAM @ 667MHz
NVIDIA Quadro FX 1500M 256MB (Working with Translucent Effects and Ripple )
5400RPM 2.5 Hitachi 250GB HDD
Atheros 9285 Mini PCIe Wireless Card
PBDS DVD+-RW DS-8W1P DVD/CD Burner



Here we go, first before installing Lion, you mist enter the BIOS and disable SPEEDSTEP as well as MULTICORE support to start Lion, After doing that SAVE/Exit the BIOS, No commands have to be entered to start Lion but I use the -v command just in case. It will take a bit of time to get to the OS X install screen so you have to be patient.

Assuming that you are at the OS X installer screen, Go into Disk Utility and then to the Partition Tab then from the Partition Layout select your partition. After selecting that, click on the Format Tab and select Mac OS Extended (Journaled) After doing so, click on Options and Then Select MBR and click on OK, then Apply.

Next, lol dont just click click click because unlike Snow Leopard, Lion lets you select the HDD and customize at the same time so be careful or you will install without checking the right installation files.

Heres what needs to be checked and keep in mind this is a 32 bit install

FakeSMC
GraphicsEnabler
Chameleon
Disabler
EvoReboot
RTC 32 Bit
Voodoo HDA 2.7.3 (Update voodoo if you feel you want 2.7.4)
PS/2
Laptop Battery

After selecting all those, continue with the install...

You will also Need VoodooTSCSync.kext to get the Multicore and Speedstep back working.
A lot of people have also asked me in person if I got Sleep and Ethernet as well as the Card Reader working and my replies to them are as follows.

Sleep works but it will freeze up the TrackPad when waking up as I have experienced, The ethernet BCM5752 will work with A kext that I will post as well as the TSCSync and Card reader Kext.

However, The card reader has its moments when it works, so for me, Its random and WILL freeze the Mac up at times so you would have to do a forced restart by holding down the Power button. Other than that, everything seems to be working fine with it, Updated to 10.7.5 with no problems and no reinstalls of kexts, Also Keep in mind that this install was did with A version of mac that was already at version 10.7.2 so any versions before that I am unsure of when it comes to lion. Happy Hackintoshing and hope it all works out for you guys. :D

One more thing, VoodooPState works but I am not sure if it keeps the processor speed at 998Mhz or if it just says that, Either way I do not use it because I want to get the full 2.00GHz out of my Processor. I will include it in the next upload or you can just browse around to find it.

Attached Files



#2
christ1111

christ1111

    Master Member

  • Members
  • PipPipPipPipPipPipPip
  • 1,549 posts
good job;)

this tutorial help a lot of guys:eagerness:;)
Posted Image

MY CONFIG HACKINTOSH

#3
tone602

tone602

    Junior Member

  • Members
  • Pip
  • 3 posts
Thanks Blackxp14,
Im trying the install with Niresh 10.7.3 right now. Do you have a dsdt for this u could upload?

#4
spyder51

spyder51

    Junior Member

  • Members
  • Pip
  • 5 posts
working nicely, M90 Quadro FX 2500m 4GB ram 2.17 GHz Core 2 Duo, thank you sir!!

PS upgraded to 10.7.5 easily. :-) thanks again

Edited by spyder51, 17 June 2013 - 07:08 PM.


#5
frees

frees

    Junior Member

  • Members
  • Pip
  • 8 posts
Hi, I also have precision m90, iAtkos L2 installation works fine, but when I try to boot I am stuck on this screen

Attached File  photo.jpg   100.42KB   10 downloads

I am using iatkos configured according blackxp14 post.

I think that real problem is with AppleRTC kext. I have no connected devices, just charging and lan.

Could please somebody help me?

M90 configuration is

C2D 2.0 ghz
4 gb ram
Nvidia Quadro 2500

#6
tone602

tone602

    Junior Member

  • Members
  • Pip
  • 3 posts
Try to boot with -v cpus=1 arch=i386 and see if it still gets stuck

#7
spyder51

spyder51

    Junior Member

  • Members
  • Pip
  • 5 posts
arch=i386 should work fine, also did you reset your bios back to default settings?

#8
frees

frees

    Junior Member

  • Members
  • Pip
  • 8 posts
Hi guys, awesome, it works, I now have fully functional Lion, just one question, I have 4 GB ram, so when I use arch=i386, only 3.25 GB is available. Is possible to use additional 0,75 GB?

#9
spyder51

spyder51

    Junior Member

  • Members
  • Pip
  • 5 posts
This is a motherboard limitation, when the M90 first came out Dell claimed 8gb usuable with x64, they lied!! :-) I do not believe there ii is possible to use your full 4gb with 32bit, but I could be wrong.

#10
frees

frees

    Junior Member

  • Members
  • Pip
  • 8 posts
Ok then, I will try Ram Disk, and I will see if it helps.

I have two more problems. Display sleep doesn't work very well, after waking up, display won't wake up. My second problem is crashing GUI, when I get white screen and after few moments GUI is restarted, but all open apps are restarted as well.

#11
spyder51

spyder51

    Junior Member

  • Members
  • Pip
  • 5 posts
have you edited you graphics kext ?

#12
frees

frees

    Junior Member

  • Members
  • Pip
  • 8 posts
No, I didn't edit graphic kext. It worked out of the box. How should I edit it?

#13
spyder51

spyder51

    Junior Member

  • Members
  • Pip
  • 5 posts
I will upload kext and kext utility.

here ya go. :-)



[ATTACH]5206[/ATTACH]

Attached Files

  • Attached File  2500.zip   1.92MB   18 downloads

Edited by spyder51, 27 July 2013 - 10:22 PM.


#14
frees

frees

    Junior Member

  • Members
  • Pip
  • 8 posts
OK thanks, I installed it, so far so good.

Edit: Hm, well it didn't help, GUI crashed again. :concern:

Edit2: I reinstalled OS X on Crucial M4 SSD installed all drivers and now Mac works perfectly and it's super fast. For example Mission Control launches instantly. I think that performance is equal to any mac with C2D cpu and graphic card similar to quadro 2500. I have one more question. Have you tried install iatkos ML2? I tried, but when I am booting installer, it stays stucked on PCI device configuration begin.

Edited by frees, 30 July 2013 - 12:54 PM.


#15
killawhale

killawhale

    Junior Member

  • Members
  • Pip
  • 5 posts
I have almost the exact same computer as the original poster my harddrive is just different but the best I can get is full res. I can't get qe/ci no matter what I do! I tried to edit the kexts, tried nvenabler/nvinject/natit, graphics enabler, etc! I know I don't have qe/ci because launchpad is very slow and imovie says I don't have quartz extreme. Can anyone help me?

#16
frees

frees

    Junior Member

  • Members
  • Pip
  • 8 posts
Didn't you forget to select GraphicsEnabler? when you was installing? If you did, you can turn it on in settings -> chameleon bootloader -> peripherals -> graphics enabler. Also don't forget to turn on Multicore and speedstep after installing specified kexts.

#17
killawhale

killawhale

    Junior Member

  • Members
  • Pip
  • 5 posts
I tried that but it didn't work :(

#18
frees

frees

    Junior Member

  • Members
  • Pip
  • 8 posts
Are you using iAtkos L2? If you have Precision M90 it has to work.

#19
killawhale

killawhale

    Junior Member

  • Members
  • Pip
  • 5 posts
Yeah iatkos l2! The graphics card just won't work for me! I'm 100% positive I have the quadro fx 2500m graphics card too. Do you have qe/ci?

#20
frees

frees

    Junior Member

  • Members
  • Pip
  • 8 posts
Yes I have. Whole GUI is accelerated and I can play FULL HD video in vlc with no problems




2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users