Jump to content


Always up to date!

Do you want to be kept up to date with new versions of files and / or news? Follow us on Twitter and Facebook! Make sure you are updated with new file versions!

Photo

[SOLVED] Help disable NVIDIA GT540M?

- - - - -

  • Please log in to reply
43 replies to this topic

#1
Coder_Dz

Coder_Dz

    Junior Member

  • Members
  • PipPip
  • 17 posts
Hello guys,

I've read on some places that it is possible to shutdown the NVIDIA Optimus GPU using the DSDT and some ACPI calls, but since I've never done such a thing, I'm totally clueless.

I have a Dell XPS 15 L502X with an NVIDIA GT540M and an Intel HD3000, and I was getting them both loaded, but the Intel GPU was the only one working, which is fine for me, but the NVIDIA discrete GPU is killing my battery, resulting in a loud fan noise, and increasing the laptop's heat too, which is really bad.

If anyone can help me patch this DSDT and disable the Optimus chip, I will tip him with a little $10 via Paypal for some appreciation.

Please anyone help.

I've tried to delete every single NVIDIA Kext that I believed it was involved, yet it's still running.

#2
Coder_Dz

Coder_Dz

    Junior Member

  • Members
  • PipPip
  • 17 posts
Thanks to "Lacedaemon" for his superb help, I got it shut down now!

Very thanks to this mysterious Soldier, he's a real HERO!

#3
Lacedaemon

Lacedaemon

    Lifetime Donator

  • Super Moderators
  • 2,552 posts
  • LocationUnited States
Just for anyone else out there: Post your dsdt.aml up here, so people can reverse-engineer it for their own successes. :eagerness:

Dfc.gif


#4
Coder_Dz

Coder_Dz

    Junior Member

  • Members
  • PipPip
  • 17 posts
I wish a tipping culture will evolve on such platforms, as it'll be rewarding for everybody involved. The simple user who needs to spend more time on other stuffs to be done for work or something similar, and the more advanced guys who need to get some love in return for their hard work that serve a lot of guys, who will come after them :)

I'll start playing with the sound a little bit, and if I can't figure it out, then I'll pay again to get it done for me :)

Well, Apple could've made a lot of money with us, but they chose to ignore us and leave us in the cold, which happened to be so wrong, since we have such great guys around making it warm and friendly, LOL!

#5
marlonfa

marlonfa

    Junior Member

  • Members
  • PipPip
  • 28 posts
please how you managed to disable your nvidia dell xps 15?

#6
Coder_Dz

Coder_Dz

    Junior Member

  • Members
  • PipPip
  • 17 posts
If it's a Dell XPS 15 L502X with an i7-2670QM, then try to use this dsdt, just put it in your /Extra:

[ATTACH]5054[/ATTACH]

Attached Files



#7
marlonfa

marlonfa

    Junior Member

  • Members
  • PipPip
  • 28 posts

If it's a Dell XPS 15 L502X with an i7-2670QM, then try to use this dsdt, just put it in your /Extra:

[ATTACH]5054[/ATTACH]


thanks for the help, I put the DSDT in the / Extra

1 - How do I know if nvidia was actually disabled?
2 - Now my sound stopped working, know what can be?
3 - What version of Mac do you use? 10.8.3?
4 - You could post your kexts?
5 - Have you had or are having problems like mine in the video in question appeared to be square in the middle of the screen and then the entire screen, as posted in this thread:

http://www.osx86.net...html#post149296

Thank you.

#8
Coder_Dz

Coder_Dz

    Junior Member

  • Members
  • PipPip
  • 17 posts
This is getting interesting.

My sound never worked before, until I installed this package:

VoodooHDA-v2.8.2.x64.ML.pkg

Everything's working except the microphone, and I haven't fully investigated it, but let's start with your questions; I guess we can help each other sort our things out.

1- Go to About This Mac->More Info->System Report->Graphics/Displays: You must see the Intel HD3000 alone. I'll attach a pic of how it looks now, also the fan gets more silent and the heat that was coming out becomes cool, and before I was I getting 2 display GPUs, now all I can see is the Intel one.

Get a look here:

Attached File  disabled_gt540m.jpg   20.59KB   39 downloads

2- May be my DSDT has indicated the package I'm using, which I've mentioned before, and here is the link, though the microphone doesn't work, it may need some customization:

http://www.osx86.net..._installer.html

3- 10.8.2

4- Sorry, but Kexts for what?

5- That's interesting, never experienced such artifacts before, but they started to appear only when I started using this DSDT and only when watching Flash Video, and not all the time, just sometimes, also some Flash Videos are burning my CPU, and I have to shut them down to unload my CPU overload.

Let me hear what do you think, I would like to get the microphone to work too.

#9
marlonfa

marlonfa

    Junior Member

  • Members
  • PipPip
  • 28 posts

This is getting interesting.

My sound never worked before, until I installed this package:

VoodooHDA-v2.8.2.x64.ML.pkg

Everything's working except the microphone, and I haven't fully investigated it, but let's start with your questions; I guess we can help each other sort our things out.

1- Go to About This Mac->More Info->System Report->Graphics/Displays: You must see the Intel HD3000 alone. I'll attach a pic of how it looks now, also the fan gets more silent and the heat that was coming out becomes cool, and before I was I getting 2 display GPUs, now all I can see is the Intel one.

Get a look here:

[ATTACH=CONFIG]5055[/ATTACH]

2- May be my DSDT has indicated the package I'm using, which I've mentioned before, and here is the link, though the microphone doesn't work, it may need some customization:

http://www.osx86.net..._installer.html

3- 10.8.2

4- Sorry, but Kexts for what?

5- That's interesting, never experienced such artifacts before, but they started to appear only when I started using this DSDT and only when watching Flash Video, and not all the time, just sometimes, also some Flash Videos are burning my CPU, and I have to shut them down to unload my CPU overload.

Let me hear what do you think, I would like to get the microphone to work too.



Thanks for the help, well come.

My sound and microphone were functioning normally, but something happened here that did not know what would happen when I came to your DSDT for my Extra folder, a time before the MAC requested update, just updating, and he went from version 10.8.3 to version 10.8.4, ie, it may not be your DSDT but the update, I do the following, I will remove your DSDT and see what answer you give and now, ok?

My sound is working again, you could pass me which part you modified the DSDT to disable nvidia? So I put in my DSDT and so we have the two features, if it works I'll give you the audio kexts that work mic and audio, ok?

Edited by marlonfa, 09 June 2013 - 02:55 AM.


#10
Coder_Dz

Coder_Dz

    Junior Member

  • Members
  • PipPip
  • 17 posts
Sorry, really have no idea, I asked Lacedaemon to do it for me, and he did it on the fly, you may PM him, and I'm sure he'll help you.

But if you want, here are the instructions:

Nvidia Gt5xxm Dev - Project OS X Forums

Oh, plz, what Audio Kexts do you use?

#11
marlonfa

marlonfa

    Junior Member

  • Members
  • PipPip
  • 28 posts
first pass to me your vendor id and device id of your sound as well as send you the modified kext's.

You could run the battery icon to show the percentage?

#12
Coder_Dz

Coder_Dz

    Junior Member

  • Members
  • PipPip
  • 17 posts
Nope, no battery indicator unfortunately!

Here is my Audio Device ID: 0X80861C20, so it's the 1C20 ALC665 (Codec Names: Realtek ALC665, Intel HD3000 HDMI)

I do appreciate your help.

For the battery, I remember installing a Kext that said it should fix one of my problems that I don't remember, and it also indicated that it would unable me from seeing the battery percentage, coz I went through many installations to finally settle down on this, and on one of the previous installations I had the battery percentage working just fine.

#13
marlonfa

marlonfa

    Junior Member

  • Members
  • PipPip
  • 28 posts

Nope, no battery indicator unfortunately!

Here is my Audio Device ID: 0X80861C20, so it's the 1C20 ALC665 (Codec Names: Realtek ALC665, Intel HD3000 HDMI)

I do appreciate your help.

For the battery, I remember installing a Kext that said it should fix one of my problems that I don't remember, and it also indicated that it would unable me from seeing the battery percentage, coz I went through many installations to finally settle down on this, and on one of the previous installations I had the battery percentage working just fine.


Their id's are like mine, well I used two kext's installed first and then the AppleHDA and VoodooHDA panel but before you uninstall the installed. For the microphone to work, you will in Preferences System - VoodooHDA - Select Microphone (ATAPI) and controls increase the iMix, so your mic work, but have to increase this control every time you use, know that the to change it, but when I want to fix things. Any questions just talk, ok?

audio - Download - 4shared

#14
Coder_Dz

Coder_Dz

    Junior Member

  • Members
  • PipPip
  • 17 posts
That's fantastic, thank you!

I'm gonna give it a try right now.

Man!

I just went to the VoodooHDA Pref I have already, and I increased the iMix and everything's working! Not just that, but I don't have to set it each time I reboot my laptop! You sure gotta use the Package I've posted from before.

_______

Edit:
There is still a lot of noise, and my voice sounds so quiet and deep, but at least I won't need to reboot into Ubuntu or Windows to have a conversation on Skype.

Edited by Coder_Dz, 09 June 2013 - 04:02 AM.


#15
marlonfa

marlonfa

    Junior Member

  • Members
  • PipPip
  • 28 posts

That's fantastic, thank you!

I'm gonna give it a try right now.

Man!

I just went to the VoodooHDA Pref I have already, and I increased the iMix and everything's working! Not just that, but I don't have to set it each time I reboot my laptop! You sure gotta use the Package I've posted from before.


Cool, if it worked the mocrifone, I will use your kext and DSDT for your already that the only problem was that she desabilitava my sound, let's see how it goes.

#16
Coder_Dz

Coder_Dz

    Junior Member

  • Members
  • PipPip
  • 17 posts

Cool, if it worked the mocrifone, I will use your kext and DSDT for your already that the only problem was that she desabilitava my sound, let's see how it goes.

Plz backup your kexts first!

#17
marlonfa

marlonfa

    Junior Member

  • Members
  • PipPip
  • 28 posts

Plz backup your kexts first!


Fantastic, working sound with microphone and nvidia disabled, another good news, I managed to work out the percentage of the battery, install this kext using kext utility here as it will backup the original kext, or you back up your way, and install this kext, it worked for me, if you ve also can, ok?

AppleACPIPlatform - Download - 4shared

you still use the kext NullCPUPowerManagement?
If not, what did you do to fix the gerenciamente energy?

Edited by marlonfa, 09 June 2013 - 04:36 AM.


#18
Coder_Dz

Coder_Dz

    Junior Member

  • Members
  • PipPip
  • 17 posts
That file has been removed on the fly, can you zip it and upload it here plz?

you still use the kext NullCPUPowerManagement?
If not, what did you do to fix the gerenciamente energy?


I used one found on the net, I can upload it for you if you want, but I don't get the 2nd part of your question if you would clarify, I'd give a better answer.

#19
marlonfa

marlonfa

    Junior Member

  • Members
  • PipPip
  • 28 posts

That file has been removed on the fly, can you zip it and upload it here plz?



I used one found on the net, I can upload it for you if you want, but I don't get the 2nd part of your question if you would clarify, I'd give a better answer.


Sorry, but that file was removed?
About power management, is that it is so, you have to use the kext NullCpu order to avoid power problems, but is not using it right, but to modify their work only when processors should work, you know? To do this you must create a SSDT, did this on my but I can not tell if ta running everything, and these changes should operate the Rest of the system, but still does not work here. In your work?

#20
Coder_Dz

Coder_Dz

    Junior Member

  • Members
  • PipPip
  • 17 posts
Yes, I didn't download your file, because it was removed.

I don't have any problems with the power management so far, and I have the CPU monitor showing on the top panel and I can see the 8 cores just fine, and are very stable so far, and only when I'm opening Android Studio, Xcode, QtCreator and launching an Android Emulator, I can see some cores going a little bit overloaded and sometimes a core gets fully overloaded, so I guess everything is fine on my part.

My issue is with the percentage not showing and I'm gonna investigate it, I didn't before because I didn't see the need, since most of the time I'm plugged into a DC, but it is worth the fix, I guess.

If you want any specific Kext from my part, I'll upload it for you.

LOL, by the end we can formulate a Package for the Dell XPS 15 users out there :)

________

Edit: My extracted SSDT from Ubuntu has been injected into my DSDT already, so all is cool.

Edited by Coder_Dz, 09 June 2013 - 03:55 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users