Jump to content


Always up to date!

Do you want to be kept up to date with new versions of files and / or news? Follow us on Twitter and Facebook! Make sure you are updated with new file versions!

Photo

Windows 7 time/clock is wrong!

- - - - -

  • Please log in to reply
15 replies to this topic

#1
naddie

naddie

    Junior Member

  • Members
  • PipPip
  • 27 posts
I am currently dual-booting SL and Win7. SL's time is correct, but Win7 is always off by hours, but the minutes and date is good.

For example, It's 10:45pm now. Win7 says it's 3:45am.

It's fine in SL, so it's not the CMOS. Consequently, the CMOS time is correct as well.

Time zome is set correctly in Win7. In fact, if I force it to update the time (internet time server time-a.nist.gov), it gets the right time right away.

I guess the only way around it now is to find a command or write a script to start up when Windows boot to sync the time to the time server.

Anyone seeing this weird behavior?

I am using Chameleon 2.0 RC3.
Gigabyte EP45-UD3R
Q9550 @ 4.0 GHz (8.5x471 MHz FSB)
4 GB DDR2 RAM
EVGA GeForce GTX260
Mac OS X 10.6.1 on 500GB HDD
Windows 7 Ultimate on 2x 500GB HDD (RAID0 on Gigabyte/jMicron controller)
Cooler Master HAF 922 case
Samsung DVD recorder
Creative Labs X-Fi Fatality FPS (Windows only)

#2
Mike

Mike

    Expert Member

  • Members
  • PipPipPipPipPip
  • 506 posts
This is normal behavior, even on Macs. Installing the Boot Camp software from your Mac OS X disc will fix it.
Chameleon EFI 2.0 RC5 | Mac OS X 10.6.5
MB MSI P55M-GD45 (BIOS v1.8)
CPU Intel Core i7 2.8 GHz
GPU ATI RADEON 4870 HD (1 GB)
RAM 8 GB G.SKILL DDR3-1600
HDD 1 TB Western Digital | DVD Sony Optiarc AD-7220S
DISPLAY 24" Apple LED Cinema Display

#3
Bluenotes

Bluenotes

    Junior Member

  • Members
  • PipPip
  • 22 posts
Mike's way works but for me it never did. Here is a workaround if yours doesn't.

**Please use this at your own risk as you are editing the Windows Registry**

1. Go into windows and set the time correctly
2. Select Daylight Savings and time synchronization to OFF (use correct time zone)
3. RUN Regedit
4. Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\TimeZoneInformation\
5. ADD a DWORD Value
6. Name it RealTimeIsUniversal, set value to 1, leave the Base as Hexadecimal. (make sure you put the DWORD exactly as you see here with the capitalization)
7. Close Regedit
8. Reboot into OSX and reset the clock and make sure you're using the same time zone as in windows.
Cartri's Bios+Bootloader: MB Gigabyte P45-UD3P | CPU QuadCore 2.8 | Memory 4Gb A-Data | GPU nVIDIA 250 |
Macbook Pro: Early 2008
iPhone 4: Black 16GB
iPad: Wi-Fi 16GB

#4
marcos

marcos

    Member

  • Members
  • PipPip
  • 30 posts

Mike's way works but for me it never did. Here is a workaround if yours doesn't.


Cool, got the same problem (one of them under win7) and will try this! Thanks a lot!
EP35-DS4 with Intel Q9400
MSI 9800GT Whisper
8GB DDR2 RAM
WIN7 & MacOSX10.6.1
EFI-X V1@4.6.14 Chameleon 2.0RC3

#5
naddie

naddie

    Junior Member

  • Members
  • PipPip
  • 27 posts
Thanks! Glad no one just gave me the standard "check your time zone" runaround. It's definately Mac OS X that is causing the issue, because it seem to change the BIOS's clock after I boot into it, causing wrong time in Windows 7. I dunno how the Mac OS gets it's time, but it's always right.
Gigabyte EP45-UD3R
Q9550 @ 4.0 GHz (8.5x471 MHz FSB)
4 GB DDR2 RAM
EVGA GeForce GTX260
Mac OS X 10.6.1 on 500GB HDD
Windows 7 Ultimate on 2x 500GB HDD (RAID0 on Gigabyte/jMicron controller)
Cooler Master HAF 922 case
Samsung DVD recorder
Creative Labs X-Fi Fatality FPS (Windows only)

#6
naddie

naddie

    Junior Member

  • Members
  • PipPip
  • 27 posts
BTW, anyone explain how/why this is happening though? What does the registry editing do?
Gigabyte EP45-UD3R
Q9550 @ 4.0 GHz (8.5x471 MHz FSB)
4 GB DDR2 RAM
EVGA GeForce GTX260
Mac OS X 10.6.1 on 500GB HDD
Windows 7 Ultimate on 2x 500GB HDD (RAID0 on Gigabyte/jMicron controller)
Cooler Master HAF 922 case
Samsung DVD recorder
Creative Labs X-Fi Fatality FPS (Windows only)

#7
Bogus

Bogus

    Junior Member

  • Members
  • PipPip
  • 18 posts
Is because windows interprets bios clock as local time, while mac os and linux consider the bios clock to be set to UTC.
Mobo: Gigabyte GA-EP45-DS3P bios F8
CPU: Intel Q9550 Quadcore CPU @ 2.83Ghz
RAM: 2x2Gb Corsair@1066Mhz
GFX: Asus NVIDIA GeForce 7300 GT 256MB
HDD: Westen Digital 500GB WD5000AADS
DVD: Optiarc AD-7200S
OS: OS X 10.5.8
Chameleon 2.0-RC3-r658 with dsdt.aml

#8
iNDi

iNDi

    Junior Member

  • Members
  • PipPip
  • 11 posts
its best to not mess with the registry settings.

Bootcamp contains a windows exe called AppleTime.exe, run that each boot and your time will be corrected.

Full guide and download availabled here

http://swmirror.org/drupal/?q=node/32

iNDi

#9
naddie

naddie

    Junior Member

  • Members
  • PipPip
  • 27 posts

its best to not mess with the registry settings.

Bootcamp contains a windows exe called AppleTime.exe, run that each boot and your time will be corrected.

Full guide and download availabled here

http://swmirror.org/drupal/?q=node/32

iNDi


Will it work for both 64-bit and 32-bit Windows 7?

I kinda like the registry setting because there's less things running. It sounds like the AppleTime fix is a service that "doesn't respond like a service" (according to the link). Not sure what that means, so I'll stick with the registry setting for now. it works, though!
Gigabyte EP45-UD3R
Q9550 @ 4.0 GHz (8.5x471 MHz FSB)
4 GB DDR2 RAM
EVGA GeForce GTX260
Mac OS X 10.6.1 on 500GB HDD
Windows 7 Ultimate on 2x 500GB HDD (RAID0 on Gigabyte/jMicron controller)
Cooler Master HAF 922 case
Samsung DVD recorder
Creative Labs X-Fi Fatality FPS (Windows only)

#10
mdcy

mdcy

    Junior Member

  • Members
  • PipPip
  • 11 posts
Another idea is

run cmd as administrator, and copy the code:

Reg add HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation /v RealTimeIsUniversal /t REG_DWORD /d 1

past the code in cmd, and put enter, reboot your win7 x32/x64. done.

#11
billtech66

billtech66

    Junior Member

  • Members
  • Pip
  • 1 posts

Another idea is

run cmd as administrator, and copy the code:

Reg add HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation /v RealTimeIsUniversal /t REG_DWORD /d 1

past the code in cmd, and put enter, reboot your win7 x32/x64. done.


Thank you for this fix, it worked perfectly.

I've never done a cmd proceedure before, so I did stumble a little, but after I figured out how to find where to enter cmd, and then proper syntax to enter it, and removed a space in the middle of "info mation" it worked just fine. :)
I restarted several times and the time is still correct, whereas it was 4 to 8hrs off before this fix.
thanks!

#12
cleopete

cleopete

    Junior Member

  • Members
  • Pip
  • 1 posts
Don't be such a wuss iNDi. Reg editing is perfectly safe and effective... as long as you aren't drunk at the time, and you check your typing carefully. If you aren't just going in deleting keys all willy-nilly, it's actually not that easy to screw up your system- though you certainly can. At any rate this fix worked great, thanks Bluenotes. The cmd line is basically the same thing, just badly typed (see above), which is why I prefer regedit.

#13
Spike

Spike

    Member

  • Members
  • PipPip
  • 72 posts
Here are a couple of registry entries that you can use, one fixes the issue, the other removes it. I used the fix and it worked fine.

Edit #1: Just so you know....these came from a thread I was following on the Insanelymac forum (installing on Asus P6T V2 Deluxe).

#14
chrisburnett87

chrisburnett87

    Junior Member

  • Members
  • Pip
  • 1 posts
Hi,
It is normal problems. If you can reinstall the window. Then window 7 take the time option, then you can change the city and time. It is proper work. or
you can go control panel option click the date and time and click time zone set the city and time. Then apply and OK.

#15
Toltuga

Toltuga

    Donator

  • Donators
  • PipPipPip
  • 145 posts
try this pack OS X Time Sync Fix by Zephyroth just install it on osx and it will fix the time problems :) , once you install it put the correct time on osx and thats it, when you boot on win7 you'll the correct time , good luck
MOBO:......GA-EP45-UD3P
CPU:.........Intel 2 Quad Q6600 @ 2.4 GHz
GPU:.........EVGA Nvidia e-GeForce 9600 GT 1GB (Dual Monitor: Acer X223W DVI / Dell M991 VGA)
RAM:.........8 GB Corsair Dominator DDR2
ODD:.........Samsung SH-S223C SATA
HDD 1:......Seagate Barracuda 40 GB ATA (WIN)
HDD 2:......Western Digital Caviar Green 1TB SATA (OSX)
OS:...........Lion 10.7.1 Vanilla | Windows 7
BOOT:.......Chameleon v2.1svn r1402

#16
MacReaper

MacReaper

    Senior Member

  • Members
  • PipPipPipPip
  • 335 posts
  • LocationDarkMac

It happens because OS X steals Windows' clock and resets it. :lol:


Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users