Jump to content


Always up to date!

Do you want to be kept up to date with new versions of files and / or news? Follow us on Twitter and Facebook! Make sure you are updated with new file versions!

Photo

Tips for Newbies and Those Almost There

- - - - -

  • Please log in to reply
7 replies to this topic

#1
elmangomez

elmangomez

    Expert Member

  • Members
  • PipPipPipPipPip
  • 519 posts
Tips for Newbies and Those Almost There...

With this post, I hope to answer what seem to be very common threads new people are asking. Please do read this carefully before asking questions. I am breaking this into various sections addressing people who are COMPLETELY new to this, all the way to those who have their systems ALMOST there.

I am writing this because I find myself answering the same questions over and over. This should be your first stop before you start asking…. Chances are I cover it here.

Section 1
I am a complete newbie!

Let me preface this by saying, I was there, I felt your pain, I was just as confused and overwhelmed as you are. What I say to everyone…. Do not despair; you will get your system up and running. Bite the bullet because you WILL need to learn this. It is not as bad as it seems, and we are all here to help. Very important… read everything very very carefully. Do not skip steps. Do not assume anything. Edit: Also if you run into issues after you have OSX almost-running, address solving each issue one at a time and attempt and test one solution at at time. This will avoid having a possible solutions that breaks more things that it fixes, and you can narrow fixes/solutions in a logical order.

The obvious truth is that there is a lot of confusing information out there. The information is constantly changing, and it is very hard to keep track of it all. My hope with this is to guide on your way. There is not (yet) a commercially available (or free) solution that will address all of your needs. There are guides galore, but lets focus on getting you up and running.

Please do not whine and demand someone make it easy for you. It simply cannot be done. You can pay a consulting fee to someone, but the reality is that you will need to go through this learning curve or you will be dependant on this consultant to hold your hand always. If you are stubborn and insist on ease, please do yourself a favor and buy a real Mac.

After all I said, if you willing to continue, at this point there are two roads you could take. One is the “as-easy-as-it-gets” Lifehacker guide. The second is to learn Chameleon.

Road One: Lifehacker Guide
(Google “Lifehacker Hackintosh Snow”)
This is as easy as it gets. However, you hardware must match their hardware; specifically the Motherboard and video card. If your hardware does match (mine actually does) give it a try. It cannot hurt…. My reality was not as easy, it simply did not work for me. It does not mean you will have the same experience I did. Give it a go.. and you will know if you must go to the next alternative. But don’t stop reading this now… we need to address “Where to Install Chameleon” below.

Road Two: Learn Chameleon
This will make you a power user. The learning curve is slightly steep, but I guarantee that within a weekend, you could be up and running. Before I start telling you how to go about this, it is important that you understand the following:

This guide will only address creating a Hackintosh based on the Hardware Compatibility List (HCL) of the Efix devices, or the one listed by Mike on this forum. No ifs ands or buts…The hardware focuses mainly on Gigabyte brand motherboards, nVidia Graphics cards, with a couple ATI cards thrown in. I do not have ATI experience, thus I cannot advice on these. Sooo if you have a Dell, or a laptop, or an Asus motherboard, etc. my guide here will not be much help. It is not that we do not want to help; it is that we may not have the experience you need. This forum is based on ex Efix users who share basically the same hardware. Because of this, it is easy to pool our resources and find solutions that are helpful to each others. This is a huge advantage.

Where to Install Chameleon
There are 3 choices for this…. I am partial to one of them. I will give you my reasons for it, feel free to disagree. For the most part I think you could go with any choice… but your mileage may vary. OK, where to install…. Three choices that I am aware of. Your Mac Hard Drive, the EFI Partition of your Mac Drive, or on a removable USB flash thumb drive (aka “stick”). EFI partition of you HD is something Mac OS creates but does not use. Chameleon can be installed here…..

My choice and advice is to go with a stick. Do not try to convince me otherwise, I am comfortable and happy with this. Why do I like it? Sticks are cheap; I have about six of them. If I want to experiment and try something new, I try it on a new stick, and I can always go back to an earlier working version if things don’t work out. Plus it keeps the Mac system completely vanilla… If you need to upgrade Chameleon, again, try it on a new stick… if you run into trouble, go back to the old stick.

How to learn Chameleon?
I think to start your education; the very best way is to follow AsereBLN’s blog. He goes into careful detail how to do all of this. This should get you 95% of the way…. The last 5%, I will address here, or you can ask if this post does not provide the answers. If you want to install Snow Leopard, start with his post titled:

1.) [10.6] Let's start with Hardware Requirements
Dated Sept. 22

And work your way up the list.

Before you leave this page, do keep in mind that you will need a dsdt.aml file. His blog describes how to create it. You can ignore this part if you have a motherboard for which he has a ready made dsdt. This is what I used, and it will save you a ton of work. Check the link below for the ready-to-go dsdt’s:

Please note that you must match your motherboard model number, revision and bios version EXACTLY. Do not assume that one close enough will work. If he does not list one, you can ask him to create one for you. He outlines what you need to prepare so he can create one….

I cannot continue without praising Asere. This community would be NOWHERE without him. He and Mike are single handedly responsible for all of us having working Mac OS. Both Asere and Mike (the owner of this forum) accept donations…. DONATEDO NOT EVEN THINK OF IGNORING THIS…. They deserve it. I have donated money and my time helping others. In order for progress to continue, these guys need to be appreciated and properly helped. Money is the way to help for legal fees (don’t ask), bandwith, equipment and their time.

Get the ready made dsdt’s on this post:

http://www.efixusers...thread.php?t=38


OK, armed with the above knowledge, go to Asere’s site, read the directions carefully, have a positive attitude, be patient, take it one step at a time (ignore the creation of the dsdt), and have fun. Do not be intimidated by the Terminal. If at the end of this whole process you end up with a working system, and I was helpful, just let me know. It will make me feel good.

Here is Asere’s blog: http://aserebln.blogspot.com



Mobo: Gygabyte EP45-UD3p
Video: nVidia 9800 GTX+
DVD: LG something
RAM: 6 GB mixed brands
HDD: About 8 of them all SATA
CPU: Intel Core 2 Quad Q9650 3.0GHz

#2
elmangomez

elmangomez

    Expert Member

  • Members
  • PipPipPipPipPip
  • 519 posts
Section 2
I am ALMOST there…. I can feel it!

If you are here, congratulations. The hardest part is over. If you are here, I am assuming that you are able to boot Mac OS and are having a couple of issues. For the most part, users need help with Sound, or Video not working properly. I will address each of these issues.

But again, the ONE condition is that you must be using the LATEST dsdt file from Asere. These address all the old issues and most likely the new ones. It will be hard to help you if you are not using the latest ones.

Video
Symptoms: You only get one screen resolution choice and/or interface seems kind of slow.

In order to take full advantage of video you must have a fully supported video card. If you have a supported card, there are a couple of ways to address this. Both of these methods require you open the com.apple.Boot.plist file (aka: boot.plist) that is stored in the /Extra folder where you installed Chameleon. Open this file with TextEdit.

First and simpler option is to search for the following 2 lines in the boot.plist:

<key>GraphicsEnabler</key>
<string>y</string>

If you do NOT find the two lines, insert them AFTER any line that ends in </key>

Make sure you have the string above set to yes…. From now on, this will be knows as GraphicsEnabler=y/n.

Reboot your computer…. If your computer boots to a blue screen (after the Apple logo screen); this is not too uncommon. After a minute or two, press the keyboard shortcut to put your computer to sleep. It may take a minute for it to go to sleep. Then wake the computer up and you should have your desktop. Test to see if you have all resolutions available. If you do, also check System Preferences > Desktop and Screensaver. Press the Desktop button, and ensure you have the “Translucent menu bar” option visible. If you do, you are golden. If you do not, chances are that you are not using hardware graphics acceleration.

If you do not see the “translucent menu bar” we should check how your graphics card is running. Google, download, and run Cinebench. Once you open the application, click on the button that says OpenGL Benchmark. It will run this little Ghostbusters type animation… at the end it will give you a result. If your result value is in the hundreds, you are NOT using hardware acceleration. If your result is in the thousands, you are good to go.

Edit 10/29/09: If you are NOT hardware accelerated after this, please read post #4 below titled - Video Addendum 1... There is one more step to attempt to see if we can get GraphicsEnabler=y to be hardware accelerated.

Continue from here if Video Addendum No. 1 did not resolve your issues.

If you are NOT hardware accelerated. You need to download, and run EFIStudio. Under Select Device, make sure it says “Display” On the drop list, find the video card that matches or is closest to yours. Click on “Add Device”. A screen will pop with two windows. Copy ALL of the contents of the lower window to your clipboard…. This is a long continues string of numbers. This is know as your video string, or EFIstring.

Paste your string into your boot.plist in the section:

<key>device-properties</key>
<string>PASTE HERE</string>

If you do not have this entry in your plist, paste the 2 lines above RIGHT BEFORE the end, above where it says </dict>. Do not forget to set GraphicsEnabler=n.

Badger77 found a version of EFIStudio that is pretty comprehensive. Check his post here

http://www.efixusers...69&postcount=18

Reboot and test as described above. In my experience, if your exact video card is not listed in EFIStudio, and you have an nVidia GeForce use the string for the 9800 GTX… Chances are it may work, but you may get the occasional blue screen after boot. At this point I would suggest searching for a valid string on the internet for your video card.

Hardware is not Properly Detected
Symptom: When you go to System Profiler, your CPU, memory, video card, etc. are not being properly listed/detected.

From what I gather, these are simply cosmetic issues. Because these are not actual Macs, with the proper hardware ID codes, the Mac is reporting missing or wrong info on the hardware. This should NOT have any impact on performance, or usability of your hardware. Everything will be used at its maximum capacity even though it is not properly reported. If this is critical to you, There are many guides out there, that will teach you how to trick System Profiler into showing the values you want. Again, cosmetic only…

Sound
Read Below…..



Mobo: Gygabyte EP45-UD3p
Video: nVidia 9800 GTX+
DVD: LG something
RAM: 6 GB mixed brands
HDD: About 8 of them all SATA
CPU: Intel Core 2 Quad Q9650 3.0GHz

#3
elmangomez

elmangomez

    Expert Member

  • Members
  • PipPipPipPipPip
  • 519 posts
Sound
Symptoms: I cannot get sound to work…. Or my headphones do not work…

Important note… there is a slight possibility that the fix below “breaks” your video… you will go back to the single resolution and slow performance. If this happens to you, I will post a guide how to fix that. I believe will may happen if you are using a graphics string in your boot.plist

The first thing to note that this ONLY fixes sound issues on Gigabyte motherboards that are using the ALC889a audio chipset. You need to check the specifications of your motherboard to see if this whole section applies to you. If you do NOT have an ALC889a on your motherboard; stop reading… This will probably not be much help.

OK, here I confess that I am not sure how your untouched latest Asere DSDT file may be configured. So let’s check one thing first. We are going to open the dsdt.aml file. I am going to describe the method I use… there are other methods… but this is what I am comfortable with.

The dsdt.aml file is compiled. In order to edit/patch it, it needs to be decompiled. Once decompiled, you can open and edit its contents with TextEdit. To decompile, Google and download iaslMe. This is a simple yet powerful utility. Lets say you copy the iaslMe app to your desktop, the icon will be there. Open Finder and navigate to your /Extra folder. Grab the DSDT.aml file and drag it to the iaslMe icon on your desktop. The software will decompile the dsdt and create a file called dsdt.dsl. This is the file you can open with TextEdit…. Now what is all this crap? I cannot make sense of this….. I know and I understand. So the rule is to be very careful, do not edit anything more than what I tell you…. Repeat: do not edit anything more than what I tell you.

Using TextEdit's Find command, search for the word “ABLN” (without quotes). If it does not find anything, shame on you; you are not following the directions and you are using someone else dsdt. For this to work, you must be using the LATEST dsdt.aml file specific to your motherboard model and bios version.

OK, so you found the string ABLN… The line should read something like this:

[FONT=Arial][SIZE=2]Name (ABLB, 0x00000000000000??)[/SIZE][/FONT]


Where the ?? is a combination of letters and numbers.

It could also read:

[FONT=Arial][SIZE=2]Name (ABLB, 0x??)[/SIZE][/FONT]
OK If you have gotten this far let me ask you what your sound issues are?

If you go to System Preferences > Sound > Output and you are NOT getting ANY sound output devices. We will try to fix this in a second.

If you are getting a few outputs including Internal Speaker. You are good… plug headphones or speakers to the green output at the rear of your case, select “Internal Speakers” as your output device and test the sound. It should work. If it does not work, or you are NOT getting any output devices; here is the fix.

Back in editing your DSDT.dsl file, on the ABLN line you should change it to read like this:

[FONT=Arial][SIZE=2]Name (ABLB, 0x4F)[/SIZE][/FONT]
This is commonly referred known as ABLN=0x4F or ABLN keyword 0x4F.

If the original file already read as 0x4F and it did not work, there may be issues with your motherboard or you are not using a motherboard with the ALC889a audio chipset. I cannot help you further.

OK, so now you have changed your ABLN keyword. We need to recompile the dsdt.dsl file back into a dsdt.aml file. After saving the dsl file in TextEdit, drag the file dsdt.dsl file again to the iaslMe icon on your desktop. This should recompile the file. In the text screen, at the end of the process, there should be a line reading “Compilation complete, 0 Errors, x Warnings, y Remarks, z Optimizations “ The key is having zero errors. If you have any errors, something went wrong… I would advice repeating the whole procedure and carefully editing the file.

If you got zero errors lets continue.

In the folder where your dsdt is, you should copy the orginal dsdt.aml file to a backup location. Now there should be a new folder called Sessions, in that folder there will a folder named with the current date and time. Inside this folder you will have a new DSDT.aml file. Copy this file to /Extra.

Reboot and lets see if you get sound… again in System Preferences . Sound > Output, Internal Speaker, you should have sound coming out of the rear green plug of your computer. If you do… great. If you don’t, something is wrong and I cannot help any further. Double check all the steps and try again.

If you get sound out of the rear speakers, but you are NOT getting sound from the front plug of your case, where you would typically plug headphones, you need to first ensure that the front speaker port is properly plugged from your case to the motherboard. Sometimes these cables come with 2 plugs on the same wire… while I cannot recall how the plugged is labeled, in my case, it is the second plug on the cable that works (not the plug at the end of the cable).

If your cable is plugged correctly and you are getting rear sound, it is still very likely you are not getting sound from headphones plug. Verify and then follow my guide on the following post… it does require editing the dsdt file again, and I hope that by now you know how to do this. Note that you ONLY have to change the values I highlighted in red… not the while section. And you will ALSO need to copy the kext in my post to /E/E. /E/E is commonly used to refer to the /Extra/Extensions folder and /E is the /Extra folder.

Please note that if you have an Extensions.mkext file in /E, AND YOU HAVE AN EXTENSIONS FOLDER, you can safely delete this file (or copy to a backup location and delete). If you used the Lifehacker guide, it ONLY includes and Extensions.mkext file (aka ‘mkext”) and no Extensions folder. The mkext file contains all the kexts that would be stored in /E/E. The system will automatically ignore the files in /E/E if there is an mkext. If there is no mkext, the system will read /E/E. You can extract and create mkexts using Kext Utility (Google it). But I have not had any luck extracting files in the mkext from Lifehacker package. If you are using Lifehacker, do your best trying to extract the kexts… someone else may be able to advice best way to do this. Once yu have all the kexts in /E/E copy the kext in my post to /E/E.

If you have gotten to this point without problems, reboot without anything plugged to headphones port. Once system is up, plug the heaphones and see if sound comes out of headphones. Sound should get autoswitched from front to rear when it detects plugged headphones. If sound comes out from rear when headphones are plugged in, try to manually change System Preferences > Sound > Output to earphones… and test.

Here is my post http://www.efixusers...hread.php?t=213

I do not have microphones and have no way to test if any of these work.

I all else fails, there are these cheap USB sound adapters that work quite nicely…. They have become so popular that their price has actually gone up.

http://www.newegg.co...N82E16812186046

Bootloader Screen - Issues
Symptoms: How do I change the default boot drive in bootloader? Or... I am getting "Mach kernel not found message"

This will fix both issues.

To change your Chameleon default drive, when at bootloader screen (where you see all the drives), hit the Tab key. You will see a text screen, with a hd(?,?) number preceding the Volume name of your choice. Note this value and enter it in your boot.plist under:

<key>Default Partition </key>
<string>hd(?,?)</string>

Where ? will be unique numbers.
Mobo: Gygabyte EP45-UD3p
Video: nVidia 9800 GTX+
DVD: LG something
RAM: 6 GB mixed brands
HDD: About 8 of them all SATA
CPU: Intel Core 2 Quad Q9650 3.0GHz

#4
elmangomez

elmangomez

    Expert Member

  • Members
  • PipPipPipPipPip
  • 519 posts
Video Addendum No. 1
Symptoms: You tried GraphicsEnabler=yes and you are not hardware accelerated.

You have to basically set your ABLN keyword to 0x4F. I describe the process how to do this very clearly at the Sound Section on post #3 above. Follow this process and reboot with GraphicsEnabler=y. If this does not give you multiple resolutions or you are not hardware accelerated (check with Cinebench). Then return to the Video section and continue with adding an EFI string to your boot.plist.



Mobo: Gygabyte EP45-UD3p
Video: nVidia 9800 GTX+
DVD: LG something
RAM: 6 GB mixed brands
HDD: About 8 of them all SATA
CPU: Intel Core 2 Quad Q9650 3.0GHz

#5
DiRTDOG

DiRTDOG

    Member

  • Members
  • PipPip
  • 33 posts
Thank you! I wish it had a pdf version so I can print it out. :P

#6
richiem

richiem

    Expert Member

  • Members
  • PipPipPipPipPip
  • 545 posts
Please note the "ABLB" typos in elmangomez's code boxes shown above -- do not change ABLN to ABLB, continue to use ABLN, not ABLB. Otherwise, this tutorial is "da bomb."
MB: Giga-Byte EP45-UD3R, rev 1.1 (F12)
CPU: Intel E6750 2.67GHz C2D
Boot: Asere v1.1.9, USB
OS: SL 10.6.8
RAM: 4GB G.Skill 1066MHz DDR2
HDs: SATA-2; using IcyDock sled
Gfx: ASUS GeForce GT 220/1GB
Cinebench R10 OpenGL=5822
DVD1: LG 18X SATA
DVD2: Toshiba/Samsung 18X SATA
LAN: en(0) - On-board Realtek 8168C
en(1) - TP_Link TG-3269 gigabit PCI card, woob
Wi-Fi: NewerTech USB 2.0 g/b adapter, driver
for SL from Realtek
Firewire: On-board FW400
Case: Broadway 939 w/ 550W PS

#7
Eryx

Eryx

    Junior Member

  • Members
  • Pip
  • 1 posts
Might be a totally unnecessary question but I'm having trouble with this. The screen turning blue thing happened to me. I can hear the music from the welcome playing but I can't see anything. So I need to put it to sleep and then back to life. The thing is... The keyboard shortcut to sleep on Macs are Option + Command + Eject.

The Windows logo thingy is Command, Alt is Option, but where is the Eject key?

#8
hunt7000

hunt7000

    Junior Member

  • Members
  • Pip
  • 4 posts
Hi there ,
i have some problems to understand some of the steps in AsereBLN’s blog
as you can see in the picture :
first of all i don't understand which snow leopard installation DVDs version i have to download because i searched for a torrent and i found out that there is a lot of versions and a lot of extensions like .iso , .dmg and there is retail DVD and also different sizes of the file ... so i don't understand which one should i get
second thing that if there is a newer version of chameleon will that work or should i use this specific version
third thing about the support files will that work fol all computers (in my case my asus g74sx-a1 laptop)
last thing is about the DSDT .. where should i get that ???
that's all for now ... please help me with this ... i have sent a massage to asere and he didn't reply also i made a thread in the the General Troubleshooting section in the forum and with no answer also ... so please help me with this ... thanks :)

Attached Files


Laptop : ASUS G74SX-A1
Currant OS: Windows 7 home premium 64-bit
CPU : Intel Core i7 2630QM 2.0 GHz Turbo boost 2.9 GHz
GPU : NVIDIA GeForce GTX560M 3 GB V-RAM
Memory : 12 GB of RAM
Hard Drives : two*750 GB hard drive




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users