Jump to content


Always up to date!

Do you want to be kept up to date with new versions of files and / or news? Follow us on Twitter and Facebook! Make sure you are updated with new file versions!

Photo

lion os x x3100 graphics opengl working perfect

- - - - - 10.7 intel lion opengl x3100

  • Please log in to reply
50 replies to this topic

#1
delgadilloalex

delgadilloalex

    OSx86.net Crew

  • Local Moderators
  • PipPipPipPipPip
  • 405 posts
i was having trouble with open gl in lion on gma965 but i got it working perfect.

make sure you have not touched/modded original kexts in sys/lib/ext any intel graphics kext if so i suggest
fresh install of lion and this solution

here is a solution for anyone having trouble take the AppleIntelGMAX3100FB.kext from any snow leo install s/l/e and overwrite/install it on lion s/l/e use

kext wizard. attached is mine from snowleo it worked for me so try it


the original lion AppleIntelGMAX3100FB.kext. save it if you like but not necessary

repair perm after with kext wizard reboot with boot flags: arch=i386 -v (so your 32bit)

then should work perf accelerated graphics,dvd,perfect

Attached Files


Edited by delgadilloalex, 14 August 2011 - 07:36 AM.


#2
artystate

artystate

    Junior Member

  • Members
  • Pip
  • 5 posts
Hello

I am a lion user on Toshiba L300.
I've tried your method, step by step, after restarting I get a white display with vertical stripes.
I can hear the sound using keybord but I can't pass the blocked screen.

I've also tried with leopard - works with his drivers.
I've tried with snow leopard - same error as in lion.
I get same white screen with original drivers (snow leopard or lion) or replacing AppleIntelGMAX3100FB.kext. I've tried all others drivers from osx86 download section

Can I get some help?
Thank you.

#3
delgadilloalex

delgadilloalex

    OSx86.net Crew

  • Local Moderators
  • PipPipPipPipPip
  • 405 posts
take out your dsdt if your using one. boot flags;
arch=i386 -f -v

also take out your natit.kext

Edited by delgadilloalex, 18 November 2011 - 07:38 PM.

Lion 10.7.4/10.8(<>)( 10.8.0 dp4 / Lion 10.7.2 x32
GA-Z68XP-UD3><> Gateway T-6816 Notebook
Intel i5 2500K> 16GB RAM 1600 DDR3 ()(<>)( Intel® GM965/Chipset
GeForce 9500 GT 1GB <> 4 GB DDR2
BCM 4322
Protools 9 /Cubase 6.5<> Intel® Graphics Media Accelerator X3100
MOTU 828MK2 firewire audio interface®>

#4
artystate

artystate

    Junior Member

  • Members
  • Pip
  • 5 posts
I booted with those flags: display out of range...
I've deleted natit.kext. I don't know what is dsdt and where is located, I don't know if I use one.

If I boot with flag "GraphicsEnabler=No" I have 1280x800 res but QE/CI is disabled.

Thank you for help.

Edited by artystate, 18 November 2011 - 07:58 PM.


#5
delgadilloalex

delgadilloalex

    OSx86.net Crew

  • Local Moderators
  • PipPipPipPipPip
  • 405 posts
install all the kext from this link with kext wizard to sys/lib/extensions then repair all permisions with kext wizard
http://www.osx86.net...ma965_lion.html
your dsdt should be in 0 sector of hdd or in your volumes/extra folder if not there don't worry . boot flags. arch=i386 -v -f

sorry forgot the link http://www.osx86.net...ma965_lion.html

Edited by delgadilloalex, 18 November 2011 - 08:34 PM.

Lion 10.7.4/10.8(<>)( 10.8.0 dp4 / Lion 10.7.2 x32
GA-Z68XP-UD3><> Gateway T-6816 Notebook
Intel i5 2500K> 16GB RAM 1600 DDR3 ()(<>)( Intel® GM965/Chipset
GeForce 9500 GT 1GB <> 4 GB DDR2
BCM 4322
Protools 9 /Cubase 6.5<> Intel® Graphics Media Accelerator X3100
MOTU 828MK2 firewire audio interface®>

#6
artystate

artystate

    Junior Member

  • Members
  • Pip
  • 5 posts
I finally made it.

I boot with: arch=i386 -v GraphicsEnabler=No
I have 1280x800 res and QE/CI enabled. I've tested with UberStrike (3d shooter game), youtube, playing movies in VLC.

I was trying about a week and no result. After booting with arch=i386 flag always I got an out of range display. It seems that adding flag GraphicsEnabler=No for me helped.
Of course, I used your drivers from above link :)

THANK YOU

Edited by artystate, 18 November 2011 - 09:10 PM.


#7
delgadilloalex

delgadilloalex

    OSx86.net Crew

  • Local Moderators
  • PipPipPipPipPip
  • 405 posts
awesome enjoy.
Lion 10.7.4/10.8(<>)( 10.8.0 dp4 / Lion 10.7.2 x32
GA-Z68XP-UD3><> Gateway T-6816 Notebook
Intel i5 2500K> 16GB RAM 1600 DDR3 ()(<>)( Intel® GM965/Chipset
GeForce 9500 GT 1GB <> 4 GB DDR2
BCM 4322
Protools 9 /Cubase 6.5<> Intel® Graphics Media Accelerator X3100
MOTU 828MK2 firewire audio interface®>

#8
madalone

madalone

    Junior Member

  • Members
  • Pip
  • 7 posts
Hello,

I have a Fujitsi Siemens t4220 with an x3100. I installed the kexts in x3100 drivers.zip with kext wizard, repaired the permissions and booted with arch=i386 -v GraphicsEnabler=No and get lines on the display. I've also tried arch=i386 -v -f with the same results. I don't have natit.kext in my Extensions folder so I can't delete it.

I'm running iAtkos L2.

Are the kexts in x3100 drivers.zip enough or do I have to install the kexts in AppleIntelGMAX3100FB.kext.zip and AppleIntelIntegratedFramebuffer.kext.zip too? As far as I can understand AppleIntelGMAX3100FB.kext.zip contains the original file. Is that right or do I have to install that one too? Is installing the kext in AppleIntelIntegratedFramebuffer.kext.zip useful too? I've reinstalled what it like seems a million times..good thing I like taking on sisyphean tasks..
Any idea what I'm doing wrong?

Thanks in advance.

Video Info:

Chipset Model: GMAX3100
Type: GPU
Bus: Built-In
VRAM (Total): 64 MB of Shared System Memory
Vendor: Intel (0x8086)
Device ID: 0x2a02
Revision ID: 0x0003
Kernel Extension Info: No Kext Loaded
Displays:
Display:
Resolution: 1024 x 768
Pixel Depth: 32-Bit Color (ARGB8888)
Main Display: Yes
Mirror: Off
Online: Yes

Edited by madalone, 09 December 2011 - 12:56 AM.


#9
delgadilloalex

delgadilloalex

    OSx86.net Crew

  • Local Moderators
  • PipPipPipPipPip
  • 405 posts
install all (not just the two, unzip) drivers and kext

same flags
also i sugest a retail lion modusb not a mod distro (iatkosl2) they some times have issues and i've never used them with lion
but try all the kext i think theres 5 or 6 kext drivers to install just drop to wizard and repair all

and its no prob hit me up anytime if it dont work
Lion 10.7.4/10.8(<>)( 10.8.0 dp4 / Lion 10.7.2 x32
GA-Z68XP-UD3><> Gateway T-6816 Notebook
Intel i5 2500K> 16GB RAM 1600 DDR3 ()(<>)( Intel® GM965/Chipset
GeForce 9500 GT 1GB <> 4 GB DDR2
BCM 4322
Protools 9 /Cubase 6.5<> Intel® Graphics Media Accelerator X3100
MOTU 828MK2 firewire audio interface®>

#10
madalone

madalone

    Junior Member

  • Members
  • Pip
  • 7 posts
Thanks for the quick response. Will a retail version of Lion work with my machine? I don't have a mac..Anyway, I've tried a usb retail Lion version and it crashes as soon as I select it from the bootmenu..I've tried with -x -f -F just to see if there would be any difference but no dice..is there any way I can extract the kexts from the installation image?

Edited by madalone, 09 December 2011 - 11:39 AM.


#11
madalone

madalone

    Junior Member

  • Members
  • Pip
  • 7 posts
I followed the instructions on tonymacx86 Blog: UniBeast: Install Mac OS X Lion Using an All-In-One Bootable USB Drive and created a USB Lion installation, installed it but when booting into my freshly installed OS I get a kernel panic and I'm unable to boot into the OS no matter what boot flags I try..so now I'm back to iATKOS..

Also should I repair and rebuild cache or only repair?

Edited by madalone, 09 December 2011 - 02:12 PM.


#12
madalone

madalone

    Junior Member

  • Members
  • Pip
  • 7 posts
So I installed Lion Retail on an external HD, installed the retail kexts with kext wizard on to my iATKOS installation, repaired permissions and rebuilt cache. Then I installed your drivers, repaired permissions, rebuilt cache and booted with -v arch=i386 GraphicsEnabler=No to get the same results..corrupted video.. I've tried with and without the AppleIntelIntegratedFramebuffer.kext you provided.. :( what in the hell am I doing wrong? I got this working once..after reinstalling a bunch of times and over 24 hours of no sleep so I can't remember what I did.. I've also tried with repair and rebuild cache, repair without rebuild cache to no avail..please help..

Edited by madalone, 09 December 2011 - 02:33 PM.


#13
delgadilloalex

delgadilloalex

    OSx86.net Crew

  • Local Moderators
  • PipPipPipPipPip
  • 405 posts
simplest way to put it is download all from here http://www.osx86.net...ma965_lion.html

unzip all and put contents of all on desktop open kext wizard and drag all kext and drivers to wizard kext installation
these are what you should install from download
all of them
AppleIntelIntegratedFramebuffer.kext
AppleIntelGMAX3100.kext
AppleIntelGMAX3100FB.kext
AppleIntelGMAX3100GA.plugin
AppleIntelGMAX3100GLDriver.bundle
AppleIntelGMAX3100VADriver.bundle
make sure u unzip all files
install and repair
reboot
arch=i386 -v -f
Lion 10.7.4/10.8(<>)( 10.8.0 dp4 / Lion 10.7.2 x32
GA-Z68XP-UD3><> Gateway T-6816 Notebook
Intel i5 2500K> 16GB RAM 1600 DDR3 ()(<>)( Intel® GM965/Chipset
GeForce 9500 GT 1GB <> 4 GB DDR2
BCM 4322
Protools 9 /Cubase 6.5<> Intel® Graphics Media Accelerator X3100
MOTU 828MK2 firewire audio interface®>

#14
madalone

madalone

    Junior Member

  • Members
  • Pip
  • 7 posts
Alright, do I have to keep booting with arch=i386 -v and -f or do I have to use -f just once? And no GraphicsEnabler=No?

I followed your instructions, then I booted with arch=i386 -v -f. No dice. I tried arch=i386 -v -f GraphicsEnabler=No "Graphics Mode"="1024x768x32" and got the same corrupted video..could it be the refresh rate of the display?

At this point I'm clueless..should I do something with DSTD I dunno..just saying.. :/

And by the way, thanks for your support :)

Edited by madalone, 10 December 2011 - 12:29 AM.


#15
delgadilloalex

delgadilloalex

    OSx86.net Crew

  • Local Moderators
  • PipPipPipPipPip
  • 405 posts
-f to force load kext
-v is for vubrose to see the boot script while booting

boot with flags on every time you make a change in your kexts cache to make sure it loads changes ; -f
after u got it you only need arch=i386

make sure your installing kext to system/library/extensions not extra/extensions

tip.
go to hdd system/library/extensions and find the kext your going to overwrite
witch r
AppleIntelIntegratedFramebuffer.kext
AppleIntelGMAX3100.kext
AppleIntelGMAX3100FB.kext
AppleIntelGMAX3100GA.plugin
AppleIntelGMAX3100GLDriver.bundle
AppleIntelGMAX3100VADriver.bundle

and delete them now install downloaded kext go back
and make sure there installed into the folder
also erase any graphics kext in extra/extensions

if that doesn't work reinstall iatkos in the customize section make sure u uncheck any graphics installs so it doesn't mess up the retail kexts.

Edited by delgadilloalex, 10 December 2011 - 03:57 AM.

Lion 10.7.4/10.8(<>)( 10.8.0 dp4 / Lion 10.7.2 x32
GA-Z68XP-UD3><> Gateway T-6816 Notebook
Intel i5 2500K> 16GB RAM 1600 DDR3 ()(<>)( Intel® GM965/Chipset
GeForce 9500 GT 1GB <> 4 GB DDR2
BCM 4322
Protools 9 /Cubase 6.5<> Intel® Graphics Media Accelerator X3100
MOTU 828MK2 firewire audio interface®>

#16
madalone

madalone

    Junior Member

  • Members
  • Pip
  • 7 posts
Ok, I'm deleting the kexts in s/l/e and installing them with kext wizard.
If I reinstall iATKOS, do I have to format the drive or can I just reinstall without reformatting?
I didn't select any graphic drivers when I installed iATKOS and the kexts are installed in s/l/e. In Extra/modules I do see Resolution.dylib, further I don't see any kexts there. do I have to delete Resolution.dylib?

And once again, thanks for the quick response ^_^

do I have to keep booting with arch=i386 -v -f until it works? I've booted with arch=i386 -v -f over ten times now with no difference.. :/

Edited by madalone, 10 December 2011 - 01:46 AM.


#17
delgadilloalex

delgadilloalex

    OSx86.net Crew

  • Local Moderators
  • PipPipPipPipPip
  • 405 posts
boot with flags once or twice if doesnt work then it didnt work

when u reinstall try the way i did http://www.osx86.net...to__nawcom.html

retail lion is needed usb flash-drive or sd card 8gb and a package maker like the one i gave you or kakewalk or tonymacx86 Blog: UniBeast: Install Mac OS X Lion Using an All-In-One Bootable USB Drive

Edited by delgadilloalex, 10 December 2011 - 04:03 AM.

Lion 10.7.4/10.8(<>)( 10.8.0 dp4 / Lion 10.7.2 x32
GA-Z68XP-UD3><> Gateway T-6816 Notebook
Intel i5 2500K> 16GB RAM 1600 DDR3 ()(<>)( Intel® GM965/Chipset
GeForce 9500 GT 1GB <> 4 GB DDR2
BCM 4322
Protools 9 /Cubase 6.5<> Intel® Graphics Media Accelerator X3100
MOTU 828MK2 firewire audio interface®>

#18
delgadilloalex

delgadilloalex

    OSx86.net Crew

  • Local Moderators
  • PipPipPipPipPip
  • 405 posts
post you com.apple.boot.plist or org.chameleon.Boot.plist
Lion 10.7.4/10.8(<>)( 10.8.0 dp4 / Lion 10.7.2 x32
GA-Z68XP-UD3><> Gateway T-6816 Notebook
Intel i5 2500K> 16GB RAM 1600 DDR3 ()(<>)( Intel® GM965/Chipset
GeForce 9500 GT 1GB <> 4 GB DDR2
BCM 4322
Protools 9 /Cubase 6.5<> Intel® Graphics Media Accelerator X3100
MOTU 828MK2 firewire audio interface®>

#19
riannugrahaa

riannugrahaa

    Junior Member

  • Members
  • Pip
  • 3 posts
anyone can you help me i just installed lion 10.7.2 on my acer aspire that hace GL965 and x3100 but when i boot into arch=i386 my monitor got this Posted Image
anyone please help me i'm very need this hackintosh

#20
delgadilloalex

delgadilloalex

    OSx86.net Crew

  • Local Moderators
  • PipPipPipPipPip
  • 405 posts
i have not tested with 10.7.2

will try soon
Lion 10.7.4/10.8(<>)( 10.8.0 dp4 / Lion 10.7.2 x32
GA-Z68XP-UD3><> Gateway T-6816 Notebook
Intel i5 2500K> 16GB RAM 1600 DDR3 ()(<>)( Intel® GM965/Chipset
GeForce 9500 GT 1GB <> 4 GB DDR2
BCM 4322
Protools 9 /Cubase 6.5<> Intel® Graphics Media Accelerator X3100
MOTU 828MK2 firewire audio interface®>





Also tagged with one or more of these keywords: 10.7, intel, lion, opengl, x3100

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users