Jump to content

VoodooHDA 2.8.8 pkg installer 1.0

1 Screenshot

About This File

2015.09.10. Update pkg with 2.8.8

http://sourceforge.net/projects/voodoohda/files/

2014.10.10. Update pkg with 2.8.7

http://www.projectosx.com/forum/index.php?showtopic=355

2014.07.18. Update pkg with 2.8.6

http://sourceforge.net/projects/voodoohda/files/

2013.07.03. Update pkg with 2.8.4 Lion compilation if previous doesn't work.

VoodooHDA v2.8.4 Come from Slice 08.06.2013.

http://www.applelife.ru/threads/%D0%94%D0%B5%D0%BB%D0%B0%D0%B5%D0%BC-%D0%97%D0%B2%D1%83%D0%BA-%D0%9D%D0%B0-%D0%9E%D1%81%D0%BD%D0%BE%D0%B2%D0%B5-voodoohda.18413/

http://www.projectosx.com/forum/index.php?showtopic=355

2013-01-26 VoodooHDA v2.8.2

2013-01-04 VoodooHDA v2.8.0 Fixed bugs that make the work with the two devices. (r75)

2012-08-08 VoodooHDA v2.7.4 with AC3 support, HDMI prevents analog. (r63)

2012-05-17 VoodooHDA v2.7.4 with AC3 support. (r60)

2011-08-09 VoodooHDA v2.7.3 with Mute Fix. (r58)

VoodooHDA v2.7.2 (r57)

Source code : http://sourceforge.net/p/voodoohda/code/ .

You may need to add flag to /Extra/org.chameleon.Boot.plist since Chameleon r1957.

Inject HDMI audio for NVIDIA or AMD/ATI.

EnableHDMIAudio

Yes

And follow the Tricks for HDMI output on Video card.

http://www.projectosx.com/forum/index.php?showtopic=355

2.8.2 pkg will auto install the following....

/Applications/VoodooHdaSettingsLoader.app 1.2

/System/Library/Extensions/AppleHDADisabler.kext 1.0.1

/System/Library/Extensions/VoodooHDA.kext 2.8.2

/System/Library/PreferencePanes/VoodooHDA.prefPane 1.2

/usr/local/bin/getdump

And backup to /Backup Extensions/AppleHDA.kext.

Save settings of VoodooHDA.prefPane by adding /Applications/VoodooHdaSettingsLoader.app to Login Items manually as below.

VoodooHDASettings.gif

And ....

If VoodooHDA doesn't work, try to make VoodooHDA.kext/Contents/info.plist as below, and rebuild kernelcache.

IOPCIClassMatch

0x284b8086place here deviceID of your sound card (Chipset HDA device, not a codecID!)

or

IOPCIClassMatch

0x04030000&0xffff0000

IOPCIPrimaryMatchadd two lines.

0x284b8086 add deviceID of your sound card (Chipset HDA device, not a codecID!)

You may need to increase the value of "Input Gain" from VoodooHDA.prefPane to hear the sound of speaker.

VoodooHDA.gif

VoodooHDA2.gif


What's New in Version 1.0   See changelog

Released

No changelog available for this version.




User Feedback



Recommended Comments

@mahkoooo4455, you may need to increase the value of "input Gain" to hear the speaker from VoodooHDA.prefPane.

Share this comment


Link to comment
Share on other sites

VoodooHDA-v2.7.4 Not working on ALC662 N10 /ICH7 Family High Definition Audio Dev ID:0x27d88086

Share this comment


Link to comment
Share on other sites

@ace1, try to make VoodooHDA.kext/Contents/info.plist as below, and rebuild kernelcache.

IOPCIClassMatch

0x27d88086

place here deviceID of your sound card (Chipset HDA device, not a codecID!)

Share this comment


Link to comment
Share on other sites

@gaiels, Use PlistEdit Pro or copy kext to ~/Desktop and re-install kext to S/L/E after modified.

Share this comment


Link to comment
Share on other sites

wow, grreat, it works on my dell adamo 13.now, i have lio 7.4 with everything working like macbook air.

Share this comment


Link to comment
Share on other sites

this works for me on Medion PC with ASUS P5K31-VM/S (N10/ICH7 Family High Definition Audio)

Just added the lines below in VoodooHDA.kext/Contents/info.plist and rebuild system kext caches using Kext Wizard. The guide above is really useful. Now, I'm currently running Mac OS 10.8.0, Mountain Lion GM. THANK YOU SO MUCH!

IOPCIMatch

0x27d88086

Share this comment


Link to comment
Share on other sites

does not work for me: Mountain Lion, GA-Z77M-D3H (VT2021), Voodoo2.7.4.

Getting KP on boot when unmodded.

Modding libraries to 12.0 gets rid of the KP, but does not load the VoodooHDA Driver: link error - (error 0xdc008016).

What am I doing wrong? Is there a fix?

Share this comment


Link to comment
Share on other sites

Got the same problem like @clickmikes with GA-Z77-D3H (VT2021) Any solution?

Share this comment


Link to comment
Share on other sites

Worked like a charm for my nForce 650i SLI motherboard Mountain Lion 10.8

Automatically !!!!!

Share this comment


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×