Jump to content

GMA X/4500/M/MHD/HD +64 bit kext 1.1


1 Screenshot

About This File

--UPDATE MAY 19th--

the project john was working on was cancelled...

--UPDATE APR 29th--

just thought i would share the news here but on this page John has finally got QE/CI working on GMA 4500M, when the driver will be released idk but i will help him make a 64 bit driver of this as i am on mountain lion and i was getting pretty close myself but i couldn't figure it out so maybe with his knowledge of the driver and mine of the 64 bit kext we can finally have a fully supported up-to-date system!

---2013---

--UPDATE APR 7th---

for those of you who are having problems with brightness on your computer's go here and follow the directions.it worked for me smile.png

---2012---

--UPDATE SEPT 16th--

been looking at the comments and certain IGP's of GMA 4500 work fine others need fixes (DSDT) to work properly...

Does not work for desktops! :Intel G41 (GMA X4500) in tablets/desktops should work fine and may enable QE/CI

Intel GM45 (GMA 4500MHD) in laptops/tablets work fine need backlight fix

seems not to work for Q chipsets

Intel GS45 (GMA 4500MHD)seems unstable...

Intel GL40 works flawlessly (my chipset wink.png )

working on more info will update shortly wink.png

--UPDATE SEPT 15th--

hello everyone i am back from a long needed vacation smile.png

ok... well back to business

only thing that's different is.. im on windows.... and i haven't had many/any problems :/ guess i was wrong windows 7 is fine

now heres one reason i have windows.. im a gamer and recently lost one of my console's :'(

but ill try to help the best i can ok guys? smile.png and yes if your guessing i highly doubt QE/CI will ever be supported....but we may figure it out wink.png

--UPDATE AUG 2nd--

10.8 does support the 64 bit kexts :cool:

---IMPORTANT UPDATE JULY 12th---

From this point on this page will be used to inform updates,

i have included a READ ME and other things

---UPDATE JULY 10th---

i put in the smbios i forgot to put in *my bad* but otherwise enjoy biggrin.png

---UPDATE JULY 9th---

i included dynamic kexts for your specific device id so u don't have to patch on your own (this took me an hour wink.png )

if u have a unlisted device message me and ill include it, they are in both 32 bit and 64 bit architecture so support for mountain lion

removed a few unnecessary files

---UPDATE JULY 8th---

Quartz Debug settings for performance: QE Enabled,QGL Enabled,BeamSync Disabled/OFF

macbook 4,1 smbios for better performance

voodoopowermini needed for macbook 4,1 smbios speedstep ill include it

plus with VPM you can set p-state limits when on ac/battery/and low battery in the info.plist

---UPDATE JULY 7th---

fixed unmodified kext and updated 2E32 DEV ID kext

---UPDATE JULY 3rd---

updated 32 bit kexts to 6.3.6 made september 2011

included unmodified kext incase someone has a unincluded kext for there dev id (which i could put in if u told me the dev ids wink.png )

less lag and more stable wink.png

no full QE/CI until the non FB kext works or someone makes a new kext (who knows it could be me wink.png )

---UPDATE JULY 1st---

software QE works i use quartz debug ill include it but be warned the CPU has limits!!

added kext for 2E32 device id wink.png

fixed kexts info.plist so theres no need to add dev ids wink.png but still patch them with the bash wink.png

---UPDATE JUNE 28th---

users with 2A42 use 2A42AppleIntelGMAX3100FB.kext if you get this line in verbose boot

IG: Invalid firmware max backlight setting or it don't work first time use GraphicsEnabler in chameleon then if u get both

IG: Invalid firmware max backlight setting

IG: Invalid firmware backlight level setting, your display should work;)

included system info you should know what to do with that wink.png


What's New in Version 1.1   See changelog

Released

No changelog available for this version.




User Feedback

Recommended Comments



@shebang i wouldn't share this with you if it was fake if anyone has problems or needs help i can make one specifically for there device i also recommend trying different chameleon boot options like graphics enabler,usb fixes,graphics mode even;)

Share this comment


Link to comment
Share on other sites

@masichigo use the 2A42 kext and read update that one is specific for 2A42 users but i meant all video kexts mine are 2A42 VGA Compatible 2A43 Display Controller so i put that in the info.plist so i can see the display, and 2A40 VRAM Hub Controller so this is for the non-FB kext but we can't use that so :/

i got this info using the system info app its not about this mac its an app ill include i guess if that many ppl don't have it

Share this comment


Link to comment
Share on other sites

@nanael well the non-FB kext triggers hardware acceleration and when i try to load it my computer freezes on gray screen so if anyone else can help me trigger it then that would be great for the rest of us =)

Share this comment


Link to comment
Share on other sites

thx for your work!

i try the GMA4500-ALL +64 bit kext. it can enable QE/CI in my lenovo x200t, but the mouse cursor disappear. do you have the same problem?

Share this comment


Link to comment
Share on other sites

hi macos665

i try the kext with 64bit deviceid=2A42 on Lion 10.7.0. i use root account to copy 64bit kext to S/L/E folder, after reboot mouse cursor disappear. if i use native resulotion (-rf) for 2A42, the ps2 and bluetooth mouse work find.

Share this comment


Link to comment
Share on other sites

i have heard problems with the mouse disappearing on think pads what you do is make the mouse really big until it reappears again mine works perfectly no QE/CI i use the 32 bit 6.2.6 version should i try the 64 bit kext with the non FB kext and see if it works? o.O

Share this comment


Link to comment
Share on other sites

@macos665 your 2A42AppleIntelGMAX3100FB.kext not work for my igma 4500m but the 64bit is work there a one problem bro its my whole screen is pixelated but i have my full resolution, can you fix it bro?

Share this comment


Link to comment
Share on other sites

did u use GraphicsEnabler if u did try disabling it and did u get any IG errors posted above in verbose mode?

Share this comment


Link to comment
Share on other sites

goto the chameleon prefpane in system preferences if u don't have it get it here

goto the 2761 folder and open the .prefpane install then in the prefpane goto peripherals and disable it it should be there ;)

Share this comment


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×