Jump to content

GMA X/4500/M/MHD/HD +64 bit kext 1.1


1 Screenshot

About This File

--UPDATE MAY 19th--

the project john was working on was cancelled...

--UPDATE APR 29th--

just thought i would share the news here but on this page John has finally got QE/CI working on GMA 4500M, when the driver will be released idk but i will help him make a 64 bit driver of this as i am on mountain lion and i was getting pretty close myself but i couldn't figure it out so maybe with his knowledge of the driver and mine of the 64 bit kext we can finally have a fully supported up-to-date system!

---2013---

--UPDATE APR 7th---

for those of you who are having problems with brightness on your computer's go here and follow the directions.it worked for me smile.png

---2012---

--UPDATE SEPT 16th--

been looking at the comments and certain IGP's of GMA 4500 work fine others need fixes (DSDT) to work properly...

Does not work for desktops! :Intel G41 (GMA X4500) in tablets/desktops should work fine and may enable QE/CI

Intel GM45 (GMA 4500MHD) in laptops/tablets work fine need backlight fix

seems not to work for Q chipsets

Intel GS45 (GMA 4500MHD)seems unstable...

Intel GL40 works flawlessly (my chipset wink.png )

working on more info will update shortly wink.png

--UPDATE SEPT 15th--

hello everyone i am back from a long needed vacation smile.png

ok... well back to business

only thing that's different is.. im on windows.... and i haven't had many/any problems :/ guess i was wrong windows 7 is fine

now heres one reason i have windows.. im a gamer and recently lost one of my console's :'(

but ill try to help the best i can ok guys? smile.png and yes if your guessing i highly doubt QE/CI will ever be supported....but we may figure it out wink.png

--UPDATE AUG 2nd--

10.8 does support the 64 bit kexts :cool:

---IMPORTANT UPDATE JULY 12th---

From this point on this page will be used to inform updates,

i have included a READ ME and other things

---UPDATE JULY 10th---

i put in the smbios i forgot to put in *my bad* but otherwise enjoy biggrin.png

---UPDATE JULY 9th---

i included dynamic kexts for your specific device id so u don't have to patch on your own (this took me an hour wink.png )

if u have a unlisted device message me and ill include it, they are in both 32 bit and 64 bit architecture so support for mountain lion

removed a few unnecessary files

---UPDATE JULY 8th---

Quartz Debug settings for performance: QE Enabled,QGL Enabled,BeamSync Disabled/OFF

macbook 4,1 smbios for better performance

voodoopowermini needed for macbook 4,1 smbios speedstep ill include it

plus with VPM you can set p-state limits when on ac/battery/and low battery in the info.plist

---UPDATE JULY 7th---

fixed unmodified kext and updated 2E32 DEV ID kext

---UPDATE JULY 3rd---

updated 32 bit kexts to 6.3.6 made september 2011

included unmodified kext incase someone has a unincluded kext for there dev id (which i could put in if u told me the dev ids wink.png )

less lag and more stable wink.png

no full QE/CI until the non FB kext works or someone makes a new kext (who knows it could be me wink.png )

---UPDATE JULY 1st---

software QE works i use quartz debug ill include it but be warned the CPU has limits!!

added kext for 2E32 device id wink.png

fixed kexts info.plist so theres no need to add dev ids wink.png but still patch them with the bash wink.png

---UPDATE JUNE 28th---

users with 2A42 use 2A42AppleIntelGMAX3100FB.kext if you get this line in verbose boot

IG: Invalid firmware max backlight setting or it don't work first time use GraphicsEnabler in chameleon then if u get both

IG: Invalid firmware max backlight setting

IG: Invalid firmware backlight level setting, your display should work;)

included system info you should know what to do with that wink.png


What's New in Version 1.1   See changelog

Released

No changelog available for this version.




User Feedback

Recommended Comments



now I noticed that after installing the kext with Kext Wisard I can't see in in "Loaded" tab. Am I missing something?

Share this comment


Link to comment
Share on other sites

hey i have dell inspiron n 5010 Intel HD driver in windows 7 pls recommend the correct kexts .. i installed N{censored}12495 lion 10.7.3 v2 1024*768*32 rs only!!! :( please i want good resolution... plzzzz

Share this comment


Link to comment
Share on other sites

Ok I have installed the laptop Kexts and put smbios in the extra folder. If i boot in 32bit mode i get the white screen only. If i boot in 64bit mode I get no kext loaded and only 1024 x 768 resolution.

I can get full screen options with another kext but without qe/ci support Below is what i see in 64bit mode.

Type: GPU

Bus: Built-In

VRAM (Total): 64 MB of Shared System Memory

Vendor: Intel (0x8086)

Device ID: 0x2a42

Revision ID: 0x0009

Kernel Extension Info: No Kext Loaded

Displays:

Display:

Resolution: 1024 x 768

Pixel Depth: 32-Bit Color (ARGB8888)

Main Display: Yes

Mirror: Off

Online: Yes

Please help any suggestions????

Share this comment


Link to comment
Share on other sites

IT WORKS!!!

Was almost on the verge of giving up with hackintosh and was just going to buy a mac,

I have iAtkos L2 installed so running x64.

I went to System>Library>Extension and deleted AppleIntelGMAX3100.kext first

Opened up Kext Helper, dragged in the Laptop 2A42 kext, used easy install.

Opened up Boot Loader Pref pane (Chameleon RC5) in System Preferences, went to peripherals and disabled Graphics Enabler.

Rebooted and I have native resolution (1366x768)

The Quartz debug works perfect as I have limited bells & whistles.

For anybody having issues with flash videos like youtube, i had a black screen whenever i tried to play videos with stuttering sound. Right click inside the video and click 'Settings' uncheck the box you see that says Hardware Acceleration and everything should be fine :)

Thank you so much macos665, now I can finally get a good feel for this OS before making the big(expensive) jump to mac!!

Share this comment


Link to comment
Share on other sites

I get the following errors in my verbose boot

IG: Invalid firmware max backlight setting

IG: Invalid firmware backlight level setting

I did not quite understand your ---UPDATE JUNE 28th--- , can you please elaborate and let me know if this can be fixed

Share this comment


Link to comment
Share on other sites

@macos665: I got this G Card: G41 Express Chipset/INTEL GMA X4500. but still didn't get exactly what you mean with "ids" But I get those maybe it can help [intel (0x8086)]

Thanks For your understanding :)

Share this comment


Link to comment
Share on other sites

IG: Invalid firmware max backlight setting

and also with graphicsenabler=yes not working...any ideas? im using ML 10.8 and 2A22x64 kext

32 bit kext also doesnt work...

any ideas?

Share this comment


Link to comment
Share on other sites

Hi - new to all things Apple.

I have an HP Laptop (G71-340US) that I have been somewhat successful installing the latest ML 10.8. I have sound and WiFi working anyway. The HP ProBook 4530s setup kit does not work on this model, must be done the hard way.

It has the GMA 4500 MHD chipset, and this driver *almost* works..

Boots up but then turns my display screen OFF, but strangely turns *ON* the side VGA port. The main display backlight stays on but it is totally black.

I can move my mouse to the side and see it on the side monitor, so I know that the desktop thinks it is extended across to monitors, as opposed to mirrored. I had installed shades ahead of time (having read warnings about backlight control) and I can see the backlight slider (the only thing I can see) on the side display, and sliding it actually controls the brightness full range.

Once it loads like this, the only way to get back to safe mode is to boot from a last known good USB backup drive, then remove the kext.

I ran System Info and it says device ID 2A43 for Display and 2A42 for VGA port. I am guessing because this is patched for 2A42 that is the reason the VGA starts working and the Display shuts off?

If so, then is it possible to patch this for device ID 2A43?

Share this comment


Link to comment
Share on other sites

Hi there , I have an Acer Aspire 5732z with Mountain Lion 10.8.2, here are my device specs:

Chipset Model: GMAX3100

Type: GPU

Bus: Built-In

VRAM (Total): 64 MB of Shared System Memory

Vendor: Intel (0x8086)

Device ID: 0x2a42

Revision ID: 0x0009

Kernel Extension Info: No Kext Loaded

Displays:

Display:

Resolution: 1024 x 768

Pixel Depth: 32-Bit Color (ARGB8888)

Main Display: Yes

Mirror: Off

Online: Yes

I has tried the 64 bit drivers on the laptop folder, and used champlist to load the smbios in the folder and loaded the Vodoo kext. Once i restart i have full resolution but no backlight. Once I try to open the quartz debug application doesn't work , I can never get to the tools pannel because just doesn't open.

Any way to get the backlight fixed ???

Share this comment


Link to comment
Share on other sites

Hi, thanks for bringing out this kext. by any chance, have you came across any way to make QE/CI any better? I am on 10.7.5 with X4500 MHD (0x2a42/0x0007), everything works great except youtube and animations.

Animations like full screen and launchpad are really laggy which I have read is due to not having hardware acceleration.

I just wonder if we have came as far as we can =/.

Still great work :D

if you want me to test kexts i will :D

Chris

Share this comment


Link to comment
Share on other sites

Hi friends, thanks for more information, but I do not obtain a result I I have little experience I please your help.

I have this HP 500B MT in to office:

mac os 10.7.5

GPU

integrated

VRAM 64 ??

Intel (0x8086)

ID 0x2e32

0x0003

Kernel Extension: not loaded Kext

1280 x 1024

32-bit (ARGB8888)

I already made

Installed Chameleon 2.0.0 RC5 with resolution mod and pref panel

i use kext utility for install 2e32 and them ALL kext from Desktop directory

them i install voodoo power mini kext

in Chamelin pref panel i customize:

boot flags -v -F

Graphics mode 1280x1024

smbios file from you archive ("Default" radiobotton - not active)

in advanced Arch i386, bus ratio 20, restart fix, disable kext blacklist

Do you can help to install true kext for install 1440x900 in system configuration/display(monitor), if i use chameleon graphics mode with 1440x900 after load mac os i have NOT SUPPORTED RESOLUTION but it's recommended resolution for my display

please comprehensive instruction

Thanks!

Share this comment


Link to comment
Share on other sites

"in tablets/desktops should work fine and may enable QE/CI

Intel GM45 (GMA 4500MHD) in laptops/tablets work fine need backlight fix"

but not working on my vostro 1320. (SL 64-bit 10.6.8) -

over two long years viva deviato? method .:eagerness:

and man! who say that he suxesfully syxeeded with QE/CI :abnormal:

or so y u piss our minds with such the foolish fake???

Share this comment


Link to comment
Share on other sites

What do I gain by using this kext?? I used graphics enabler in chameleon and immediately got native res.. what else does it do good for me for??

Share this comment


Link to comment
Share on other sites

iv tryed to install kext but still no resolution and quartz. pls help what i hve to do mb modify kext or mb u can help or somebody, something. hw - samsung r519 4500 m i dont know what kinda '45 chipset... osx86 lion 1.7.2

Share this comment


Link to comment
Share on other sites

what can be a problem of voodoopowermini kext>>> when os boots nothing happend after voodoopowermini.kext loading and boot stops.... ?

Share this comment


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.