Jump to content

GMA X/4500/M/MHD/HD +64 bit kext 1.1


1 Screenshot

About This File

--UPDATE MAY 19th--

the project john was working on was cancelled...

--UPDATE APR 29th--

just thought i would share the news here but on this page John has finally got QE/CI working on GMA 4500M, when the driver will be released idk but i will help him make a 64 bit driver of this as i am on mountain lion and i was getting pretty close myself but i couldn't figure it out so maybe with his knowledge of the driver and mine of the 64 bit kext we can finally have a fully supported up-to-date system!

---2013---

--UPDATE APR 7th---

for those of you who are having problems with brightness on your computer's go here and follow the directions.it worked for me smile.png

---2012---

--UPDATE SEPT 16th--

been looking at the comments and certain IGP's of GMA 4500 work fine others need fixes (DSDT) to work properly...

Does not work for desktops! :Intel G41 (GMA X4500) in tablets/desktops should work fine and may enable QE/CI

Intel GM45 (GMA 4500MHD) in laptops/tablets work fine need backlight fix

seems not to work for Q chipsets

Intel GS45 (GMA 4500MHD)seems unstable...

Intel GL40 works flawlessly (my chipset wink.png )

working on more info will update shortly wink.png

--UPDATE SEPT 15th--

hello everyone i am back from a long needed vacation smile.png

ok... well back to business

only thing that's different is.. im on windows.... and i haven't had many/any problems :/ guess i was wrong windows 7 is fine

now heres one reason i have windows.. im a gamer and recently lost one of my console's :'(

but ill try to help the best i can ok guys? smile.png and yes if your guessing i highly doubt QE/CI will ever be supported....but we may figure it out wink.png

--UPDATE AUG 2nd--

10.8 does support the 64 bit kexts :cool:

---IMPORTANT UPDATE JULY 12th---

From this point on this page will be used to inform updates,

i have included a READ ME and other things

---UPDATE JULY 10th---

i put in the smbios i forgot to put in *my bad* but otherwise enjoy biggrin.png

---UPDATE JULY 9th---

i included dynamic kexts for your specific device id so u don't have to patch on your own (this took me an hour wink.png )

if u have a unlisted device message me and ill include it, they are in both 32 bit and 64 bit architecture so support for mountain lion

removed a few unnecessary files

---UPDATE JULY 8th---

Quartz Debug settings for performance: QE Enabled,QGL Enabled,BeamSync Disabled/OFF

macbook 4,1 smbios for better performance

voodoopowermini needed for macbook 4,1 smbios speedstep ill include it

plus with VPM you can set p-state limits when on ac/battery/and low battery in the info.plist

---UPDATE JULY 7th---

fixed unmodified kext and updated 2E32 DEV ID kext

---UPDATE JULY 3rd---

updated 32 bit kexts to 6.3.6 made september 2011

included unmodified kext incase someone has a unincluded kext for there dev id (which i could put in if u told me the dev ids wink.png )

less lag and more stable wink.png

no full QE/CI until the non FB kext works or someone makes a new kext (who knows it could be me wink.png )

---UPDATE JULY 1st---

software QE works i use quartz debug ill include it but be warned the CPU has limits!!

added kext for 2E32 device id wink.png

fixed kexts info.plist so theres no need to add dev ids wink.png but still patch them with the bash wink.png

---UPDATE JUNE 28th---

users with 2A42 use 2A42AppleIntelGMAX3100FB.kext if you get this line in verbose boot

IG: Invalid firmware max backlight setting or it don't work first time use GraphicsEnabler in chameleon then if u get both

IG: Invalid firmware max backlight setting

IG: Invalid firmware backlight level setting, your display should work;)

included system info you should know what to do with that wink.png


What's New in Version 1.1   See changelog

Released

No changelog available for this version.




User Feedback

Recommended Comments



Hello,

I have eMachines E725 with GMA4500M / Mountain Lion (N{censored} 10.8.5) and when I install AppleIntelGMA4500FB2A42x64.kext I end up with black screen after boot selection screen.

Can you help me to troubleshoot? I tried with 32bit driver, but no luck (it does not load it). I removed 64bit kext file from Extensions with console, and now it boots again, but I would realy want to enable Wide screen on this one, if possible.

Thank you for your help.

Share this comment


Link to comment
Share on other sites

hi there, i was happy to see this kext but as i tested it my screen became black after boot as it was still running behind, i typed my password it shows some splashes and did log me in and i could see two displays in my display menu. when i am in default mode i can see the menu bar but my dock does't appear and when i switch my display to another i get a small resolution half my screen size where everything works and i could get a 144 mb graphics where as in default i could get 5mb, you guys are doing great, i'll wish u all the best, i'll post some pictures if that might help. and i am on El Capitan

Screen Shot 2017-05-22 at 10.13.08 AM.png

Screen Shot 2017-05-22 at 11.20.12 AM.png

Screen Shot 2017-05-22 at 11.20.30 AM.png

Screen Shot 2017-05-22 at 11.21.09 AM.png

Edited by Romeao

Share this comment


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×