Jump to content

GMA X/4500/M/MHD/HD +64 bit kext 1.1


1 Screenshot

About This File

--UPDATE MAY 19th--

the project john was working on was cancelled...

--UPDATE APR 29th--

just thought i would share the news here but on this page John has finally got QE/CI working on GMA 4500M, when the driver will be released idk but i will help him make a 64 bit driver of this as i am on mountain lion and i was getting pretty close myself but i couldn't figure it out so maybe with his knowledge of the driver and mine of the 64 bit kext we can finally have a fully supported up-to-date system!

---2013---

--UPDATE APR 7th---

for those of you who are having problems with brightness on your computer's go here and follow the directions.it worked for me smile.png

---2012---

--UPDATE SEPT 16th--

been looking at the comments and certain IGP's of GMA 4500 work fine others need fixes (DSDT) to work properly...

Does not work for desktops! :Intel G41 (GMA X4500) in tablets/desktops should work fine and may enable QE/CI

Intel GM45 (GMA 4500MHD) in laptops/tablets work fine need backlight fix

seems not to work for Q chipsets

Intel GS45 (GMA 4500MHD)seems unstable...

Intel GL40 works flawlessly (my chipset wink.png )

working on more info will update shortly wink.png

--UPDATE SEPT 15th--

hello everyone i am back from a long needed vacation smile.png

ok... well back to business

only thing that's different is.. im on windows.... and i haven't had many/any problems :/ guess i was wrong windows 7 is fine

now heres one reason i have windows.. im a gamer and recently lost one of my console's :'(

but ill try to help the best i can ok guys? smile.png and yes if your guessing i highly doubt QE/CI will ever be supported....but we may figure it out wink.png

--UPDATE AUG 2nd--

10.8 does support the 64 bit kexts :cool:

---IMPORTANT UPDATE JULY 12th---

From this point on this page will be used to inform updates,

i have included a READ ME and other things

---UPDATE JULY 10th---

i put in the smbios i forgot to put in *my bad* but otherwise enjoy biggrin.png

---UPDATE JULY 9th---

i included dynamic kexts for your specific device id so u don't have to patch on your own (this took me an hour wink.png )

if u have a unlisted device message me and ill include it, they are in both 32 bit and 64 bit architecture so support for mountain lion

removed a few unnecessary files

---UPDATE JULY 8th---

Quartz Debug settings for performance: QE Enabled,QGL Enabled,BeamSync Disabled/OFF

macbook 4,1 smbios for better performance

voodoopowermini needed for macbook 4,1 smbios speedstep ill include it

plus with VPM you can set p-state limits when on ac/battery/and low battery in the info.plist

---UPDATE JULY 7th---

fixed unmodified kext and updated 2E32 DEV ID kext

---UPDATE JULY 3rd---

updated 32 bit kexts to 6.3.6 made september 2011

included unmodified kext incase someone has a unincluded kext for there dev id (which i could put in if u told me the dev ids wink.png )

less lag and more stable wink.png

no full QE/CI until the non FB kext works or someone makes a new kext (who knows it could be me wink.png )

---UPDATE JULY 1st---

software QE works i use quartz debug ill include it but be warned the CPU has limits!!

added kext for 2E32 device id wink.png

fixed kexts info.plist so theres no need to add dev ids wink.png but still patch them with the bash wink.png

---UPDATE JUNE 28th---

users with 2A42 use 2A42AppleIntelGMAX3100FB.kext if you get this line in verbose boot

IG: Invalid firmware max backlight setting or it don't work first time use GraphicsEnabler in chameleon then if u get both

IG: Invalid firmware max backlight setting

IG: Invalid firmware backlight level setting, your display should work;)

included system info you should know what to do with that wink.png


What's New in Version 1.1   See changelog

Released

No changelog available for this version.




User Feedback

Recommended Comments



that way no way not need to read last 2 post but still dunno what to do with kernel panic i cant see any info bout that coz the screen is too small for that

Share this comment


Link to comment
Share on other sites

Hi I have Intel G41RQ MB and Display is GMA4500 8086:2E32 so I installed 2E32 64 bit Now its boot No error but Monitor show out of range I try to give boot string at 1024x768x32 but still its show out of range my monitor is Max 1360x768 how I set to it Plz Help

Share this comment


Link to comment
Share on other sites

I tried the x64 kext present in the laptop folder. I can see OS X booting up but then my LCD backlight stops working i can barely see the desktop. Is there any fix for it?.

Acer Aspire 4736Z

GMA 4500M

Share this comment


Link to comment
Share on other sites

Hi I have Intel G41RQ MB and Display is GMA4500 8086:2E32 so I installed 2E32 64 bit Now its boot No error but Monitor show out of range I try to give boot string at 1024x768x32 but still its show out of range my monitor is Max 1360x768 how I set to it Plz Help

Share this comment


Link to comment
Share on other sites

Working here on a Compaq CQ71-410ED, GMA4500M device id 2a42, Lion 10.7.5.

Had to specify GraphicsEnabler=Yes, otherwise screen would stay black.

Unfortunately external 24" Samsung screen stays black, though it's detected by Mac OS X and has the correct resolution in the Display control panel.

No QE/CI as Quartz debug won't start, so can't comment on that.

@GamingDJ, what happens if you boot with GraphicsEnabler=Yes at the boot prompt?

Share this comment


Link to comment
Share on other sites

One addition...

Because of a comment earlier, I tried to boot without GraphicsEnabler=Yes, but with the external monitor connected. This time as long as I did not log in, the external monitor displayed the dark canvas background! As soon as I logged in, a fraction of a second the default background came up, and the screen turned black again.

The system info shows the card as having 144 mb ram in stead of 512; could that have something to do with it?

Share this comment


Link to comment
Share on other sites

Mine is appearing a message Kernel Extensions in backtrace> AppleIntelGMAX3100FB

tried in a 64bit Mountain Lion the version 2A42, please someone help me, I already tried booting in -x mode and I think it may be some configuration in Chameleon, like, what should I mark and what not?

Share this comment


Link to comment
Share on other sites

macos665 create one for me my sys id is

Model Name: MacBook Pro

Model Identifier: MacBookPro4,1

Processor Name: Intel Core 2 Duo

Processor Speed: 2.29 GHz

Number Of Processors: 1

Total Number Of Cores: 2

L2 Cache: 1 MB

Memory: 4 GB

Bus Speed: 800 MHz

Boot ROM Version: MBP41.0073.B00

SMC Version (system): 1.30f3 Type: GPU

Bus: Built-In

VRAM (Total): 64 MB of Shared System Memory

Vendor: Intel (0x8086)

Device ID: 0x2a42

Revision ID: 0x0009

Kernel Extension Info: No Kext Loaded

Displays:

Display:

Resolution: 1024 x 768

and thank you , i am using gma 4500m

Pixel Depth: 32-Bit Color (ARGB8888)

Main Display: Yes

Mirror: Off

Online: Yes

Share this comment


Link to comment
Share on other sites

Keep on the hard work and thank you for what you are already doing.

I actually have no idea on which kext i can use. i use a mountain lion iatkos distribution on my laptop with intel gma 4500mhd. If any one can help me out on the kext i should use i would be so grateful. Thank you

Share this comment


Link to comment
Share on other sites

not working for me b43 chipset gma4500 os:lion 10.7.4 i only can see the backgroung picture and cursor nothing icon on desktop

Share this comment


Link to comment
Share on other sites

sorry,it work. the problem is my os detected two displays(actually only one),one is built-in spdisplays_display ,another is my display(len 27w),os show everything on the bulit-in display so i can see nothing on my display(len 27w). mark: i use a desktop computer. ;)

Share this comment


Link to comment
Share on other sites

I have a desktop with Intel G41 Express Chipset (Intel GMA X4500). It doesn't work, black screen after install (I installed the 2E32 version), but I managed to remove the kext.

Share this comment


Link to comment
Share on other sites

Gateway DU10G, Q45/Q43 Express Chipset, GMA 4500

Vendor: Intel (0x8086)

Device ID: 0x2e12

Revision ID: 0x0003

Mountain Lion 10.8.0

2E12AppleIntelGMA4500FBx64.kext makes the system come up, but DVI monitor instantly goes to sleep (even before login screen loads & never recovers)

GraphicsEnabler whichever way makes no difference

Share this comment


Link to comment
Share on other sites

In fact after few tests I discovered that I have the same issue as

joshuamalmsteen - first post on page 20

the VGA input gives me a perfect extended desktop with correct resolution

Is there a way to make DVI work, or at least make VGA being primary?

sebus

Share this comment


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.