Jump to content

Pack Lenovo IdeaPad Z470 1.0

Sign in to follow this  

About This File

Pack Lenovo IdeaPad Z470

BR > http://shop.lenovo.com/brweb/br/pt/products/laptops/ideapad/z-series/z470/index.html

EN > http://www.lenovo.com/products/us/laptop/ideapad/z-series/z470/

This thread may help someone who are experiencing issues > http://www.osx86.net/10-7-lion/14279-how-install-lion-lenovo-z470-help-me.html

Only tested on the machine with the specs below, made sure to have the exact same specs...

Chipset: Intel HM65 ?

Processor: Core i7-2620M ?

Memory: 6Gb ?

HDD: Western Digital 750Gb ?

Video: Intel HD Graphics 3000 ?

Audio: ALC269 ?

Lan: Realtek RTL8101/8102/8103 ?

Wireless: Atheros AR9285 ?

Essential System Files

FakeSMC.kext (Version 3.1.0 with plugins support)

NullCPUPowerManagement.kext (Version 1.0.0d2 "for non-dsdt users")

Essential Device Drivers

VoodooHDA.kext Patched for ALC269

RealtekR1000 > RTL8101/8102/8103

IO80211Family.kext > Atheros AR9285

AppleACPIPS2Nub.kext > PS2 Devices (Keyboard TrackPad)

ApplePS2Controller.kext > PS2 Devices (Keyboard TrackPad)

VoodooBattery.kext > Battery Meter

System Settings

SMBios.plist (MacBook Pro 8,1 Sandy Bridge)

org.chameleon.Boot.plist with the following settings...

EthernetBuiltIn

ForceHPET

GenerateCStates

GeneratePStates

GraphicsEnabler

arch=i386 (Unfortunately, the AR9285 can find Available networks only in 32bit after the update 10.7.3)

Miscelaneous

IntelCPUMonitor.kext > http://www.projectosx.com/forum/inde...showtopic=1644

IntelThermal.kext > http://www.projectosx.com/forum/inde...showtopic=1594

Add-Ons

DSDT Auto-Patcher (App Only) by MaLd0n > http://www.olarila.com/forum/viewtopic.php?f=19&t=507

Text file with Patches for Lenovo IdeaPad Z470 to be used with DSDT Auto-Patcher

with the following patches...

_T_x rename

AHCI SATA orange icon

DTGP

EHCI

FN KEYS

HDEF_DSM

IRQs

LPC

PNLF SB

New HPET

RTC

SBUS

Shutdown

All Patches above can be found here > http://www.olarila.com/forum/viewtopic.php?f=19&t=62

If you have any issues booting the system after the installation, boot Ignoring Caches ( -f )...

All working 100%...

Enjoy!!




User Feedback

Recommended Comments

hi! thanks for your upload and guide, very complete.

i have a z479 but with

core i3 2330m

memory 4gb

everything else is exactly the same as yours, so i used t]your files and everything is working, im on lion 10.7.3

but one major problem, azurewave atheros ar9285 is working but it wont find any available networks.

im sure im booting with arch=i386 just as you mention...

any ideas??? thanks!

Share this comment


Link to comment
Share on other sites

You are using the the "org.chameleon.Boot.plist" from the pack or you are using your own???

I`m asking this because the boot flag "arch=i386" does`t work with OS X Lion...

Share this comment


Link to comment
Share on other sites

Sorry I took a while to reply. I was travelling.

I explained wrong, Im sure im using the org.chameleon.Boot.plist from the pack, which obviously says, arch

i386

this ar9285 is still not finding networks, i cant find the reason :S

Share this comment


Link to comment
Share on other sites

@almeidabr: are you talking about crackling sound on the music, especially on high treble and boom base part of the music/sound? you can check this link out... it worked for me. [link]

Share this comment


Link to comment
Share on other sites

anybody experiencing problems with disk utility? after sometime of usage, when i tried opening disk utility, it stuck @ "Gathering Disk Information" while the colored wheel cursor rotates endlessly. and still having occasional kernel panic at boot.

Share this comment


Link to comment
Share on other sites

Hello, well I installed osx 10.7.0 lion but when I upgrade to 10.7.1 as could find the disc and get the message still waiting for root device, if I can help with this issue. thanks

Share this comment


Link to comment
Share on other sites

When I try to boot up it says " Can't find ?system?Library/Caches/com.apple.kext.caches/Startup Kernel cache" When I try booting up from the ML system partition or my USB mac ML installer I installed all your kexts and pu tin your Extras folder and repaired permissions and rebuilt and refreshed the cache for both S/L/E and E/E and restarted ( didn't touch the DSDT folder you had)

BTW I have the Same exact specs as your laptop

Share this comment


Link to comment
Share on other sites

@lohweekuin,

If this machine have similar specs maybe yes...

@all

I don't have this machine anymore and lots of things get changed after I upload

this pack, so, I don't know if everything still working as expected...

Share this comment


Link to comment
Share on other sites

@kyndder

yes i still am using Lenovo Z470. and also using the same files you have uploaded. still using the 10.7.2 iAtkos L2, didn't bother to update coz i got my mac mini late 2012 - 10.8.3. also I made some changes to make use of dual-monitor (laptop LCD + full HD HDMI monitor) setup. thanks for the files kyndder.

Share this comment


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.