Jump to content

About This File

Works Tested On G31M-S2C & P5GCMX




User Feedback

Recommended Comments

I Just Use HDEF

I Use Layout 12

# Insert device HDEF into device with _HID PNP0A08 (PCI0)

#

into device name_adr 0x001B0000 parent_hid PNP0A08 remove_entry;

into device name_hid PNP0A08 insert

begin

Device (HDEF)\n

{\n

Name (_ADR, 0x001B0000)\n

Method (_DSM, 4, NotSerialized)\n

{\n

Store (Package (0x04)\n

{\n

"layout-id", \n

Buffer (0x04)\n

{\n

0x0C, 0x00, 0x00, 0x00\n

}, \n

"PinConfigurations", \n

Buffer (Zero) {}\n

}, Local0)\n

DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))\n

Return (Local0)\n

}\n

}

end

Share this comment


Link to comment
Share on other sites

I have the same thing in my dsdt file, but my PCI0 _HID is "PNP0A03". But I think that's because I have a different mobo.

What do you mean you use Layout 12?

Share this comment


Link to comment
Share on other sites

http://www.osx86.net/members/kemalalkin.html your kexts is working your kexts 1.9.9f12 SL not Lion 2.1.1f12

sudo perl -pi -e 's|\x84\x19\xd4\x11|\x62\x06\xec\x10|g' /System/Library/Extensions/AppleHDA.kext/Contents/MacOS/AppleHDA

sudo perl -pi -e 's|\x83\x19\xd4\x11|\x00\x00\x00\x00|g' /System/Library/Extensions/AppleHDA.kext/Contents/MacOS/AppleHDA

Share this comment


Link to comment
Share on other sites

imick;

hda alternative voodooo

gums;

lion working my pc tested

but some in motherboards my kexts not work

some in motherboards your kexts not work

;)

my alc662rev1 :)

Share this comment


Link to comment
Share on other sites

Not working for ALC662 Foxconn G41MD-V;

I use gums'es AppleHDA, Kemal's ALC662, and Kemal's HDAEnabler

Help neeeeed

Share this comment


Link to comment
Share on other sites

works on GA P35-S3G, but.. after 30-35 seconds sound turned off (noise in speakers). If I change volume level - sound appears. And It happens all time

sorry for my English

Share this comment


Link to comment
Share on other sites

I finally got it work with changing the dsdt layout-id to 0x0C, 0x00, 0x00, 0x00 and additionally using alc662.kext. BUT no mic input. Only one input device present in Sound settings, but it's not working with my mic. GA-G31M-S2L - Lion 10.7.2

Share this comment


Link to comment
Share on other sites

I have a problem, using this kext, my console is spammed with this:

kernel[0]: Sound assertion "kTypePinComplex != fType" failed in AppleHDAWidget at line 2043 goto Exit

kernel[0]: Sound assertion "kTypePinComplex != fType" failed in AppleHDAWidget at line 2043 goto Exit

kernel[0]: Sound assertion "kTypePinComplex != fType" failed in AppleHDAWidget at line 2043 goto Exit

in every 30 seconds! Any fix for this?

Share this comment


Link to comment
Share on other sites

I just made the headphone/speaker autoswitch working. Needed to modify platforms.xml, I just put headphone and speaker together into one array and it switches. :)

Share this comment


Link to comment
Share on other sites

does it work on Biostar G31-M7 TE? It has ALC662 onboard soundcard.. I have tried all applehda, but no input/output in Sound Pref Pane..

Share this comment


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.