Jump to content

[FULLY Working] ATI Mobility Radeon HD 5470 1.0

Sign in to follow this  

About This File

If you try it, please comment if it works or not !

This will make your ATI Mobility Radeon HD 5470 FULLY WORKING !!! When I say fully it means that the QE/CI, transparency, Resolution... Is FULLY WORKING !

Try it yourself !!

This is working with Snow Leopard and Lion !!

PS: You may need to use the chameleon I used ! Look at the bottom for it ! PS: In the installation, take everything !

Instruction :

1. Add this to your Com.Apple.Boot.plist located in /Extra

AtiConfig

Hoolock

GraphicsEnabler

Yes

2. Install all Kext with KextUtility

3. Reboot !

Tested using Chameleon_2.0_RC5_r1083 [Outdated, Don't use with Lion or Mountain Lion] which can be downloaded here: http://www.mediafire.com/?1w252qttg5o25o2 and ATI Mobility Radeon HD 5470 1GB

Miror: http://www.mediafire.com/?4zlor6cg5iiza6r

This is a PROOF that it does work !! (Picture taken with a camera on my laptop!)

http://img29.imageshack.us/img29/6296/img0188un.jpg

PLEASE COMMENT IF IT WORKS FOR YOU !




User Feedback

Recommended Comments



I have an Acer Aspire 5740G, ATI Mobility Radeon HD 5470, Snow Leopard 10.6.3 and just get a black screen

Share this comment


Link to comment
Share on other sites

Well, I don't know for Snow Leopard user because I only tested on Lion but someone tried it and told me it did work on 10.6.8

Share this comment


Link to comment
Share on other sites

It does work on 10.6.8 but I have no external displays. I am using the DSDT from kexts.com

I am also using your recommended chameleon version. Please advise, would love dual monitor to work again. It sees the monitor, the mouse scrolls off the screen as if it were there. This goes for either HDMI or VGA. Thank you for your excellent work.

Jeremy

jvisaproductions@yahoo.com

Share this comment


Link to comment
Share on other sites

@jrviccari

Try without de DSDT because I didn't use any. You can also try with Lion. If it's the GM version, don't install any kext, just add

AtiConfig

Hoolock

GraphicsEnabler

Yes

And it will work perfectly

Share this comment


Link to comment
Share on other sites

asus x42je (same as k42je)

Ati 5470M 512MB

try on 10.6.7

i had put the kext files in S\L\E\ and run kext utility

reboot, and screen scratche!!!!

did i do something wrong?

or just don't fit my notebook?

any solution??? anyway, thanks your file

Share this comment


Link to comment
Share on other sites

The error isn't because of a bunky driver but lion's inability to detect the correct EDID... the EDID tutorial mentioned earlier will do the trick. The display on my Acer 5741g, which has an RadeonHD 5740m, was coming up blank until i did the EDID fix.

Share this comment


Link to comment
Share on other sites

Hi jamesst20,can i ask you to post your raw data? i need to test it on my sony vaio vpc with this fucking AtiRadeonHD 5470...please.... :)) thanks in advance...

Share this comment


Link to comment
Share on other sites

Hi Jamesst20...can i ask you to post your raw data from your monitor???? i need to try a different one on my Sony Vaio...im stucked with the lvds issue.....many thanks... Alexandre Carvalho

Share this comment


Link to comment
Share on other sites

@jamesst20. First thanks for your support, i have a laptop Asus k42je with HD 5470 and installed 10.6.7. it's not full resolution. i try install many time but unsuccessful. i used chameleon to test and i didn't see 1366x768, it work 1024x768.

Share this comment


Link to comment
Share on other sites

After two days of trying to boot into my Lion Installer partition these kexts worked, but arch=i386 needs to be used as well or you're just going to get a kernel panic.

Share this comment


Link to comment
Share on other sites

I install chameleon from link from description. System finally starts with GraphicsEnabler=Yes but only on VGA monitor :/ the screen on notebook was like a second screen...

VGA: http://img834.imageshack.us/img834/7272/zrzutekranu20110921o133.png

Notebook screen: http://img405.imageshack.us/img405/7272/zrzutekranu20110921o133.png

I have Dell Studio 1558 i5 450M HD5470M 4GB RAM 1333Mhz HDD640GB

Sorry for my bad english :(

Share this comment


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.