Jump to content

1 Screenshot

About This File

Experience The Truly QE/CI Acceleration of Radeon Graphics In Mavericks...With DSDT Injection!!!

Experience The TRUE DOLBY DIGITAL 5.1 SURROUND SOUND via HDMI!!!

Supported Products:

>>>> HD 7600 Series

HD 7700 Series

HD 7850

HD 7850M

HD 7870

HD 7870 XT

HD 7950

HD 7970

HD 7970M

HD 8850M

HD 8970

HD 8760 OEM

R9 270X

R9 280X !!!! <<<<<

Below All Files Are Included in zip...

>>Kext Utility

>>DSDT Editor

Procedure....

1.Use KextUtility To Install Kexts !!

2.Check Your Graphics Card Device Location Whether it is in PCI0,PCI1,PEGP or PCE2...Wherever ...Using IORegistryExplorer.app!!

3.Use DSDT Injection With DSDT Editor.Save as "DSDT.aml" and Copy To Extra Folder!!!

4.You're Done!!!!


What's New in Version v2.2

Released

  • Added New Device Support: AMD R9 270X & 280X...



User Feedback

Recommended Comments



I get a kernel panic when using a provided DSDT.aml file from in one of the injector folders for my AMD Radeon R9 280. (Radeon HD 7950) Mavericks 10.9.1 worked FLAWLESSLY and now kernel panic after rebooting from this.

"Panic(cpu 0 caller 0xffffff80006bbb01): "Unable to find driver for this platform: /"ACPI/".\n"@/Users/Shaneee/Desktop/xnu-2422.1.72/iokit/Kernel/IOPlatformExpert.cpp:1503". First off, my username is Kyle. Not "Shaneee"...so no idea where that came from. :| Please help me! I need guidance on creating my own DSDT.aml for my system.

Thank you.

SPECS:

AMD Phenom II X6 1090T

14GB RAM

AMD Radeon R9 280X (Radeon HD 7950)

Share this comment


Link to comment
Share on other sites

Thats Your BootLoader Issue...

Re-Install Your Default Working BootLoader

i used boot flag -v to pass bootloader issue. It regconized r9 270 but memory show only 5Mb. Can you do teamviewer??

?

Gpuz of my card

?

20140925_171633.jpg

Share this comment


Link to comment
Share on other sites

I have some troubles installing the DSDT Patch to graphics card.

specs:

motherboard: ASUS F2A85-MLE
CPU: AMD A-Series 10

GPU: AMD Radeon 7660d HD

?

my IORegistryExplorer file:?http://www.mediafire.com/download/c6fi319yvxsfwhy/mySystem.ioreg

my DSDT extracted from DSDT Editor:?http://www.mediafire.com/download/rlumcxpyx0xxrd1/MyDSDT

?

Can you please patch that DSDT and send me the patched version?

It would be great!

Thanks

Share this comment


Link to comment
Share on other sites

Anyone able to help me with this proccess? ?Im having trouble figuring out how to use DSDT Editor Any help would be appreciated

?

?

Here is my regfile

?

?

https://drive.google.com/file/d/0ByylNWOIfcUJYkRHMWlOZjNmbDg/view?usp=sharing

?

?

Not sure which adapter is my video card

?

And do i need to run the dsdt editor first and create one for my computer?

?

?

?

This is my edited DSDT.aml ?

https://drive.google.com/file/d/0ByylNWOIfcUJUnlGTzFOZGJpOWs/view?usp=sharing

?

but it doesn't seem to be working yet ?Any help appreciated

Share this comment


Link to comment
Share on other sites

Graphics card is?AMD Radeon HD 7970

?

Regfile again if you need it

?

https://drive.google...iew?usp=sharing

?

Unedited DSDT is here

?

https://drive.google.com/file/d/0ByylNWOIfcUJdzFQalpKNS1xcFE/view?usp=sharing

?

Thanks for the help

Let me know what else you need

It Has Still GFX Code Patched in It...

I Said Unedited...

follow steps:-

open DSDT Editor

Go to File Menu then...

1.extract dsdt

2.Go To ..... IASL from the menu bar

3.click on compile then fix errors..

4.and last...click on IASL>>> save aml as..

5.done

Share this comment


Link to comment
Share on other sites

It Has Still GFX Code Patched in It...

I Said Unedited...

follow steps:-

open DSDT Editor

Go to File Menu then...

1.extract dsdt

2.Go To ..... IASL from the menu bar

3.click on compile then fix errors..

4.and last...click on IASL>>> save aml as..

5.done

?

Sorry I had one that I booted with before ?Had to reboot with no DSDT in Extra ? ?

?

This one should be the correct one ?I fix all Errors except the warning except ?_REG has no corresponding Operation Region

?

?

https://drive.google...iew?usp=sharing

Share this comment


Link to comment
Share on other sites

currently I have skipATIGFX ?set to yes for a boot flag would I need to change that to no?

?

?

or any other flag?

?

Becasue the DSDT didnt seem to work all my games are still stuck at 1280x720

?

is there an easy way to test is t works?

?

or maybe thats something I cant fix

?

Kext are installed as well

Share this comment


Link to comment
Share on other sites

currently I have skipATIGFX ?set to yes for a boot flag would I need to change that to no?

?

?

or any other flag?

?

Becasue the DSDT didnt seem to work all my games are still stuck at 1280x720

?

is there an easy way to test is t works?

?

or maybe thats something I cant fix

?

Kext are installed as well

first of all boot with your normal boot flags...dont add any others....

boot with >>>> AtiConfig=kAji GraphicsEnabler=Yes -v

Share this comment


Link to comment
Share on other sites

first of all boot with your normal boot flags...dont add any others....

boot with >>>> AtiConfig=kAji GraphicsEnabler=Yes -v

Hmm still no luck

?

Im not sure what normal boot flags are

?

Here is my current boot

?

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Credits</key>
<string>www.N{censored}.co</string>
<key>EthernetBuiltIn</key>
<string>y</string>
<key>GraphicsEnabler</key>
<string>Yes -v</string>
<key>Kernel Flags</key>
<string>npci=0x2000 dart=0</string>
<key>Timeout</key>
<string>2</string>
<key>AtiConfig</key>
<string>kAji</string>
<key>UseKernelCache</key>
<string>y</string>
? ? ? ? <key>HDEFLayoutID</key>
? ? ? ? <string>01000000</string>
? ? ? ? <key>HDAEnabler</key>
? ? ? ? <string>Yes</string>
</dict>
</plist>
?
?
?
It may very well be working and this could be another issue ?is there a way to tell if this is working?

Share this comment


Link to comment
Share on other sites

Here are the Normal Flags....replace your plist file's Content with this....[backup your plist b4 doing this]..

?

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">

<dict>
?? ?<key>Graphics Mode</key>
?? ?<string>1920x1080x32</string>
?? ?<key>GraphicsEnabler</key>
?? ?<string>Yes</string>
?? ?<key>Kernel</key>
?? ?<string>mckay_kernel</string>
?? ?<key>Kernel Flags</key>
?? ?<string>mckay_kernel AtiConfig=kAji arch=x86_64 npci=0x2000 -v</string>
?? ?<key>Timeout</key>
?? ?<string>5</string>
?? ?<key>UseKernelCache</key>
?? ?<string>No</string>
</dict>
</plist>

?

?

Boot With your Working BootLoader and Just Press "Enter"....

rename your kernel to mckay_kernel or vice-versa..

Share this comment


Link to comment
Share on other sites

Here are the Normal Flags....replace your plist file's Content with this....[backup your plist b4 doing this]..

?

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">

<dict>

?? ?<key>Graphics Mode</key>

?? ?<string>1920x1080x32</string>

?? ?<key>GraphicsEnabler</key>

?? ?<string>Yes</string>

?? ?<key>Kernel</key>

?? ?<string>mckay_kernel</string>

?? ?<key>Kernel Flags</key>

?? ?<string>mckay_kernel AtiConfig=kAji arch=x86_64 npci=0x2000 -v</string>

?? ?<key>Timeout</key>

?? ?<string>5</string>

?? ?<key>UseKernelCache</key>

?? ?<string>No</string>

</dict>

</plist>

?

?

Boot With your Working BootLoader and Just Press "Enter"....

rename your kernel to mckay_kernel or vice-versa..

So I didnt see your bottom line there and skipped that step ?now im getting /cant find mckay_kernal error which makes sense. ?but how do I fix this now since it wont let me single user mode? ?or is there a flag I can use to ignore that boot? ? I can access single usermode from my install usb but it only shows the usb fiels and volumes is empty though I didnt try sudo ls

?

Ill keep trying to fix in meantime stupid of me to not read your full message

Share this comment


Link to comment
Share on other sites

I had to boot with the flag ?/mckay_kernal and it seemed to work not sure if im going to have to do that every time now or not

and im assuming I shouldnt use mach_kernal

?

?

?

this is after I renamed mach_kernal to mckay_kernal ? should I put mckay_kernal in /Extra?

?

?

?

hmm Diablo 3 still stuck in 1280x720 ?but games that werent working before work now So guess thats a different issue

Share this comment


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×