Jump to content

Apple HDA for ALC 275 10.8 and 10.9 1.0

Sign in to follow this  

About This File

worked on Dell XPS 13 and Sony SA, SB, SE: complile from 10.8.2, use with layout id 28 ( add to DSDT in HDEF), support Speaker, Mic, headphone.




User Feedback

Recommended Comments

Microphone working well, but in speaker only noise and nothing more, what I made wrong?

My model Sony VPCF22 (ALC275)

My DSDT setion HDEF:Device (HDEF)

{

Name (_ADR, 0x001B0000)

OperationRegion (HDAR, PCI_Config, 0x4C, 0x10)

Field (HDAR, WordAcc, NoLock, Preserve)

{

DCKA, 1,

Offset (0x01),

DCKM, 1,

, 6,

DCKS, 1,

Offset (0x08),

, 15,

PMES, 1

}

Method (_PRW, 0, NotSerialized)

{

Return (GPRW (0x0D, 0x04))

}

Method (_DSM, 4, NotSerialized)

{

Store (Package (0x0C)

{

"built-in",

Buffer (One)

{

0x00

},

"codec-id",

Buffer (0x04)

{

0x75, 0x02, 0xEC, 0x10

},

"ConfigData",

Buffer (0x40)

{

/* 0000 */ 0x01, 0x47, 0x1C, 0x20, 0x01, 0x47, 0x1D, 0x01,

/* 0008 */ 0x01, 0x47, 0x1E, 0x10, 0x01, 0x47, 0x1F, 0x90,

/* 0010 */ 0x01, 0x57, 0x1C, 0x10, 0x01, 0x57, 0x1D, 0x10,

/* 0018 */ 0x01, 0x57, 0x1E, 0x21, 0x01, 0x57, 0x1F, 0x01,

/* 0020 */ 0x01, 0x87, 0x1C, 0x30, 0x01, 0x87, 0x1D, 0x50,

/* 0028 */ 0x01, 0x87, 0x1E, 0xA1, 0x01, 0x87, 0x1F, 0x01,

/* 0030 */ 0x01, 0xE7, 0x1C, 0x50, 0x01, 0xE7, 0x1D, 0xE1,

/* 0038 */ 0x01, 0xE7, 0x1E, 0x45, 0x01, 0xE7, 0x1F, 0x01

},

"layout-id",

Buffer (0x04)

{

0x1C, 0x00, 0x00, 0x00

},

"device-type",

Buffer (0x0F)

{

"Realtek ALC275"

},

"PinConfigurations",

Buffer (0x10)

{

/* 0000 */ 0x20, 0x01, 0x10, 0x90, 0x10, 0x10, 0x21, 0x01,

/* 0008 */ 0x30, 0x50, 0xA1, 0x01, 0x50, 0xE1, 0x45, 0x01

}

}, Local0)

DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

Return (Local0)

}

}

Please help me with this.

Share this comment


Link to comment
Share on other sites

Only:Method (_DSM, 4, NotSerialized) { Store (Package (0x06) { "layout-id", Buffer (0x04) { 0x1C, 0x00, 0x00, 0x00 }, "PinConfigurations", Buffer (Zero) {}, "hda-gfx", Buffer (0x0A) { "onboard-2" } }, Local0) DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0)) Return (Local0) }

Share this comment


Link to comment
Share on other sites

I change my section, but same, only small noise, like from HDD.

Also I have:

Sound assertion in AppleHDAController at line 1294

What it can be?

Share this comment


Link to comment
Share on other sites

Now I have

02.08.13 22:47:20,000 kernel[0]: Sound assertion in AppleHDAPath at line 1360

02.08.13 22:47:20,000 kernel[0]: Sound assertion in AppleHDAEngine at line 519

and situation the same: external headphone working well, but internal speaker not working, only small noise.

Maybe can help you my linux dump of codec?

Share this comment


Link to comment
Share on other sites

Also I go to system view and find that recognize devices are: internal microphone and internal output, nothing more.

P.S. thank you for help me

Share this comment


Link to comment
Share on other sites

GOOD JOB!?

It also works on XPS12 9Q23. And now I have made it more perfect after adding the LineIn(ExtMic) nodes. I will share it on this site.?

PS:

Now I know your binary patch on AppleHDA:

replace ff 87 ec 1a 0f 8f 53 01 00 00 with?75 02 ec 10 0f 84 8f 02 00 00

replace?ff 87 ec 1a 0f 8f 2f 01 00 00?with?75 02 ec 10 0f 84 53 02 00 00

Share this comment


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.