Jump to content

Atheros AR5B95 AR5B95H AR5B95-H Atheros 9285 1.0


About This File

Latest Mountain Lion kext modified to support Atheros AR5B95-H (Atheros 9285 it seems to be known as, as well) (That's the exact card I use, could support others).

Works perfectly. Airdrop supported natively.

Pci id added was vendor 168c - device 303f. You can do this yourself by editing the Airportatheros40.kext in the plugins directory of your io80211family.kext. Add that in the info.plist and you're golden if this works for you (for future reference).

Anyways, enjoy guys!




User Feedback

Recommended Comments

Honestly, I'm not sure :/ The model number that's written on the module for me is AR5B95-H, and in system profiler it is identified as Atheros 9285 as far as the firmware states. Maybe they're one and the same, or something different.

Share this comment


Link to comment
Share on other sites

Nice! So what do I add where when I try to get my Atheros AR5B22 to work? Where do I look for the right vendor ID and Device# ???

Share this comment


Link to comment
Share on other sites

OK - Win7 says vendor 168c - device 0034 so I did edit the Airportatheros40.kext, added vendor 168c - device 34NOT working. Any idea? Its written AR5B22 on the chip and the Win7 driver name the card Atheros AR5BWB222

Share this comment


Link to comment
Share on other sites

I added Vender ID: 168c and Device ID: as 2b and mine works great. I have the DW1702 (Atheros 9285) installed in the new GA-H77N WiFi motherboard with 10.8.2.

Share this comment


Link to comment
Share on other sites

It's Works for me!! Atheros9285 in Mountain Lion 10.8 and Acer S3-951, thanks.

Saludos desde Oax. Mexico.

Share this comment


Link to comment
Share on other sites

I got a Atheros9285

put it in my laptop edit the string with 168,2b and 168,002b

But didnt work at all :( in windows and linux it just works fine

Win 7 say its

( AR9285 802.11/g/n wifi adapter )

pci\ven_168C&DEV_002B&SUBSYS_3040103C&REV_01

pci\ven_168C&DEV_002B&SUBSYS_3040103C

pci\ven_168C&DEV_002B&CC_028000

pci\ven_168C&DEV_002B&CC_0280

in the string lines i edit ''168,2b''

Just like it already was

Plz help :(

Share this comment


Link to comment
Share on other sites

i have some problems on 10.9.2. i can only log in on networks that are WEP encripted. if they are WPA2 i cant log in :( it just say cant log in.?

?

is my card set up wrong or what? :(

Share this comment


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×