Jump to content

ALC662 10.8.2 Patched (2.3.1f2) 1.0

Sign in to follow this  

About This File

This is Mountain Lion 10.8.2 AppleHDA 2.3.1f2 patched to work with ALC662.

I used VCH888's patch from Insanelymac, so thanks to him for the binpatch!

You need these in your DSDT:

Device (HDEF)
{
Name (_ADR, 0x001B0000)
Method (_PRW, 0, NotSerialized)
{
Return (Package (0x02)
{
0x09,
0x05
})
}
Method (_DSM, 4, NotSerialized)
{
Store (Package (0x06)
{
"built-in",
Buffer (One)
{
0x01
},
"layout-id",
Buffer (0x04)
{
0x0C, 0x00, 0x00, 0x00
},
"PinConfigurations",
Buffer (Zero) {}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
}




User Feedback

Recommended Comments

ekztal: download the last kemalALKIN package and copy only the "HDAEnabler.kext" (and if it won't work, then the "ALC662.kext" too) from it to your /S/L/E. (that kext does the same thing as the dsdt code) Then use this new AppleHDA.kext.

Share this comment


Link to comment
Share on other sites

Hi, I can see my sound card, but I can hear anything.

I have Asrock 4Core1600-GLAN with pached DSDT.

Here is kextstatus:

kextstat | grep HDA

35 0 0xffffff7f81065000 0x4000 0x4000 com.kext.HDAEnabler (1.0.0d1) <10 4 3>

67 2 0xffffff7f81cda000 0xf000 0xf000 com.apple.iokit.IOHDAFamily (2.3.0f2) <5 4 3 1>

68 1 0xffffff7f81ced000 0x16000 0x16000 com.apple.driver.AppleHDAController (2.3.0f2) <67 53 10 6 5 4 3 1>

81 0 0xffffff7f81dc2000 0x7b000 0x7b000 com.apple.driver.AppleHDA (2.3.0f2) <80 79 68 67 59 53 6 5 4 3 1>

82 0 0xffffff7f81ce9000 0x2000 0x2000 com.apple.driver.AppleHDAHardwareConfigDriver (2.3.0f2) <4 3>

Could you please help me ? Thx

Share this comment


Link to comment
Share on other sites

I have tried never version 2.3.1f2

kextstat | grep HDA

57 2 0xffffff7f81cea000 0xf000 0xf000 com.apple.iokit.IOHDAFamily (2.3.1f2) <5 4 3 1>

58 1 0xffffff7f81cfd000 0x16000 0x16000 com.apple.driver.AppleHDAController (2.3.1f2) <57 53 10 6 5 4 3 1>

81 0 0xffffff7f81dd2000 0x7b000 0x7b000 com.apple.driver.AppleHDA (2.3.1f2) <80 79 58 57 56 53 6 5 4 3 1>

but result is same. I have ML 10.8.2

Share this comment


Link to comment
Share on other sites

I have a ultrabook whit this audio codec (ALC662).

But work only internal speaker. No sound in headphones and on prefpane setting for headphones, no internal mic!

How i can patch it for me? I have just one insert port on the right side.

Share this comment


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.