Jump to content

ATI Radeon HD5450 with Full QE/CI Support 1.0


About This File

ATI Radeon HD 5450 with full QE/CI Support - DSDT (Contains HDMI Audio Edit Too) & AGPM included

Updated from 10.8.2 kexts 0n 21st Sep 2012, enhanced graphic performance. wow

***NEW KEXTS FROM 10.8.4 COMING SOON. CECK OUT LATER****

http://www.osx86.net/downloads.php?do=file&id=4131

Tools Needed

1. Use KextUtility to install kexts

2. Use DSDTEditor to edit DSDT

3. Use PlistEdit Pro to edit plist

Here I list three methods to make ATI Radeon HD 5450 working. Method 1 & 2 applies for newbies, method 3 for advanced users. You can use any one of the method upon your interest

**Backup all kexts before patching**

Method 1

1. Install ATI5000Controller.kext & AMDRadeonAccelerator.kext

2. Use the below flag in Extra/org.chameleon.boot.plist

ATIConfig

Eulemur

GraphicsEnabler

Yes

3. Reboot

**This method will work for most Sapphire Radeon Cards**

Method 2

1. Install ATI5000Controller.kext, AMDRadeonAccelerator.kext & EVOenabler.kext

2. Use the below flag in Extra/org.chameleon.boot.plist

GraphicsEnabler

Yes

3. Reboot

Known issues for method 1 & 2

a. Display over HDMI will not wake from sleep sometime

Method 3

1. Install ATI5000Controller.kext & AMDRadeonAccelerator.kext

2. Patch DSDT.aml with ATI 5450 DSDT patch attached and place the patched DSDT.aml in Extra folder

3. The patch includes working HDMI Audio edit. For some cards AppleHDA needs to be patched to get sound from HDMI

4. Remove all Graphics related flags in Extra/org.chameleon.boot.plist

5. Reboot. No wakeup issues like the one, mentioned in method 1 & 2

Patching AppleGraphicsPowerManagement.kext (AGPM)

a. Common for all three methods listed above

b. Patch AppleGraphicsPowerManagement.kext (Patch is included in download), repair permissions and update system cache

c. Reboot. Open terminal, type "kextstat" without quotes and check if com.apple.driver.AGPM is loaded

d. Those who don't want to patch AppleGraphicsPowerManagement.kext, rename/delete it from S/L/E

COMMON ISSUES

a. Reduced frame rate after system wake from sleep. Fix: Change SMBios.plist to iMac or Mac mini and that will fix the problem

b. If your card has different frame buffer i.e Eulemur, change it to new one in DSDT Patch/EVOenabler/boot flag or all

If you found this post useful, appreciate my hard work. All credits goes to me only:encouragement:




User Feedback

Recommended Comments



Hi , i cant boot mountain lion with GE=yes, could be the chameleon?

Can you help me please.

Ati: sapphire 5450 512mb.

Thnx

Share this comment


Link to comment
Share on other sites

Hi , i cant boot mountain lion with GE=yes, could be the chameleon?

Can you help me please.

Ati: sapphire 5450 512mb.

What bootloader are you using?

Thnx.

Share this comment


Link to comment
Share on other sites

Hi , i cant boot mountain lion with GE=yes, could be the chameleon?

Ati: gigabyte 5450 512mb.

What bootloader are you using?

Thnx.

(sorry for the other coments)(my ati is gigabyte not sapphire xD)

Share this comment


Link to comment
Share on other sites

@naxeteoner

Set GE=No in your boot list and do the installation. Anyway it will work for you and thats what Evoenabler.kext does. Intall AMDRadeonAccelerator.kext, ATI5000Controller.kext & Evoenabler.kext in one shot using Kext Utility and restart. Done

Share this comment


Link to comment
Share on other sites

@naxeteoner

Update your chamelion to Enoch rev_2011 (updated for Mountain lion and works fine).

Share this comment


Link to comment
Share on other sites

@naxeteoner

Copy pate all your console message in here as comment. Let me've a look.

Are you using any ATI injector kext? Also I need your device id of your graphics card (Google to find out how)

Share this comment


Link to comment
Share on other sites

But i can't boot ML with the kexts installed. i prove GE=yes and GE=no.

the problem about graphics enabler become when i update chameleon , that happened in lion and mountain lion.

In my hardware info i can see this:

Fabricante: ATI (0x1002)

ID del dispositivo: 0x68f9

ID de la revisi?n: 0x0000

(Im from spain ) :P

Share this comment


Link to comment
Share on other sites

@naxeteoner

Try Chimera boot loader. May be it's a problem with boot loader. The kexts should work fine

Share this comment


Link to comment
Share on other sites

Did all via instructions. But just one display over HDMI working, second one on DVI not working. Also QE/CI is missing. In displays there is a lot of resolutions but my Full HD 1920x1080 is missing :(((( I've got Saphire HD5450 1024 MB. I'm so sad.... Teresa

Share this comment


Link to comment
Share on other sites

@Pignon

Full HD 1920x1080 missing means your display is not identified properly. Try updating your boot loader/edit your dsdt and try to include the information of your graphics card and that resolves your issue 90%.

I'm also using dual display Samsung Full HD TV via HDMI & Samsung 17" display via DVI and seems to work fine.

Another option:- Install AMDRadeonAccelerator.kext & ATI5000Controller.kext. No need to install EVOenabler and change ATIConfig = Shrike/Hoolock/Orangutan/Langur/Zonalis in org.chamelion.boot.plist.

Let me know if the alternate option works

Share this comment


Link to comment
Share on other sites

The same above applies to @naxeteoner. He has also commented his DVI is not working. Try changing ATIConfig = Shrike/Hoolock/Orangutan/Langur/Zonalis in org.chamelion.boot.plist.

Share this comment


Link to comment
Share on other sites

NITHY - YOU ARE THE KING! THOUSAND KISSES... I've just installed Accelerator and Controller and nothing more and it is working great! Thanks a lot again... Teresa

Share this comment


Link to comment
Share on other sites

Can I use these kexts with my ati mobility radeon hd5470, 512 MB? The card is Cedar Pro, too. With the drivers included in the 10.8 myhack installation the card works great on ext Hdmi, but without qe/ci (flash video and movies are unplayable).

The card is recognized as Ati M Radeon HD5000.

Share this comment


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.