Jump to content
  • 0
HackinDoge

[WORKING] ATI Radeon HD 6770 on OS X 10.9

Question

SOLUTION


Patch AMD5000Controller, AMD6000Controller no longer necessary, and AMDRadeonX3000 with the following Dev ID:

0x68BA1002

If you have a Gigabyte AMD Radeon HD 6770 1 GB GDDR5 and your dual link DVI-D isn't working, try this patched Vervet framebuffer:

00040000040300000001000012040102040000001402000000010000110203030002000004020000000100000010040300080000040200000001000022050204

That can be injected via Clover or edited directly into AMDRadeon5000Controller binary via a hex editor.

Share this post


Link to post
Share on other sites

41 answers to this question

Recommended Posts

  • 0

Did you put your Dev ID in the right place.

My card is a Cedar and the framebuffer is Eulemur. So the Dev ID comes in the Cedar section. Same for Eulemur. You should try to find yours.

My HD5450 only need adding Dev ID in AMD5000Controller.kext and AMDRadeonX3000.kext.

http://www.osx86.net/desktops/23595-guide-hd5450-1gb-0x68f9-mavericks-10-9-dp2.html#post150872

Share this post


Link to post
Share on other sites
  • 0
Did you put your Dev ID in the right place.

My card is a Cedar and the framebuffer is Eulemur. So the Dev ID comes in the Cedar section. Same for Eulemur. You should try to find yours.

My HD5450 only need adding Dev ID in AMD5000Controller.kext and AMDRadeonX3000.kext.

http://www.osx86.net/desktops/23595-guide-hd5450-1gb-0x68f9-mavericks-10-9-dp2.html#post150872

Yes, I'm sure I put it in the right place (Juniper).

I'm away from it right now, I'll double check my double check later. :P

Edit: Yes, my Dev ID is in Juniper. ATI5000Controller = the AMD5000Controller you mentioned right?

Edited by Lacedaemon

Share this post


Link to post
Share on other sites
  • 0

GraphicsEnabler=No

Framebuffer=Vervet

You should do exact the same as you did in Mountain Lion.

Where did you put it in ATI6000Controller and AMD6000Controller (ML and Mavericks)?

Share this post


Link to post
Share on other sites
  • 0
GraphicsEnabler=No

Framebuffer=Vervet

You should do exact the same as you did in Mountain Lion.

Where did you put it in ATI6000Controller and AMD6000Controller (ML and Mavericks)?

There's such thing as an "AMDxxxxController" as opposed to "ATIxxxxController"?

I'm actually using Hoolock on ML, and it's working good so far. I'll try Vervet later...

Update: I GOT IT!

GraphicsEnabler=No AtiConfig=[B]Hoolock[/B]

How do I set different options for different OS's in Clover, so I don't have to use the myHack USB to boot?

Edited by Lacedaemon

Share this post


Link to post
Share on other sites
  • 0
Update: I GOT IT!

GraphicsEnabler=No AtiConfig=[B]Hoolock[/B]

Great news man, you should put it in the download sections with the kexts just like I did for the HD5450:

http://www.osx86.net/view/3995-hd5450_mavericks_dp2.html

http://www.osx86.net/desktops/23595-guide-hd5450-1gb-0x68f9-mavericks-10-9-dp2.html#post150872

This will save time for many users :)

Sorry, don't know so much about Clover :(

Share this post


Link to post
Share on other sites
  • 0
Great news man, you should put it in the download sections with the kexts just like I did for the HD5450:

http://www.osx86.net/view/3995-hd5450_mavericks_dp2.html

http://www.osx86.net/desktops/23595-guide-hd5450-1gb-0x68f9-mavericks-10-9-dp2.html#post150872

This will save time for many users :)

Sorry, don't know so much about Clover :(

Will do! I'll upload them as soon as I can. :eagerness:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×