Jump to content
  • 0
gowthamsadasivam

RealTek ALC233 (0x10EC0233) Audio Not Working [ASUS X550LD - XX082D]

Question

Hey guys,

I have a working Hackintosh (Mavericks 10.9) in my Laptop "ASUS X550LD-XX082D".

OS X:?Mavericks 10.9

Model:?ASUS X550LD
CPU:?Intel Core i7 4500U

GPU:?Nvidia GeForce GT 820M - 2GB

RAM:?8GB

AUDIO: Intel High Definition (RealTek ALC233 & Codec id 0x10EC0233 & Device id 0x80869C20)
Wi-Fi:?Qualcomm?Atheros AR9565 (AR956X)


I installed the OS using "xpcm-free -v" and It worked, OS X Mavericks Boots without any boot flags. Intel HD Graphics, Ethernet, Bluetooth, Keyboard, TrackPad, USB 3.0 Devices works perfect. The problems are with the Audio and Wi-Fi Devices.

Here are the screenshots from my Hackintosh:

Audio Device:?RealTek ALC233 & Codec id 0x10EC0233 & Device id 0x80869C20

JIc4RI9.png

In?PCIList?It's detected as below:?Lynx Point-LP HD Audio Controller?But still no audio device found in Mac Sound Preferences :(

KxMZXq8.png

Mac System Information Shows as below:

ZfiQOIl.png

Please help and suggest me to find the appropriate?KEXT?for the Audio Devices. Thanks In Advance :)

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Hi, I have the same hardware but a different Wifi (Broadcom?BCM43142) .

I read that it doesn't work, how can I solve or replace it??

Share this post


Link to post
Share on other sites
  • 0

Hi, and Welcome.

?

Here we are talking about sound, not WiFi - This is the right place:?Networking & Wireless

And?what does not work for you? WiFi or Sound.

?

For sound, try VoodooHDA, or this:?http://www.hackintoshosx.com/topic/21367-realtek-alc233-0x10ec0233-audio-not-working-asus-x550ld-xx082d/?p=107125

For WiFi try this:?http://www.hackintoshosx.com/files/file/2656-broadcom-43xx-series-airport/?st=80

Share this post


Link to post
Share on other sites
  • 0

Hi, and Welcome.

?

Here we are talking about sound, not WiFi - This is the right place:?Networking & Wireless

And?what does not work for you? WiFi or Sound.

?

For sound, try VoodooHDA, or this:?http://www.hackintoshosx.com/topic/21367-realtek-alc233-0x10ec0233-audio-not-working-asus-x550ld-xx082d/?p=107125

For WiFi try this:?http://www.hackintoshosx.com/files/file/2656-broadcom-43xx-series-airport/?st=80

I'm sorry, I've also the ALC233 and for the wifi I wouldn't open another topic because I created only more problems for moderators? :(

Anyone could try the kext of @Mirone?

(Just in case, I find the Broadcom 43XX but I've the 43XXX and I think (but I'm very newbie) that doesn't work)).

Sorry for bad english, hope that you can understand.

Regards.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.