Jump to content

We are currently experiencing problems with some external links - please bear with us while we fix this!


You can find your file using the site search - or post in the forums if you can't and we will find it for you :)


OS X boot loader path

Recommended Posts

Hi, I'm doing my first attempts to install OS X 10.11.6 on an Intel S5520HC (Dual Xeon) machine.

To get some results I need the path to the OS X boot loader.

For example: The Windows 10 Installer boot loader path is X:\efi\boot\bootx64.efi

So, if I knew the Clover installed OS X boot loader path I could invoke it.


Can someone help with this?




Edited by Spas

Share this post

Link to post
Share on other sites

Something more:

The Disk 1 below has been formatted by Mac Disk Utility during the process of installing OS X conducting by Clover.

The 200 MB EFI partition is FAT32 and I can see in Explorer it is empty.

Is this my problem at the moment?

Windows Disk Menagement.png

Edited by Spas

Share this post

Link to post
Share on other sites

Is this my problem at the moment?

Yes - and no. You need to install Clover onto the Mac EFI partition. The Clover installer package does that automatically by default.

First of, you will need a bootable macOS volume with boot loader installed on it. There are many guides to create such a thing.

Such boot volume is needed to get into the macOS installer at all.

From the installer format your Disk1 with the Mac Disk Utility, install macOS and finally install Clover onto Disk1.

When your BIOS settings are right (no RAID Jazz etc.) the installer should find your hard disks.

A OSX boot volume can be created in the macOS fairly easy, GNU/Linux may work, Windows is near useless in my opinion.

Back to Clover: If you have a custom setup for your machine, (from a similar hack on the net) you may also copy over the files by hand.

From my HackBook, things look like this: (Mac EFI is hidden in userland by default)




One method to mount Mac EFI is described here: Mount EFI copy.txt


Your server board may give you some headache, gven its your first Hackintosh.

Be sure to set the ICH10 HHD controller to AHCI and choose a OSX compatible PCI graphics card.

Did you already read this? http://forum.osxlatitude.com/index.php?/topic/7798-install-on-intel-s5520sc-with-dual-xeon/


Good luck!



Share this post

Link to post
Share on other sites

Thank you  for answering me.

I saw the answer after I've made some progress not having reached the final goal, though.
What I have now is a working El Capitan - macOS 10.11.6 generated using a Clover installer.
It is working because I can boot the system in VMware Workstation environment.

My host cannot boot it and, I think, it cannot because neither I nor AMD BIOS can see a boot.efi file in the EFI partition.
I've checked the EFI partition of the already booted system and saw:
gEFI FAT32 non system disk Press any key to reboot.

So, I think if I knew the boot.efi file for the installed system, maybe Clover should now it, and I save it in the EFI partition I can tell BIOS the path to it.
That should be enough, although there could be problems with the BIOS but I have to handle them.


So, I've seen the answer and tried this method but not a success - some errors I couldn't understand.

Then tried another approach  I've seen on youtube: 

diskutil mount /dev/disk0s1

I got a message saying something about redirection requested operation to the host system which could explain my previous unsuccessful attempt.


Nevertheless, I think, this is not the way I need to follow.

First, mount, as long as I remember, is establishing a link which is to be interpreted by the executing software.

In the case of maxOS this should be OK, but my board BIOS understand a direct path of the form EFI\BOOT\BOOTX64.EFI or maybe shorter.

This BIOS loads the OS (for example Microsoft Windows) from its EFI Shell.

Here is what Intel say in their publication 

GUID Partition Table (GPT)

How to install an Operating System (OS) using the GUID Disk Partition Table (GPT) on an Intel® Hardware RAID (HWR) Array under uEFI environment.


20. Reboot into EFI shell.
21. Launch the installer under EFI. (\EFI\BOOT\BOOTX64.EFI)

So, I've been looking for something like macOS 10.11 boot.efi and found publications mentioning


– cd /Volumes/SSD_Ext/System/Library/CoreServices

This will take you to the first place where the boot.efi needs to be replaced.

– chflags nouchg boot.efi

The above command will remove the protection from boot.efi

and replacing the boot.efi.

But these all work with macOS.


I've even found boot.efi developed in a project whose author says:


This project aims to add support for El Capitan (OS X 10.11) for unsupported Mac hardware with a 32-bit only EFI implementation. Like for example the first and second generation Mac Pro models. Though it should work well with any other model with a 32-bit EFI implementation.


So, I think I need the 64-bit file boot.efi, maybe from the System/Library/CoreServices, to copy it to the EFI partition and to set path to it in my board BIOS.

I'm not a Macintosh user, I've forgotten UNIX shells long time ago, so help me please.


If I cannot get the original boot.efi, which knows were the boot code is, I have to recompile the published boot32.efi to 64-bit and try it.


So, really, help me, please.

Edited by Spas

Share this post

Link to post
Share on other sites

I've copied  /Volumes/SSD_Ext/System/Library/CoreServices/boot.efi to my macOS installation EFI folder.

BIOS displayed the mac Lego and ... "Boot failed"

I could't mount boot.efi while working on VMware.

Share this post

Link to post
Share on other sites

Let me finish this topic although I'm not finished yet.


I've found this:


In this case, install El Capitan, install Clover in the EFI of HD and copy/paste the EFI folder from pendrive's EFI to HD's EFI


I did that and using the installer to run its BOOTX64.efi Clover offered an option to boot the OS from the HDD and finally macOS 10.11 started on my machine.

Not understanding this boot process, I'm not satisfied.

The chain is:

Clover boots from the boot installer,

which boots from the HDD where the installed OS resides. (This OS is bootable by VNware also.)

The HDD EFI partition contains a BOOT directory where there is a BOOTX64.efi and two more directories:

Clover and BOOT.

The last BOOT directory contains BOOTX64.efi also.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now