Jump to content
  • 0

wifi is not working for atheros ar8161 pci-e gigabit


Successfully install all the kexts and ethernet is working like a charm but wifi is not detected..

I've already tried atherosI08211family.kext and wifiinjector.kext

But neither wifi nor bluetooth is working.

this is my toshiba satellite pro laptop's ethernet card details :


Qualcomm Atheros AR8161 PCI Express Gigabit Ethernet:


  Name:    ethernet

  Type:    Ethernet Controller

  Bus:    PCI

  Vendor ID:    0x1969

  Device ID:    0x1091

  Subsystem Vendor ID:    0x1179

  Subsystem ID:    0xff1e

  Revision ID:    0x0010

  Link Width:    x1

  BSD name:    en0

  Kext name:    AtherosE2200Ethernet.kext

  Location:    /System/Library/Extensions/AtherosE2200Ethernet.kext

  Version:    1.0.0


this is the wifi details : 


  Software Versions:

  CoreWLAN:    5.0 (500.35.2)

  CoreWLANKit:    4.0 (400.35)

  Menu Extra:    10.0 (1000.33.2)

  System Information:    9.0 (900.9)

  IO80211 Family:    7.0 (700.52)

  Diagnostics:    4.0 (400.68)

  AirPort Utility:    6.3.4 (634.17)


for bluetooth : no info found.


so my question is : how can i enable wifi and bluetooth in my hackintosh ???


please help.


thank you.

Share this post

Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now