Jump to content
Sign in to follow this  
guidorosso

Speedstep Issues

Recommended Posts

Hello All,

I've been trying to get speedstepping to work on my q9950 (quad core 2.83ghz) and my ga-ep45-ud3p. I'm using Chameleon 2 RC3 and everything is running fine except for speedstepping. These are my kexts:

CPUi.kext (to be able to use the CPUi app to monitor my cpu)

CPUInjector.kext

fakesmc.kekt

LegacyHDA.kext

OpenHaltRestart.kext

PlatformUUID.kext

My processor is constantly running at 58 degrees Celsius, so I'd like to get this figured out.

I've tried running with voodoopowermini.kext but still no luck.

I also tried to follow the guide here http://www.insanelymac.com/forum/index.php?showtopic=181631&st=20&start=20 to get speedstep working natively through my DSDT. However, I get no PStates when running PStateChanger (even after rebooting with VoodooPState.kext). The PState table is simply empty.

Any ideas or tips? Is there any other way to get my PStates? Any help would be most appreciated, thanks!

Share this post


Link to post
Share on other sites

Is speedstepping enabled in your BIOS? C1E, etc? I don't mean to insult by something obvious, but it's also easy to overlook...

Share this post


Link to post
Share on other sites

Hi Richiem,

Yep I have C1E, C2/C2E, C4/C4E enabled in the bios.

However, your post reminded me that I initially had to increase the voltage on my RAM (per the manufacturer's recommendation) as apparently the auto settings are incorrect and could cause stability issues. Would this cause speedstepping to be automatically disabled?

Share this post


Link to post
Share on other sites

X-EFI-X'er,

I'll certainly post the DSDT when I'm back in the office (at home right now). However, you won't see any of these values in there yet.

I was trying to follow the guide I linked to in my first post, but I'm getting stuck at the part where I have to run the PStateChanger app to get the values for my processor. The app is simply empty and shows no info in the tables. I added VoodooPState.kext to my extras folder, as the guide suggests, but I still don't get the values.

I'll post my full DSDT later today or tomorrow. Thanks!

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×