Jump to content

mongole

Members
  • Content count

    45
  • Joined

  • Last visited

About mongole

  • Rank
    Member
  • Birthday 04/14/1976
  1. mongole

    SL 10.6.2 is OUT!!!

    they took the link on the apple page offline. :-( I took the risk, but got only kernel panics on booting at my first try...
  2. mongole

    RSS Feeds?

    Hi, I had not been here in the forum for some weeks now, too many other stuff to do around... So I realiced, I needed some time to follow up again. Wouldn't it be great to have an RSS feed one could subscribe to? One for each whole forum subgroup, and also for following single very interesting threads. Could this be possible? greets, mongole
  3. Hi, I wrote a small shell script to back up my Chameleon Boot Stick. I give you the listing, but don't use it if you don't understand, what it's doing. But could be a good motivation to learn something very useful ;-) #!/bin/bash usb_stick=Chameleon backup_dir="/Users/andi/Hackintosh/Backups/Chameleon 2 RC3 Backup/" slice=`mount | grep ${usb_stick} | cut -f 1 -d ' '` disc=${slice%s?} timestamp=`date '+%Y.%m.%d_%T'` dd if=${disc} of="${backup_dir}/Chameleon_2-RC3-Backup_${timestamp}" bs=1m gzip "${backup_dir}/Chameleon_2-RC3-Backup_${timestamp}" say "finished backup" To restore the backup (ATTENTION overwrites the stick of course) use following commands: cd /where/ever/backup/is gunzip thebackup.gz dd if=thebackup of=/rdiskX bs=1m; say "finished restoring" But once again, only use it if you understand what you are doing.... much fun
  4. mongole

    Upgrading Leo to Snow Leopard

    Hi, am I right, you are talking about some software from a company starting with A and ending with e with a C and an S inside their software collection name? Can you tell me, what was your solution to get rid of little snitch? I also would like to avoid it, as it makes more problems (anoyances) as it helps. I really seldom use the not named software suite, but sometimes need it. A tipp would be very apreciated ;-) Thanks in advance greets, mongole
  5. Hi, As I have to use SL in i386 mode because of VMWare Fusion is not available as x64 application up to now, I needed a working solution for this. I used following setup DSDT from AsereBLN, added following fix to replace the HDEF device (which was for the 889a, ALC888 is correct for this device). http://www.insanelymac.com/forum/index.php?showtopic=181509&pid=1235359&mode=threaded&start=0#entry1235359 (search for the first post of the user cparm, direct link does not work :-() Applied the DSDT fix, added the three kexts to /S/L/E with kexthelper (I know /E/E would be better) and restart. :-) I have at least rear analoag out and rear mic in. Maybe I will struggle with konfiguration to get front audio up and running when I find some time. This tutorial should help: http://www.projectosx.com/forum/index.php?showtopic=465&view=findpost&p=1825 I hope somebody will find it useful. Attention! Other audio kexts will not work with this DSDT anymore! Also x64 mode Audio is not working with this solution. greets, mongole
  6. mongole

    DSDT's ready for use with Chameleon

    AAhhhh.! This pointed me to the problem. One line before in the boot messages there was the message: OpenHaltRestart could not be loaded because of an unresolved dependency! It looks like I had an old version, which used the method _kdreboot which was not available in one of the kexts. And I also found a solution for my audio problem. I had to change the DSDT and 3 kexts to /S/L/E. Maybe it would work in /E/E with some more kexts there.... maybe I give it a try. Thanks for the help! AFAIK now everything should work in i386 mode :-) I will write a thread about working ALC888 in SL in the audio section. greets, mongole
  7. mongole

    DSDT's ready for use with Chameleon

    Hi Asere, I am now back there where you pointed me to. Have the same kexts installed like you on the picture. The _CST error message is gone now. I am back also to the EFI String solution for graphics. Again had the scrolling issue. No idea why. But I still have the reboot problem in SL and no Audio. I think I have to take out your modifications for ALC889a (as it is the ALC888) to get the other audio kexts to work. Any idea about the reboot issue? It works fine if I go for hibernation. Only shutdown does not work.... Greets, mongole
  8. mongole

    Search in signatures?

    maybe this would be interesting for others too.
  9. mongole

    WTF is Vnukov

    you are talking about the author or the conultant? ;-)
  10. mongole

    DSDT's ready for use with Chameleon

    Hi AsereBLN, I hope you got my private message. Anyway, I tried again to get everything working using to be prepared for SL. I think I am nearly there, but I am missing one ore two last things. If you could give me some hint, it would make me really happy! When I switch EHCIaquire to y then Chameleon stops to start at an EHCI message. Screenshot attached. In the bootlog I find following Message (not sure about severity of this problem, sounds like power management stuff): kernel[0]: ACPI_SMC_PlatformPlugin::pushCPU_CSTData - _CST evaluation failed In the HDEF Device Area of the DSDT there is the "device-type" set to "Realtek ALC889a". But for my Motherboard it is the ALC888. Is it enough to Change only the string in the DSDT, or is there more to be changed? I know, normaly you do not care about sound, but maybe you know... Under SL it's not shutting down properly. It does all the pre-shutoff stuff (unmounting....), screen turns black, but it's not turned off. I have installed Chameleon 2 RC3 to an USB Stick with following files in the /Extra directory: com.apple.Boot.plist dsdt.aml smbios.plist 10.5/Extensions.mkext 10.5/Extensions/fakesmc.kext (the one for Leo) 10.5/Extensions/OpenHaltRestart.kext 10.5/Extensions/UUID.kext 10.6/Extensions.mkext 10.6/Extensions/fakesmc.kext (the one for SL) 10.6/Extensions/OpenHaltRestart.kext 10.6/Extensions/PlatformUUID.kext My com.apple.Boot.plist looks like this: <plist version="1.0"> <dict> <key>Kernel</key> <string>mach_kernel</string> <key>Kernel Flags</key> <string>-v debug=0x144</string> <key>Default Partition</key> <string>hd(1,2)</string> <key>GUI</key> <string>y</string> <key>Timeout</key> <string>5</string> <key>Graphics Mode</key> <string>1440x900x32</string> <key>GraphicsEnabler</key> <string>y</string> <key>ForceWake</key> <string>y</string> <key>ForceHPET</key> <string>y</string> <key>UHCIreset</key> <string>y</string> <key>EthernetBuiltIn</key> <string>n</string> <key>EHCIacquire</key> <string>n</string> <!-- y => stops during chameleon initialisation --> <key>Wait</key> <string>n</string> <key>device-properties</key> <string></string> </dict> </plist> I used your last DSDT.aml and changed the ABLN Variable to 0x4F, recompiled with DSDTSE and placed it into the /Extra folder. I have also three issues only occuring in SL (vanilla install again): Sound is not working. First I tried with a HDAEnabler and AppleHDA in /S/L/E which worked for me with LEO, but this seems to have caused the boot issues in i386 mode. I think the last issue are more SL related than DSDT issues. But maybe you have got an idea or it really has something to do with DSDT. Thanks for your help in advance! Greets, mongole So, now it's really time for bed....
  11. mongole

    Troubleshooting EFI-X

    Hi, I also have the same/similar problem. SL boots fine in 64 bit mode but stops during boot in 32 bit mode. But I don't think I have problems with the kexts. I just copied over all of the 10.5/Extension/*.kext files to 10.6/Extension and regenerated the mkext files. I only added the spezific fakesmc.kext files. that's all. Which kext caused your problems? FIXED: I had some AppleHDA.kext and HDAEnabler.kext in /S/L/E which cause the stop at boot without a message. Removing them and everthing works fine now :-) greets, mongole
  12. mongole

    How to Remove Chameleon from HD

    To be really clean one should remove the boot0 and boot1h also, istn't it? I had last night a funny journey. I tried to install Chameleon to my HD, but failed. Then I wanted to remove it again. In a weak moment I overwrote the MBR with fdisk -e and was surprised as my system could not find my partitions anymore! After the first shock I found a tool called testdisk, which can restore partition tables. First I was happy to get back my partitions, but then the system did not boot anymore! It hang when the AHCI bios module detects the discs. It stopped on the restored disk. I war really glad SATA is hot plugable so I could connect it after startup from the CCC backup of my system disk. Reformat the disk, play back my Time Machine Backup and everthing works again aus before. I really love my Mac :-) Long story short meaning: Be carful or have backups
  13. mongole

    DSDT's ready for use with Chameleon

    What confusion ;-) Kassia sounded female to me... Sorry :-)
  14. mongole

    DSDT's ready for use with Chameleon

    I played with the new version of DSDT for my motherboard (look for exact model in the signature), but had the scrolling issue Kassia described in her post allready. I could not figure out what's causing this issues. Did anybody find something reason for this issue allready?
×