Jump to content

jimmyco2008

Trusted Member
  • Content Count

    54
  • Donations

    $0.00 
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by jimmyco2008

  1. Need specifics, yo, I just said that. Can you post a picture of the kernel panic text?
  2. Sorry guys, I kind of moved to InsanelyMac, I check this rarely. But I'm here now! You guys need to be more specific, the "system uptime screen" is a kernel panic (common for Hackintoshes), and can be caused by almost anything. The AppleAHCIPort.kext is a relatively innocent little kext, I wouldn't think to blame it... But post a screenshot of the screen with "system uptime in nanoseconds", I can tell you what is causing the kernel panic. As for not working on 10.8.3.... My guide for the m6-1045dx and this kext only goes to 10.8.2, I sold the damn thing, because HP computers suck (eh, haters gonna hate), and then 10.8.3 came out... So... What do you mean by it not working, does the installation not work with 10.8.3, or is the hard drive not being detected after the update to 10.8.3? If you updated to 10.8.3, keep in mind it may overwrite the AppleAHCIPort.kext with Apple's stock one, which we all know does not work. So try, and this is why I had *two* installations of ML on my hackintosh, booting into a separate OS X environment, access the primary one with the 10.8.3 update, and copy the modified AppleAHCIPort.kext back to it. Remember that it goes in S/L/E and you use Kext Wizard to apply it properly.
  3. Wish I could add to the title that this probably only works for Intel Panther Point chipsets! All that work, only to find an absence of hard drive in the OSX installer! This may be because your (probably laptop's) SATA mode is RAID and not AHCI. On many HP (probably other newer) laptops, the SATA mode is RAID. I'm not really sure why, but it makes our lives more difficult. And of course you cannot change this in the BIOS. NOTE: You may *think* you're in AHCI mode, if only because you just bought your laptop, but it could be RAID. We can safely rule out IDE mode if your laptop has Ivy Bridge, not sure about earlier Core setups but I imagine the same goes for at least Sandy Bridge. You also may have used one of the various methods of verifying AHCI mode as enabled through Windows. I got that too. My setup is an HP m6-1045dx with Ivy Bridge i5 and Panther Point (H77 - Series 7) chipset. I'm seeing a pattern with the Panther Points being RAID mode, so this just might be your fix. You need Kext Wizard, a computer running OSX (even if it's a Virtual Machine) and your U{censored} or myHack USB flash drive. Download the modified-for-RAID kext here and extract the zip. Note that the zip includes the modified and unmodified kext "AppleAHCIport", use the modified one. Select that modified kext and install it to System/Libraries/Extensions on your USB flash drive with Kext Wizard. Now try that installation again!
  4. Sorry, guys, email wasn't going through so I didn't get notifications to the replies! Someone over at another forum was nice enough to modify.... oh what was it, AppleAHCIport.kext - the m6-1045dx uses RAID for SATA mode, and effing HP can burn in hell for not letting us change that in BIOS. We don't need AHCI mode, but ultimately you have to change the device ID in the kext for the SATA controller, it should be 282a I think? I'll post some more info MOMENTARILY (for real this time!), I have to call up the messages on the other forum site. Thanks to eep357 over at InsanelyMac.com for patching this for me/us. https://dl.dropbox.com/u/12515989/untitled%20folder%202.zip Download that bad boy, replace the AppleAHCIport.kext with the one in the MODIFIED folder. Use Kext Wizard (Mac) to install the kext, you cannot just copy and paste it. It goes in System/Libraries/Extensions. And that's it, now you should be able to install OSX to your hard drive or SSD! Again, the original kext uses Device ID 282x (where x is a value that I forget), and the modified kext uses Device ID 282a, for laptops with BOISes locked to RAID SATA mode. I couldn't get System Info to work in goddamn Windows, either. I used a Linux live CD to just download and run it real quick, took a picture of it. Oddly, not all the devices are showing, it's not showing (whether I run it in Mac or Linux) the WiFi/bluetooth card, fingerprint reader, or the webcam. Of course all of those things are technically USB, they show up with lsusb and not lspsci in Terminal. I'll work towards posting it in the solutions thread, this hackintosh is my only computer and as you can imagine, I've had a few kernel panics, even had to reformat and reinstall once. Oh and yes, I have Panther Point (H77) for the chipset.
  5. Any other ideas then? I appreciate your help but I'd rather you didn't just throw random ideas out there...
  6. No dice... I think I need to modify the IOATAfamily.kext or the AppleSATAport.kext.....
  7. Thanks for the reply but.... GraphicsEnabler, would that really affect the SATA controller?
  8. I have an HP laptop with an HP 18A4 motherboard, Intel Ivy Bridge chipset and H77 SouthBridge. The problem is that my hard drive and Intel SSD are not being detected by myHack OSX USB installer, and I heard only certain Intel chipsets are natively supported by OSX... Furthermore, I read that I need to patch the AppleAHCIport.kext, which I see in the USB drive under System > Library > Extensions... So if possible, could someone patch it for me and link me to it, or walk me through patching it myself. I'm not sure what info is needed, but the hardware ID from Windows is PCI\VEN_8086&DEV_282A&SUBSYS_18A4103C&REV_04 (for the SATA controller) I also read that I may need to edit IOAHCIFamily.kext? Thanks! Here's a screenshot of the only SATA controller I see in Device Manager.
  9. Hey all, I finally got my flash drive to get me to the installer screen for OSX 10.8, however it is not detecting either my SATA HDD or SSD. We're talking about an m6-1045 HP laptop (Intel Core i5 Ivy Bridge, H77 SouthBridge, 8GB RAM) with a single SATA port for the hard drive. The BIOS is extremely limited because HP is a dick of a company that way, and so there are no settings for SATA as far as RAID, AHCI and IDE go. I am using a myHack-made flash drive, and I can run OSX in a Virtual Machine to modify the contents, including stuff in Extra, lib, etc, you know. Can I either boot with a flag or overwrite a driver, perhaps to make RAID or IDE mode work with OSX? I hear those exist, but maybe I need an HP-specific IOFamily.kext (is that what it's called?) Just as well, where do I put kexts? Like let's say I have a kext for the WiFi/Bluetooth card, do I put that...I think it's somewhere in Extra? Thanks for your help!
  10. Got it with cpus=1 Of course now my hard drive and SSD are not being detected. I think we can mark this thread as solved. Thanks for all the help, now to go create a thread for this new issue... Oh and it's actually ACIP, not ACPI..... Apologies but I don't think we'd have made it to cpus=1 any sooner.
  11. Well we already established that those flags do not work... Turns out VirtualBox ejected the myHack USB drive before it was done, that explains the errors on Page 4, I made it again and now I'm back where I was- Kernel Panic from ACPI. On a POS AMD machine I have laying around, it wouldn't even make it to the Apple splash screen before rebooting, if that helps at all, but really I think all that means is that it's a POS AMD machine...lol I can edit the crap out of this myHack USB drive, if I have to modify the chameleon.boot.plist or anything in Extra, maybe insert a fakeSMC.kext (which should already be on) I CAN DO IT, so if there's some kind of ACPI patch, I'd appreciate a link to it...
  12. You always say to do that, are you just throwing that out there, I mean do you know what the error I am getting is?
  13. Okay myHack now boots, but it gave me an error couldn't find mach_kernel, so I downloaded one for HP i5 laptops... now it boots to the white Apple splash but USB activity stops... So I -v boot flagged and I get... well I'll upload the pic here... I'm not uploading a pic, but here's the error: couldn't find symbol __ZNBIOMapper18_RESERVEDIOMAPPER3Ev and it gives me this error for a plethora of items, AppleUSBComposite, ApplePS2, I mean a lot of things... And then it stops listing those and starts listing Still waiting for root device Still waiting for root device Still waiting for root device And it just adds one of those lines of Still waiting for root device every minute or so...
  14. Woo, Friday night, here we go! I'll keep you guys informed, but I remain optimistic.
  15. Well VirtualBox is being a dick, so much so that I'm just about ready to say fuck it and go to Linux. Buuuuuuuuuut I'm hanging in there, after all I need the program compatibility of a mainstream OS. Even if that means reinstalling EVERYTHING, I ought to anyway, since OSX successfully boots in VirtualBox about half the time. Jesus Christ. Thanks again for the help all, I'm reinstalling now so stay tuned!
  16. I can make a bootable USB drive just fine, I just get a kernel panic..
  17. Myhack wont even boot... lime it doesn't get detected as a boot device.
  18. Oh, sorry- it shows up as a reply to a quote to an already-existing post. I'll look into it now that the VM is back up. Full specs? It's an HP m6-1045dx with in Intel Ivy Bridge 3210m i5, 8GB of some BA Lynux (sp?) RAM that Windows gives a high performance score, Intel chipset, Intel 240GB 330 SSD, Intel HD Audio, I mean it's all Intel, really.... Sorry, I'm not sure exactly what you need to know. And I'll give it another go with "No"
  19. Gotcha, thanks. Negative on that DSDT=NO bootflag. The panic happens right after that Apple logo pops up, I mean it's gotta be something serious but obvious... At the same time, this is just the U{censored}, not the actual install. And using Hackboot 1 and 2 to boot U{censored} doesn't solve the problem. :/
  20. Anyway, as I said, I gave all of those bootflags individual tries to no avail. DSDT= NO is something to try, though- is there a space after the equal sign? And just a friendly reminder, the kernel panic refers to ACPI! Thanks again for all the help.
  21. Honestly, I don't know. I didn't put a DSDT in /Extra, so does U{censored} come with one?
  22. Well... I mean I don't know what the problem is, it *could* be DSDT, but I was hoping you knew for sure.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.