Jump to content

montag

Members
  • Content Count

    43
  • Donations

    $0.00 
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by montag

  1. ? @Chanelle, ? I initially followed pokenguyen's tutorial (pretty good I might add) for an E7440, but I've been unable to get QE/CI (graphics acceleration) working properly. Looks like our model shares almost identical specs. Have you had any luck??
  2. That's what I thought. I guess I will hold off until I hear back from him.
  3. Where are we at on the DSDT?
  4. Have you been able to get your wifi card working yet? If the VooDooHDA doesn't cause KPs, I'll install tonight.
  5. @David does the audio work now or does it still give KPs? I noticed it looks like you're recommending a different audio kext in the guide.
  6. I am upgrading to it now. I suggest everyone else does then. Good deal gsavoldi, thank AJ for the bios info. I would start with removing the geforce kexts like in the guide.
  7. I would go ahead and update to F.26. Sounds like 24 is buggy. You might wait for AJ to verify this but I think it's safe. Make sure your computer is plugged in and you don't have any extra windows programs open, etc so your computer doesn't brick if the flash fails. I can't be responsible for that, obviously. Heed HP's warnings.
  8. Can everyone post what bios they are running? @david @gsavoldi @aj. I'll check after I'm done rendering a cat. Update: Looks like I'm running F.23. I'm game for updating to 26.
  9. Yes, I did. Once I deleted the geforce kexts and set up the SMBios, I think that was what fixed it. @gsavoldi Did you try deleting the geforce kexts and setting up the SMBios like in David's guide? Also, what is the last line you see when you have the verbose (-v) flag? Like what does it freeze on? That way we might be able to figure out where it's hanging at. Also, is your display full HD? That might have something to do with it, since mine is 720p or 1366x768.
  10. Will do man. Good luck. I have a few finals and some 3d rendering to do. I think 10.8.2 works fyi, since that's what I'm on I believe. I can double check.
  11. Indeed we might have to make our own anyway, but maybe we should all consider updating to the latest bios for simplicity. I think it's F.23 if I'm not mistaken. I haven't noted any changes or problems with it since I updated from my older one. I guess that's up to the user, though personally I don't see something not working between bios revisions. Also AJ, it's good to have you back. I'm sorry about what happened--I had an ex gf go through a similar circumstance...it was rough. For the record, I can boot with zero flags and so far, zero KPs. I used david's guide. I wasn't able to boot 10.8.3 after a clean install (which installed without issues, but couldn't boot), however you might have better luck.
  12. USB 2.0 flash speeds are much, much slower than USB 3.0. If you run it off an external hard drive, you're getting almost SATA level performance, whereas with USB 2.0, you're probably getting 7-27 mb/s read/write, which is pretty miserable.
  13. Actually man, there is a way to edit the kext files in windows. My macbook pro came with boot camp drivers that made HFS+ partitions editable and viewable in windows just like you'd think like an NTFS partition. If you install the latest boot camp drivers, you should be able to edit your HFS partition. I have done this and got it to work successfully on my Probook and my hackintosh desktop. @David- The computer world is pretty vast. You'll be able to find something interesting, I'm sure. As a senior CS college student I have limited time on stuff like this and spend most of my time programming as required by my major. My story is pretty similar as well--started building computers from dead ones when I was 12 and had no internet and no idea what I was doing. I've learned more that way in every subject by trial and error than watching a professor babble away. Don't get me wrong; school is important, but it can't carry you as far as self-motivation in the long term. However, in this day and age, you MUST have a 4 year degree if you hope to live not as a popper. On a related note, I have the atheros wifi card from my Probook installed but it is not being recognized, I'm guessing because I need to drop in a kext or something. If I get time, I'll try to do that this week. Still keeping away from audio per david since I hear it is causing KPs, unless this has changed?
  14. It looks like a very similar model... I'll bet the power management would work and most everything else, including the Intel HD 4000 graphics... maybe you can help us test.
  15. What's your exact model #? You might have to have a different DSDT and cpu management w/ lapic fix but some work might carry over.
  16. Is it causing a kernel panic or just not working?
  17. So David, Again, awesome with the progress on this. I just got back from South Padre and re-carboned copied my 10.8.2 install. I followed your guide and now I have a working system with HD4000 graphics and 4 cores, although it appears to be running at 3.09 GHz and not 2.3. It boots with no flags now (thanks!). Only thing I didn't do was follow iGabriel's directions with the lapic fix starting at #6, I did the five before that and followed your directions in the tut for rebuilding the kernel: 6- rebiuilding the system cache *Move ll kexts from /extra/extensions/ to system/library/extensions/ i used kext wizard *add this to org.chameleon.Boot.plist <key>UseKernelCache</key> <string>yes</string> *in terminal do the following sudo chown -R root:wheel /system/library/extensions sudo chmod -R 755 /system/library/extensions sudo touch /system/library/extensions I am not sure what he means by the 11 kexts from /extra because I only have three files in my /Extra folder and no extensions folder. No KPs so far. I am trying to take it easy on it in the hopes that it wont KP (knock on wood). After a few days of testing I'll try to get the audio working. Also, I threw in my Wifi card from my Probook and it didn't get the wifi working off the bat. Not sure what I have to do to get it working... probably using a dsdt would help or there was some tweak in the probook installer package that got it working... So far, so good. Even if we don't get the Nvidia card working, we have come quite a long way. This build is still much faster than the aging Probook build, and it is simply a better system all around. I hope it will be stable enough to replace it maybe one day, or at least add it to the Best Hackintosh Laptops of 2013. Apparently the keyboard backlight works, as does the camera, on a side note.
  18. When I try to boot the 10.8.3 installer now it is giving the following error: Kext com.apple.driver.AppleSMCPdrc - library kext com.apple.driver.IOPlatformPluginFamily not found. Kext com.apple.driver.AppleSMCPDRC failed to load etc etc etc and then it kernel panics. Using the -v cpus=1 and GraphicsEnabler=No flags, as well as tried PCIRootUID=0. I have a working backup of 10.8.2 on a separate drive so I'm not panicking or anything. I want to see how far you get before I reload it though. Interestingly, I had no issue with upgrading my gigabyte ga ep45 ud3p to 10.8.3 via the app store. On a semi related note, I noticed this and I know the architecture might be slightly different and there is obviously not direct compatibility, but the 15" retina model has an identical GPU as mine. I am assuming it has to do some form of graphics switching like ours does because it has both Intel Graphics 4000 and the GT 650M 1 GB. Why can't we steal that somehow? Really wish I had a friend with a Retina MBP. http://store.apple.com/us/browse/home/shop_mac/family/macbook_pro
  19. Ok. So I backed up the old installer and am currently redownloading 10.8.3. I'll report back with how it goes.
  20. Let me know how it goes. I will probably reinstall. Do you just re-download it from the app store to get 10.8.3?
  21. So I don't recommend installing the update because I can't get it to boot now post combo update, with any combination of flags. If you get rid of the cpus=1 flag it kernel panics and if you get rid of GraphicsEnabler=No it gets stuck on the nvidia graphics. With all the flags I used previously it gets stuck on USBMSC Identifier (non-unique):.... Still waiting for root device Still waiting for root device I had to switch hard drives. Maybe this one has bad sectors. It doesn't click though, and the drive booted pre update.
  22. Do you think this might help us at all with our graphics issue? I wonder if they are doing intelligent switching now... {censored} - OS X 10.8.3 Update
  23. How do i make an snbios for 9.1 exactly?
  24. Now it thinks its 3.06 for some reason (I didn't change anything since the last boot). Here are some pictures of what it says: http://sdrv.ms/YWCPCo
  25. I'm trying to follow this guide: How to make your own DSDT with DSDT Editor And I can't find the board patch.. I am assuming we will have to do this manually. There are a crap ton of Gigabyte board DSDT patches.. I know now why they are so supported... olarila.com ? User Control Panel ? Login Attached is my extracted DSDT. Also I installed chameleon locally on the drive that boots and I can't get it to boot like david without the U{censored} flash drive. Not sure why either. Lastly, I saw this article: http://www.{censored}.com/289-apple-s-new-mac-minis-have-ivy-bridge-mobile-cpus.html If the Mac Mini runs the 3615QM and obviously recognizes it, is there a way to somehow take the way that OS X identifies our processors as a 3610QM? The only difference between the two is the Graphics Max Dynamic Frequency which is 1.1 for the 10 and 1.2 for the 15. The sockets and the packet sizes are different as well as Intel® Virtualization Technology for Directed I/O (VT-d) Yes on one and Intel® Trusted Execution Technology No and vise versa on the other one. I feel like that might be enough for someone to hunt down and jack the kext/dsdt and whatever is needed to fully recognize our chip. Here are the ARK links: http://ark.intel.com/products/64899/Intel-Core-i7-3610QM-Processor-6M-Cache-up-to-3_30-GHz http://ark.intel.com/products/64900/Intel-Core-i7-3615QM-Processor-6M-Cache-up-to-3_30-GHz UPDATE: I think I did one better. If you search "3610QM macbook pro" in google, you can see that some of the retina models had the same processor we do. Shouldn't that help us recognize our cpus somehow? dsdthpi7.zip
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.