Jump to content

m.gbt

Moderators
  • Content Count

    525
  • Donations

    $0.00 
  • Joined

  • Last visited

  • Days Won

    15

Everything posted by m.gbt

  1. You are right, there was something bad in the config.plist and your fix works indeed! I'm not sure how I didn't spot this before, maybe when I installed El Capitan I already had an updated config.plist and didn't try the one provided in this guide. Sorry I've never tried this system with Sierra. Chances are the guide would need to be updated. It doesn't perform anything, as written in the guide we're only keeping it because the DSDT makes some references to registers that are defined in SSDT-1. And because we've opted in Clover to drop all SSDTs, if we don't add this file we're effectively not loading any of its contents, which would end up making our DSDT point to invalid references. I don't have it anymore either, sorry. That's great to know, thank you very much for your contribution! At the time of writing this guide, I didn't try disassembling the laptop completely, so I had always believed that the Centrino board was integrated but actually it can be replaced like you correctly pointed out.
  2. Unplug everything that you have connected to your USB ports and try again. If it works, then try to isolate which USB device is causing the problem, in my case it is my WiFI dongle, in your case I'd say it is probably your bluetooth dongle. Both for sleep and shutdown, I must first take it off... Still no definitive solution found for this.
  3. Thanks, I'll give it a try so far I had always thought that the Configurator was perfect... lol Allan, no, unfortunately the MacBook4,1 is completely different of MacBookAir4,1 ? edit: great, champlist really was the solution. However, it doesn't have as much information as Clover Configurator does, so some of them I had to Google a little (BiosReleaseDate,?BoardType,?ChassisAssetTag)
  4. I've been studying into details the SMBIOS configuration in the last days and something I always wondered was: why my SMBIOS is detected as MacBookPro8,1 if the only laptop ever produced by Apple containing my exact processor is the MacBook Air 11-inch Mid 2011:?https://support.apple.com/kb/SP631?locale=en_US&viewlocale=en_US In a Brazilian Apple page I found it to be MacBookAir4,1 however this SMBIOS doesn't exist in Clover Configurator (there are only 5,2 and 6,2 for the MBA). So maybe that's why it was always detected as a MacBookPro8,1, as?among the existent?it is the best SMBIOS. Is there an alternative way to follow in these cases? ? Thanks!
  5. The guide now supports El Capitan! ? I've been using ElCap in a secondary partition since Public Beta and the USB 3.0 port is working again only since latest public release (10.11.2). You'll need the latest GenericUSBXHCI though, which you can always find at?RehabMan's repo. The guide now contains information about loading unsigned kexts on El Capitan. ? Currently, IMO the system is still not good for everyday use on El Capitan,?because sleep/wake is not working, even after having set some special parameters so that the PC should never sleep deeply... When it sleeps, after some minutes it reboots itself :/ If you don't mind to run "caffeinate" command to keep it awake, then go ahead, El Capitan is running great
  6. go into System Preferences > Network and remove all interfaces (the "minus" button), then add a new one selecting Ethernet. that should be it... otherwise the kext wasn't correctly installed. gl
  7. the AppleBacklightInjector method is useless with this laptop, for El Capitan you must use the newest ACPIBacklight and that's all the rest is the same as on the guide
  8. Hello Nscxp2005, I haven't had time since the GM release but I believe the same workings and not workings remain. Unfortunately wake after sleep is not working either, and that together with the USB3 port makes me feel that the system is just not stable enough for daily usage. That's why I didn't update the guide. I will if someday I find a fix at least for the wake issue, however I'm kinda hopeless about it because the fix applied to Mavericks should work for every release, but doesn't for ElCap...
  9. Running 10.11 GM with the very same working/not working from 10.9, except for USB 3.0 which might never work I'll wait for 10.11 final release to update the guide, I believe there will be no need to create a new one because almost everything is the same or can be adapted to work for both versions.
  10. So, today I was going to install El Capitan GM over a Public Beta 6 installation I have in a secondary partition, and usually I would do that by booting an USB installer, but this time unfortunately I decided to try a new thing. I've just opened the .app downloaded from the App Store and clicked to install to that drive. After about a minute, the system restarted and then it wouldn't boot anymore from Clover... I'm using v3259 both on my SSD's EFI partition and my USB drive. Tried many things like adding slide=0 and booting without caches, but nothing would work, neither the installation contained in the USB drive, nor my current stable Mavericks main partition. When booting verbose, it always presented the error in the title of this topic. Ended up solving it by replacing the following files in my USB Clover with a just downloaded Clover v3259 ISO from a Linux Live USB: EFI/BOOT/* EFI/CLOVER/*.efi Also replaced EFI/CLOVER/Drivers64Uefi/OsxAptioFixDrv by OsxAptioFix2Drv and deleted the folder EFI/APPLE. Probably the most important was using OsxAptioFix2, remains to be tested... If someone ever gets this error, please try just replacing OsxAptioFix and report if successful Once I did that, I booted into USB's Clover and it booted fine the El Capitan installation. It automatically proceeded the installation that I had begun before. ? edit: this issue could have been corrected by Clover v3264, also remains to be tested!
  11. Do you have any failure symptom because of this or you just want to eliminate the error from your system log? There will always be some errors in a hackintosh log simply because you don't have all the hardware a real Mac does, so if it doesn't represent an issue then you should just chill about it
  12. I'm not sure but maybe you already have some related kexts in the /System/Library/Extensions folder ..? Please run this command and see if it returns something: ls /System/Library/Extensions/ | grep RTL8I will have to add an uninstaller script if this is the reason of the failure. Thanks!
  13. I don't know about modified systems such as iatkos... We don't know what modifications were made so we can never be sure if it is because of them or not.
  14. Hi! I believe the only file you need to remove before installing the new files is RtWlanU.kext You can do that by running the following commands: cd /System/Library/Extensionssudo kextunload RtWlanU.kextsudo rm -r RtWlanU.kext
  15. the update itself took 30 minutes here on a kinda slow HDD. updated flawlessly, no need to reinstall FakeSMC and stuff...
  16. Version 1827.4.05142015 / 2.3.11

    13,007 downloads

    All credits go to vbin. I've just repackaged it in order to make it installable under El Capitan. Universal driver for Mac OS X 10.x.x. Only one drive for many Wireless USB Adapters on the chip Realtek The list of supported devices and chips: The package includes: 1.RtWlanU.kext 2.Wireless Network Utility 3.Icon app in the status bar and a separate utility to delete old files.
  17. @vbin do you know where does the Wireless Network Utility store the network profiles?
  18. I can't say about all versions but apparently the app and the kexts are kind of disconnected things. Just like on Windows you would have a driver and a manager app. I've used multiple versions of Realtek kexts and the utility and so far they work fine together.
  19. for the brightness, have you tried RehabMan's AppleBacklightInjector method? if not working, go for ACPIBacklight
  20. for instance, you don't need kernel extensions for AHCI as far as I know, you can patch it with Clover. it works fine for me, at least! <key>KernelAndKextPatches</key>????<dict>????????<key>KextsToPatch</key>????????<array>????????????<dict>????????????????<key>Comment</key>????????????????<string></string>????????????????<key>Find</key>????????????????<data>????????????????RXh0ZXJuYWw=????????????????</data>????????????????<key>Name</key>????????????????<string>AppleAHCIPort</string>????????????????<key>Replace</key>????????????????<data>????????????????SW50ZXJuYWw=????????????????</data>????????????</dict>????????</array>????</dict>
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.