Jump to content

TwisterChoc

Members
  • Content Count

    7
  • Joined

  • Last visited

About TwisterChoc

  • Rank
    Newbie

Recent Profile Visitors

673 profile views
  1. TwisterChoc

    AMD Radeon HD 7xxx & R9 Series Graphics Drivers For Mavericks 10.9.x

    Hi. I´ve installed Yosemite GM C1 with the your ?injection DSDT, but i don´t have the same video card performance than mavericks: Novabench GPU test: 1700 fps (mavericks) Novabench GPU test: 700 fps (yosemite) Is there any solution for that? Thanks. My specs: Xeon E5 2609 v2 Gigabyte X79 UD3 rev 1.1 Gigabyte R9 270x
  2. TwisterChoc

    AMD Radeon HD 7xxx & R9 Series Graphics Drivers For Mavericks 10.9.x

    Thank you very much Deekay! It works perfectly with my dual display setup, one led cinema via display port and the other hp 23xi via hdmi
  3. TwisterChoc

    AMD Radeon HD 7xxx & R9 Series Graphics Drivers For Mavericks 10.9.x

    Hi, thanks for you work!! ? My system specs: ? Xeon E5 2609 v2 Gigabyte X79 UD3 rev 1.1 Gigabyte R9 270x Mavericks 10.9.3? Here you are my ioreg and dsdt files?https://drive.google.com/file/d/0ByNcoAcBCrmFTk03bjlhZzdYVlE/edit?usp=sharing Can you help me with that?
  4. TwisterChoc

    AMD Radeon R9 270 Series

    Hi, I've two monitors on my system, one connect via hdmi and the other via displayport. With the original 10.9.3 kexts the dport monitor works great but the hdmi´s goes blackscreen (sleep) Withyour 1.6b or 1.7 drivers the hdmi monitor works great and the display port' s goes blackscreen (sleep) There is a way to get video on both monitors? (Sleep trick doesn´t work for me) My specs: OSX 10.9.3 Xeon E5 2609 Gigabyte X79 UD3 mobo Gigabyte R9 270x 60fps ?cinebench benchmark
  5. TwisterChoc

    AMD Radeon R9 270 Series

    Hi! The driver works fine on hdmi port but on the display port ?the screen goes black at login screen and for me the sleep trick does not work. The problem is ?my apple led cinema display monitor only has a mini-display port and I think there´s ?no adapters :_( Thanks anyway, if there's something I can contribute or help please do not hesitate to ask.? Is there any way to fix the black screen issue?? Thanks a lot. My specs: Mavericks 10.9.2 with myHack? Chameleon Bootloader Gigabyte X79-UD3 mobo Gigabyte R9 270x 2GB GDDR5 Xeon E5-2609v2
  6. TwisterChoc

    AMD Radeon R9 270 Series

    Hi! Thanks for your support, and please sorry my scrappy english. ? I´ve reinstall entire system 10.9.2 with myhack, postinstall adding mobo kexts and reboot normaly, then install atyinjector from your pack and can´t boot without -x flag and lost sound. About this mac shows me this: AMD Radeon R9 270 Series 8 MB AMD Radeon R9 270 Series: ? ? Modelo de chipset: AMD Radeon R9 270 Series ? Tipo: GPU ? Bus: PCIe ? Ranura: Slot-1 ? Anchura de canal PCIe: x16 ? VRAM (total): 8 MB ? Fabricante: ATI (0x1002) ? ID del dispositivo: 0x6810 ? ID de la revisión: 0x0000 ? Revisión de la ROM: AMD Curacao XT ? Versión del driver EFI: 01.00.318 ? Pantallas: Pantalla: ? Resolución: 1920 x 1200 ? Profundidad de píxel: Color de 32 bits (ARGB8888) ? Pantalla principal: Sí ? Duplicado: Desactivado ? En línea: Sí ? No fakesmc in /Extra/Extensions/ so Kext wizard show this smc kexts: org.netkas.FakeSMC (1111) com.apple.driver.AppleSMC (3.1.8) com.apple.driver.ACPI_SMC_PlatformPlugin (1.0.0) my new dsmg: ? Longterm timer threshold: 1000 ms PMAP: PCID enabled PMAP: Supervisor Mode Execute Protection enabled Darwin Kernel Version 13.1.0: Thu Jan 16 19:40:37 PST 2014; root:xnu-2422.90.20~2/RELEASE_X86_64 vm_page_bootstrap: 986260 free pages and 54124 wired pages kext submap [0xffffff7f807a6000 - 0xffffff8000000000], kernel text [0xffffff8000200000 - 0xffffff80007a6000] zone leak detection enabled "vm_compressor_mode" is 4 standard timeslicing quantum is 10000 us standard background quantum is 2500 us mig_table_max_displ = 74 TSC Deadline Timer supported and enabled SAFE BOOT DETECTED - only valid OSBundleRequired kexts will be loaded. "name" not a kext "Kernel-__SYMTAB" not a kext NullCPUPowerManagement::init: properties=0xffffff800b2e1640 NullCPUPowerManagement::start AppleKeyStore starting (BUILT: Jan 16 2014 20:19:00) AppleACPICPU: ProcessorId=0 LocalApicId=0 Enabled AppleACPICPU: ProcessorId=1 LocalApicId=2 Enabled AppleACPICPU: ProcessorId=2 LocalApicId=4 Enabled AppleACPICPU: ProcessorId=3 LocalApicId=6 Enabled calling mpo_policy_init for Sandbox Security policy loaded: Seatbelt sandbox policy (Sandbox) calling mpo_policy_init for Quarantine Security policy loaded: Quarantine policy (Quarantine) calling mpo_policy_init for TMSafetyNet Security policy loaded: Safety net for Time Machine (TMSafetyNet) Copyright ? 1982, 1986, 1989, 1991, 1993 The Regents of the University of California. All rights reserved. ? MAC Framework successfully initialized using 16384 buffer headers and 10240 cluster IO buffer headers Unsynchronized ?TSC for cpu 1: 0x0000038a899c9883, delta 0x378b848eac0 Unsynchronized ?TSC for cpu 2: 0x0000038a8a2a9557, delta 0x378b848eaa0 Unsynchronized ?TSC for cpu 3: 0x0000038a8ab00b34, delta 0x378b848eaa5 Current tsc from rdtsc64() is 76596595383. Rendezvouing.. IOAPIC: Version 0x20 Vectors 64:87 ACPI: sleep states S3 S4 S5 pci (build 20:00:24 Jan 16 2014), flags 0x61008, pfm64 (44 cpu) 0xfff80000000, 0x80000000 [ PCI configuration begin ] console relocated to 0xe0000000 [ PCI configuration end, bridges 11, devices 19 ] RTC: Only single RAM bank (128 bytes) [ PCI configuration begin ] [ PCI configuration end, bridges 12, devices 53 ] USBF: ? ?2.177 ? ?AppleUSBXHCI::CheckSleepCapability - controller will be unloaded across sleep USBF: ? ?2.177 ? ?AppleUSBXHCI::CheckSleepCapability - controller will be unloaded across sleep USBF: ? ?2.177 ? ?AppleUSBXHCI::CheckSleepCapability - controller will be unloaded across sleep USBF: ? ?2.177 ? ?AppleUSBXHCI::CreateRootHubDevice ?Bus 14 already taken USBF: ? ?2.188 ? ?AppleUSBXHCI::CheckSleepCapability - controller will be unloaded across sleep USBF: ? ?2.191 ? ?AppleUSBXHCI::CreateRootHubDevice ?Bus 14 already taken mcache: 4 CPU(s), 64 bytes CPU cache line size mbinit: done [64 MB total pool size, (42/21) split] Pthread support ABORTS when sync kernel primitives misused rooting via boot-uuid from /chosen: 2E7E8975-8F1D-34D3-8B53-2419336C3F4A Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict> com.apple.AppleFSCompressionTypeDataless kmod start com.apple.AppleFSCompressionTypeZlib kmod start com.apple.AppleFSCompressionTypeDataless load succeeded com.apple.AppleFSCompressionTypeZlib load succeeded Got boot device = IOService:/AppleACPIPlatformExpert/[email protected]/AppleACPIPCI/[email protected],2/AppleAHCI/[email protected]/[email protected]/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice/IOBlockStorageDriver/OCZ-AGILITY4 Media/IOGUIDPartitionScheme/Macintosh [email protected] vendor:device: 0x8086:0x1503. AppleIntelE1000e(Info): Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode AppleIntelE1000e(Info): changing MTU from 0 to 1500 BSD root: disk0s2, major 1, minor 2 jnl: b(1, 2): replay_journal: from: 13808640 to: 15071232 (joffset 0x774000) jnl: b(1, 2): journal replay done. AppleIntelE1000e(Info): AppleIntelE1000e:WOL = 2 hfs: mounted Macintosh HD on device root_device hfs: Removed 2 orphaned / unlinked files and 6 directories? flow_divert_kctl_disconnect (0): disconnecting group 1 SMC::smcReadKeyAction ERROR $Num kSMCKeyNotFound(0x84) fKeyHashTable=0x0 SMC::smcReadKeyAction ERROR LsNM kSMCKeyNotFound(0x84) fKeyHashTable=0x0 SMC::smcGetLightshowVers ERROR: smcReadKey LsNM failed (kSMCKeyNotFound) SMC::smcPublishLightshowVersion ERROR: smcGetLightshowVers failed (kSMCKeyNotFound) SMC::smcInitHelper ERROR: smcPublishLightshowVersion failed (kSMCKeyNotFound) Previous Shutdown Cause: 3 SMC::smcInitHelper ERROR: MMIO regMap == NULL - fall back to old SMC mode Waiting for DSMOS... VM Swap Subsystem is ON ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out WARNING: IOPlatformPluginUtil : getCPUIDInfo: this is an unknown CPU model 0x3e ? -- power management may be incomplete or unsupported ATY_Init: Starting ATY_Init: Checking dev-id 6810 ATY_Init: Card 0x6810 was posted ATY_Init: Card was posted, reading rom from legacy address ATY_Init: Quiting for card 0x6810 ATY_Init: Starting DSMOS has arrived ATY,Futomaki: Not usable ATY,Futomaki: Not usable ATY,Futomaki: Not usable ATY,Futomaki: Not usable AppleIntelE1000e(Info): e1000e NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx AppleKeyStore:Sending lock change 0 hfs: summary table not allowed on FS with block size of 2048 hfs: could not initialize summary table for Google Chrome hfs: mounted Google Chrome on device disk3s2 Resetting IOCatalogue. ATY_Init: Starting CoreServicesUIAg[318] Unable to quarantine: 93 ? ? ? ? ?0 [Level 5] [Facility messagetracer] [com.apple.message.domain com.apple.kernel.cs.mismatch] [com.apple.message.signature 1000] [com.apple.message.signature2 3345639bd98273913ff25086fe0151f45fea0fa3] [com.apple.message.signature3 38872323d4adae2cb310de88ceeeae695630ffd7] [com.apple.message.summarize YES]? ? ? ? ? ?0 [Level 5] [Facility messagetracer] [com.apple.message.domain com.apple.kernel.cs.invalidate] [com.apple.message.signature invalidate] [com.apple.message.signature4 338] [com.apple.message.signature3 ksadmin] [com.apple.message.summarize YES]? CODE SIGNING: cs_invalid_page(0x1000): p=338[ksadmin] final status 0x0, allowing (remove VALID) page ? ? ? ? ?0 [Level 5] [Facility messagetracer] [com.apple.message.domain com.apple.kernel.cs.invalidate] [com.apple.message.signature invalidate] [com.apple.message.signature4 342] [com.apple.message.signature3 ksadmin] [com.apple.message.summarize YES]? CODE SIGNING: cs_invalid_page(0x1000): p=342[ksadmin] final status 0x0, allowing (remove VALID) page ? ? ? ? ?0 [Level 5] [Facility messagetracer] [com.apple.message.domain com.apple.kernel.cs.mismatch] [com.apple.message.signature 1000] [com.apple.message.signature2 53a18aae61685cc356b171ce37cc504048ed45a1] [com.apple.message.signature3 b928c695e1e1a867d5fc392eb8f09e460f3139af] [com.apple.message.summarize YES]? ? ? ? ? ?0 [Level 5] [Facility messagetracer] [com.apple.message.domain com.apple.kernel.cs.invalidate] [com.apple.message.signature invalidate] [com.apple.message.signature4 341] [com.apple.message.signature3 GoogleSoftwareUp] [com.apple.message.summarize YES]? CODE SIGNING: cs_invalid_page(0x1000): p=341[GoogleSoftwareUp] final status 0x0, allowing (remove VALID) page ? ? ? ? ?0 [Level 5] [Facility messagetracer] [com.apple.message.domain com.apple.kernel.cs.invalidate] [com.apple.message.signature invalidate] [com.apple.message.signature4 343] [com.apple.message.signature3 ksadmin] [com.apple.message.summarize YES]? CODE SIGNING: cs_invalid_page(0x1000): p=343[ksadmin] final status 0x0, allowing (remove VALID) page process Google Chrome He[348] caught causing excessive wakeups. Observed wakeups rate (per sec): 221; Maximum permitted wakeups rate (per sec): 150; Observation period: 300 seconds; Task lifetime number of wakeups: 45218 SMC::smcReadKeyAction ERROR F0Ac kSMCBadArgumentError(0x89) fKeyHashTable=0x0xffffff800e2df600
  7. TwisterChoc

    AMD Radeon R9 270 Series

    Thank for your work. ? I´ve installed 10.9.2 properly with myHack ?and get correct cpu support, sound and ethernet but no graphics accel, after that I´ve installed your radeon 1.5v ?I can only boot with -x flag , lost sound and still with no graphics accel. Please can you help to get that? ? My specs: Gigabyte X79-UD3 mobo LGA2011 socket Xeon E5-2609v2 Gigabyte R9 270x No DSDT or SSDT ? dmesg log: ? Longterm timer threshold: 1000 ms PMAP: PCID enabled PMAP: Supervisor Mode Execute Protection enabled Darwin Kernel Version 13.1.0: Thu Jan 16 19:40:37 PST 2014; root:xnu-2422.90.20~2/RELEASE_X86_64 vm_page_bootstrap: 986012 free pages and 54372 wired pages kext submap [0xffffff7f807a6000 - 0xffffff8000000000], kernel text [0xffffff8000200000 - 0xffffff80007a6000] zone leak detection enabled "vm_compressor_mode" is 4 standard timeslicing quantum is 10000 us standard background quantum is 2500 us mig_table_max_displ = 74 TSC Deadline Timer supported and enabled SAFE BOOT DETECTED - only valid OSBundleRequired kexts will be loaded. "name" not a kext "Kernel-__SYMTAB" not a kext NullCPUPowerManagement::init: properties=0xffffff800b2b3500 NullCPUPowerManagement::start AppleKeyStore starting (BUILT: Jan 16 2014 20:19:00) FakeSMCKeyStore: started AppleACPICPU: ProcessorId=0 LocalApicId=0 Enabled AppleACPICPU: ProcessorId=1 LocalApicId=2 Enabled AppleACPICPU: ProcessorId=2 LocalApicId=4 Enabled AppleACPICPU: ProcessorId=3 LocalApicId=6 Enabled calling mpo_policy_init for Sandbox Security policy loaded: Seatbelt sandbox policy (Sandbox) calling mpo_policy_init for Quarantine Security policy loaded: Quarantine policy (Quarantine) calling mpo_policy_init for TMSafetyNet Security policy loaded: Safety net for Time Machine (TMSafetyNet) Copyright ? 1982, 1986, 1989, 1991, 1993 The Regents of the University of California. All rights reserved. ? MAC Framework successfully initialized using 16384 buffer headers and 10240 cluster IO buffer headers Unsynchronized? TSC for cpu 1: 0x0000041960531aad, delta 0x4022a6ef715 Unsynchronized? TSC for cpu 2: 0x0000041960da5229, delta 0x4022a6ef6f5 Current tsc from rdtsc64() is 99756364276. Rendezvouing.. FakeSMC v6.0.1058 Copyright 2013 netkas, slice, usr-sse2, kozlek, navi, THe KiNG, RehabMan. All rights reserved. FakeSMC: 13 preconfigured keys added IOAPIC: Version 0x20 Vectors 64:87 ACPI: sleep states S3 S4 S5 pci (build 20:00:24 Jan 16 2014), flags 0x61008, pfm64 (44 cpu) 0xfff80000000, 0x80000000 [ PCI configuration begin ] console relocated to 0xe0000000 [ PCI configuration end, bridges 11, devices 19 ] RTC: Only single RAM bank (128 bytes) [ PCI configuration begin ] [ PCI configuration end, bridges 12, devices 53 ] OSMetaClass: Kext org.netkas.FakeSMC class FakeSMC is a duplicate;kext org.netkas.driver.FakeSMC already has a class by that name. Kext org.netkas.FakeSMC start failed (result 0xdc00400a). Kext org.netkas.FakeSMC failed to load (0xdc008017). Failed to load kext org.netkas.FakeSMC (error 0xdc008017). FakeSMC v6.0.1058 Copyright 2013 netkas, slice, usr-sse2, kozlek, navi, THe KiNG, RehabMan. All rights reserved. FakeSMC: 16 preconfigured keys added USBF:? ? 2.263? ? AppleUSBXHCI::CheckSleepCapability - controller will be unloaded across sleep USBF:? ? 2.263? ? AppleUSBXHCI::CheckSleepCapability - controller will be unloaded across sleep USBF:? ? 2.284? ? AppleUSBXHCI::CheckSleepCapability - controller will be unloaded across sleep USBF:? ? 2.288? ? AppleUSBXHCI::CreateRootHubDevice? Bus 14 already taken USBF:? ? 2.289? ? AppleUSBXHCI::CheckSleepCapability - controller will be unloaded across sleep USBF:? ? 2.293? ? AppleUSBXHCI::CreateRootHubDevice? Bus 14 already taken USBMSC Identifier (non-unique): 93D12089FD8ACE10F8C06F09 0x930 0x6544 0x100, 2 FakeSMC: [Fatal] failed to initialize SMC device FakeSMC v6.0.1058 Copyright 2013 netkas, slice, usr-sse2, kozlek, navi, THe KiNG, RehabMan. All rights reserved. FakeSMC: 13 preconfigured keys added FakeSMC: [Fatal] failed to initialize SMC device SMC: successfully initialized CPUSensors: CPU family 0x6, model 0x3e, stepping 0x4, cores 4, threads 4, TJmax 89 CPUSensors: setting platform keys to [d8? ? ? ] CPUSensors: base CPU multiplier is 25 CPUSensors: RAPL units power: 0x3 energy: 0x10 time: 0xa CPUSensors: started mcache: 4 CPU(s), 64 bytes CPU cache line size mbinit: done [64 MB total pool size, (42/21) split] Pthread support ABORTS when sync kernel primitives misused SuperIODevice: found ITE IT8728F on port=0x2e address=0xa30 com.apple.AppleFSCompressionTypeDataless kmod start rooting via boot-uuid from /chosen: E65130C9-17EB-3752-93EA-DC41DDC2E0C9 IT87xxSensors: started com.apple.AppleFSCompressionTypeZlib kmod start Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict> com.apple.AppleFSCompressionTypeDataless load succeeded com.apple.AppleFSCompressionTypeZlib load succeeded vendor:device: 0x8086:0x1503. AppleIntelE1000e(Info): Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode AppleIntelE1000e(Info): changing MTU from 0 to 1500 Got boot device = IOService:/AppleACPIPlatformExpert/[email protected]/AppleACPIPCI/[email protected],2/AppleAHCI/[email protected]/[email protected]/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice/IOBlockStorageDriver/OCZ-AGILITY4 Media/IOGUIDPartitionScheme/Macintosh [email protected] BSD root: disk0s2, major 1, minor 3 jnl: b(1, 3): replay_journal: from: 17296896 to: 1108992 (joffset 0x774000) AppleIntelE1000e(Info): AppleIntelE1000e:WOL = 2 jnl: b(1, 3): journal replay done. hfs: mounted Macintosh HD on device root_device RadeonSensors: still waiting for accelerator to start... RadeonSensors: still waiting for accelerator to start... hfs: Removed 1 orphaned / unlinked files and 7 directories? flow_divert_kctl_disconnect (0): disconnecting group 1 OSMetaClass: Kext org.netkas.FakeSMC class FakeSMC is a duplicate;kext org.netkas.driver.FakeSMC already has a class by that name. Kext org.netkas.FakeSMC start failed (result 0xdc00400a). Kext org.netkas.FakeSMC failed to load (0xdc008017). Failed to load kext org.netkas.FakeSMC (error 0xdc008017). Previous Shutdown Cause: 5 SMC::smcInitHelper ERROR: MMIO regMap == NULL - fall back to old SMC mode Waiting for DSMOS... RadeonSensors: still waiting for accelerator to start... VM Swap Subsystem is ON RadeonSensors (pci2): [Error] unable to locate ATY,bin_image RadeonSensors (pci2): found ATI Radeon ID: 0x6810,? BIOS: undefined ACPI_SMC_PlatformPlugin::start - waitForService(resourceMatching(AppleIntelCPUPowerManagement) timed out WARNING: IOPlatformPluginUtil : getCPUIDInfo: this is an unknown CPU model 0x3e ? -- power management may be incomplete or unsupported RadeonSensors (pci2): using device-id to resolve temperature sensor type RadeonSensors (pci2): adding Southern Islands thermal sensor RadeonSensors (pci2): started ATY_Init: Starting ATY_Init: Checking dev-id 6810 ATY_Init: Card 0x6810 was posted ATY_Init: Card was posted, reading rom from legacy address ATY_Init: Quiting for card 0x6810 DSMOS has arrived ATY_Init: Starting AppleIntelE1000e(Info): e1000e NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx ATY,Futomaki: Not usable ATY,Futomaki: Not usable ATY,Futomaki: Not usable ATY,Futomaki: Not usable hfs: mounted myHack OS X 10.9.2 Install Disk on device disk3s1 hfs: unmount initiated on myHack OS X 10.9.2 Install Disk on device disk3s1 AppleKeyStore:Sending lock change 0 hfs: mounted myHack OS X 10.9.2 Install Disk on device disk3s1 Resetting IOCatalogue. OSMetaClass: Kext org.netkas.FakeSMC class FakeSMC is a duplicate;kext org.netkas.driver.FakeSMC already has a class by that name. Kext org.netkas.FakeSMC start failed (result 0xdc00400a). Kext org.netkas.FakeSMC failed to load (0xdc008017). Failed to load kext org.netkas.FakeSMC (error 0xdc008017). ATY_Init: Starting ?? ? ? ? 0 [Level 5] [Facility messagetracer] [com.apple.message.domain com.apple.kernel.cs.mismatch] [com.apple.message.signature 1000] [com.apple.message.signature2 3345639bd98273913ff25086fe0151f45fea0fa3] [com.apple.message.signature3 38872323d4adae2cb310de88ceeeae695630ffd7] [com.apple.message.summarize YES]? ?? ? ? ? 0 [Level 5] [Facility messagetracer] [com.apple.message.domain com.apple.kernel.cs.invalidate] [com.apple.message.signature invalidate] [com.apple.message.signature4 318] [com.apple.message.signature3 ksadmin] [com.apple.message.summarize YES]? CODE SIGNING: cs_invalid_page(0x1000): p=318[ksadmin] final status 0x0, allowing (remove VALID) page ?? ? ? ? 0 [Level 5] [Facility messagetracer] [com.apple.message.domain com.apple.kernel.cs.invalidate] [com.apple.message.signature invalidate] [com.apple.message.signature4 321] [com.apple.message.signature3 ksadmin] [com.apple.message.summarize YES]? CODE SIGNING: cs_invalid_page(0x1000): p=321[ksadmin] final status 0x0, allowing (remove VALID) page process launchd[181] thread 1703 caught burning CPU! It used more than 50% CPU (Actual recent usage: 54%) over 180 seconds. thread lifetime cpu usage 90.422542 seconds, (56.514818 user, 33.907724 system) ledger info: balance: 90005664540 credit: 90155579466 debit: 149914926 limit: 90000000000 (50%) period: 180000000000 time since last refill (ns): 163693708237?
×