Jump to content

Search the Community

Showing results for tags 'DSDT Firewire HD5770'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • OSx86.net
    • Angelbird SSD Competition
    • Forum Rules
    • News and Announcements
    • Feedback
  • Support Forums
    • General Discussion
    • Frequently Asked Questions
    • Guides & Tutorials
    • Bootloaders
    • OSx86.net Installation
    • OSx86.net Post Installation
    • Laptops / Notebooks
    • DSDT
    • Hardware questions
    • International
    • Macintosh Support Forums
    • Virtual Appliance (VMware / Parallels)
  • Other Stuff

Categories

  • Hackintosh Guides
  • Reviews
  • News

Categories

  • Hackintosh Tools
  • Bootloaders
    • Chameleon
    • Clover
    • Ozmosis
  • Miscellaneous
  • Videocards
    • NVidia
    • ATI
    • Intel
  • Audio
  • Network
  • Chipset
  • USB Images / Packages
  • Kernels
  • ISO
  • DSDT
  • iOS Hack
  • BIOS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location:


Interests


Biography


Location:


Interests


Occupation

Found 1 result

  1. Hi guys, I am trying to get hackintosh working on my system. I hopefully included all logs and files needed. You can find them below the system specs: I have come from far, my original DSDT is a mess and had alot of errors probably because of my quite closed BIOS/Motherboard. In case you want to know, I extracted my DSDT with ubuntu liveUSB ? I partially fixed but there are a few issues I would like to nail(See attached log below): ? Sep 24 17:16:04 localhost kernel[0]: FireWire runtime power conservation disabled. (2) (Might be fixable: http://www.insanelymac.com/forum/topic/196359-firewire-issues/)?FIXEDSep 24 17:16:13 localhost kernel[0]: SMC::smcInitHelper ERROR: MMIO regMap == NULL - fall back to old SMC mode? FIXEDSep 24 17:16:13 localhost kernel[0]: ** AppleSMBusPCI::start failed to get acpi path for provider?FIXEDPciRoot not detect in chameleon FIXEDProper sleep: monitor/GPU doesn't wake after sleepAudioSensorsUSBMSC Identifier (non-unique): 20060413092100000 0xbda 0x181 0x8197, 2 not an errorEHCI - FIXED?I also hope if someone can take a look at my DSDT to see if I edited it correctly: ? System PC: HP - xw4600 Motherboard: HP 0AA0H, ICH9R chipset, BIOS version: 1.22 GPU: ASUS HD5770 CPU: Core2Quad Q9450@2,66Ghz WLAN: RTL8191SU LAN: Broadcom 5755 NetXtreme Gigabit RAM: 4GB DRR2 Dual-Channel with ECC SOUND: Realtek ALC262 + Firewire PCI card + DVD-RW drive + BD-drive + 9in1 Cardreader ? Logs and files: lspci output: http://pastebin.com/xSSUZ5zV dmesg: http://pastebin.com/dmQWUFzH part of system.log: http://pastebin.com/PQcq6vhE DSDT(original + my fixed version): https://www.dropbox.com/sh/xjkggjec01ly632/AADrpguZpM68W9Z-_dEAbjwha/Hackintosh?dl=0 Also includes a winmerge report to see the differences yourself ? Bootflags Used: Aticonfig=Eulemur, UseKernelCache=Yes, GenerateCStates=Yes GeneratePStates=Yes PCIRootUID=1 (However 0 works too)? -v ? CPU: This one is weird, speedstepping always worked OOTB but I didn't had an scope _PR with CPU's defined in original DSDT which caused C-states + P-states not to be generated with chameleon. Modified/added a _PR scope/block to DSDT and this is fixed. However still getting a: Invalid Character Found in ProcessorOP. However before it was getting 4-8 of these Invalid Characters Found messages ? ? GPU: Works pretty good straight OOTB. QE/CI enabled. Also Tested? with COD4 and it works good but I have under windows more sensors, like voltage etc... I think it doesn't wake up properly though. ? LAN: I think it works pretty good with the opensource 5722D.kext from adlan. So nothing to add I guess ? WLAN: Works with the official 10.8 driver and utility from the realtek site. Only thing is that I don't like the utility, prefer to use the built-in settings but that's not critical. ? Sound: Works with voodooHDA, prefer native support but that's a bit hard for me at this time. ALC262 is not supported by the scripts floating around here, so all has to be done manually. For time being I resort to voodooHDA, as this isn't that critical. Clues and thoughts on this are appreciated. ? USB: USB was a bit flaky, didn't work if I booted without -f. So I had to patch my DSDT: I generally changed all device ID's to ICH10R ones, Changed internal naming so USB1 -> UHC1, etc… Removed the 0, 2, 8 IRQflags from the RTC, IPIC and TIME devices. Assigned 0, 8, 11 and 15 to HPET device. I assigned four IRQflags as in IORegisteryExplorer I saw that there were 4 values. Should only 0 and 8 be added to DSDT? and let it automagically assign the other 2? ? Anyway USB works, however if I unplug my keyboard and try to replug it. Numlock(+numlock LED light) doesn't work anymore, but I guess this is another issue and not USB related. Is this right? Also the keyboard doesn't enumurate when plugged in the usb of the card-reader. I have somehow the feeling that this keyboard is a bit flaky too as my mouse does get always enumerated, on every USB port. Also tested with SD and microSD, and these worked too. So it might be my keyboard too. ? Also can I steal the IRQ flags from the PS/2 stuff in DSDT? I don't use PS/2 keyboards or mouses? ? ? DVD/BD - Drives: DVD and BD drive works but I haven't tested burning. As I don't have BluRay-Discs so I tested a DVD and that worked. So the device itself is working I guess. ? Thanks in advance. I am not scared of doing this myself but I have absolutely no idea what's the right way of doing it. I just did what felt right and worked.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.