Jump to content

Search the Community

Showing results for tags 'grub2'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • OSx86.net
    • Angelbird SSD Competition
    • Forum Rules
    • News and Announcements
    • Feedback
  • Support Forums
    • General Discussion
    • Frequently Asked Questions
    • Guides & Tutorials
    • Bootloaders
    • OSx86.net Installation
    • OSx86.net Post Installation
    • Laptops / Notebooks
    • DSDT
    • Hardware questions
    • International
    • Macintosh Support Forums
    • Virtual Appliance (VMware / Parallels)
  • Other Stuff

Categories

  • Hackintosh Guides
  • Reviews
  • News

Categories

  • Hackintosh Tools
  • Bootloaders
    • Chameleon
    • Clover
    • Ozmosis
  • Miscellaneous
  • Videocards
    • NVidia
    • ATI
    • Intel
  • Audio
  • Network
  • Chipset
  • USB Images / Packages
  • Kernels
  • ISO
  • DSDT
  • iOS Hack
  • BIOS

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location:


Interests


Biography


Location:


Interests


Occupation

Found 1 result

  1. Hai there I'm having troubles getting GRUB2 to chainload OS X. Basically OS X works, Linux works and Windows works, except I can't boot without the Flash drive containing the OS X Installation. My hard drives are like this (in Linux): /dev/sda1 NTFS Windows bootloader /dev/sda2 NTFS Windows 7 /dev/sdb1 NTFS Data /dev/sdb2 HFS+ OS X 10.8 /dev/sdb3 EXT4 Crunchbang I'm using the original Windows bootloader and Windows is totally self-contained in the SSD, as is Linux/OS X on the hard drive. I have installed Chimera 2.0.1 on the OS X partition. I've copied boot0 to /boot/chameleon/boot0 on the Linux partition, as well as just putting it in the root of the OS X partition. I can't get GRUB2 to load OS X. The entry in /boot/grub/grub.cfg is this: menuentry "Mac OS X (on /dev/sdb2)" { insmod hfsplus set root='(hd1,2)' search --no-floppy --fs-uuid --set=root cf082926772bae5b chainloader (hd1,3)/boot/chameleon/boot0 } If I'm correct, the GRUB and Linux mapping is like this: /dev/sda1 (hd0,1) /dev/sda2 (hd0,2) /dev/sdb1 (hd1,1) /dev/sdb2 (hd1,2) /dev/sdb3 (hd1,3) I pretty much tried everything but it always returns "file not found", "invalid signature" or in one case "Chain booting error_" when I try to chainloader /boot0 Any of you out there who have gotten GRUB2 and OS X playing along nicely?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.