Jump to content
Sign in to follow this  
Shehabic

Boot issue after Setting Windows Partition Active from Windows 7

Recommended Posts

I installed iATKOS L2 ( OSX 10.7.2 ) on my Second Primary Partition on the first disk and it was working fine with the Chameleon Boot Loader, then I logged into Windows which was on the same disk but the first partition and from Windows Management I've set Windows Partition as the Active one, I have already EasyBCD installed,

now when I choose The Mac partition from the Boot Menu it says: "Chain Booting Error", and When I insert iATKOS CD and choose Mac's Partition to boot from I have 2 issues:

1-The Mac partition which i named "MacPartition" is displaying as "Windows NTFS" in the iATKOS boot menu

2-When I choose it to boot from the cursor keeps blinking and screen freezes like that

I believe that the MBR is incorrect or the Bootloaders on the OSX partition is damaged or something but I could fix it

I tried booting into iATKOS L2 CD and went through setup > Terminal tried fdisk -u /dev/disk0

also fdisk -e /dev/disk0

f 2

active

write

and all the stuff described many where in forums but non of them solved the issue, I don't wanna re install the OSX as I Installed it almost 12 times during the last week, also I downloaded many apps from the app store like (XCODE) and I don't wanna re download it.

Could anyone tell me how to re-install the boot loader or fix the mbr ?

Thanks in advance.

Share this post


Link to post
Share on other sites

Make windows partition active and repair it with windows install dvd. Then use iAtkos dvd, and boot Mac partition and from there use Chameleon Wizard > Buildbot > Install Method : Boot0hfs

Share this post


Link to post
Share on other sites
Make windows partition active and repair it with windows install dvd. Then use iAtkos dvd, and boot Mac partition and from there use Chameleon Wizard > Buildbot > Install Method : Boot0hfs

OSX doesn't boot anymore when I choose the OSX partition the cursor keeps blinking in the black screen and stays like that forever, I have no problem with windows, the only problem is that I can't get the osx to boot again

Share this post


Link to post
Share on other sites

No it doesn't boot, when I select the partition of the OSX the cursors keeps blinking and freezes there, the iATKOS setup loads normally but doesn't see the OSX partition as HFSJ (while I didn't even touch it ) all I did was setting windows partition active from windows 7

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.