Jump to content
  • 0
Sign in to follow this  
goobyjr9

Hp dv6-7000

Question

Booting into verbose leaves be at what the attached image shows

Using cpus=1 GraphicsEnabler=No or just graphicsenabler=no goes to the apple logo then tells me to reboot

PCIRootUID=0/1 tells me an error with my Nvidia graphics(630m)

post-277029-137746146125_thumb.jpg

Edited by goobyjr9

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Wow, I go away for a while and HUGE progress has been made. First off I want to apologize for dissappearing. I was having some life issues after my friend committed suicide literally infront of me. However, I am back and I can help. The only problem is that I lost the flash drive with the files on it. I am going through and restoring my mini so I have a working copy of OSX and I will be working on this again after that.

@David, I saw that you've successfully installed OSX. Good job, however I haven't seen if you've gotten out of safemode only mode. If you have, please let me know how. I wanted to thank you for picking up where I left off. I didn't mean to be so absent, life just threw me a really bad lemon.

Also I saw that HP will be putting out a bios to select the GPU. This is GREAT news. Once we can shut down the hd4000 we theoretically should be able to boot into OSX without safemode just fine. However, until that is done, this system will NEVER boot properly. I hate to be a debbi-downer but that's the truth. Me and a friend even spent 3 weeks trying to re-write the freaking OSX driver. All that resulted in was my laptop overheating and his system (a retina macbook) accidentally installing the driver and killing itself.

So for not we're playing a waiting game. The good news is once we can do this I'm fairly certain that we can get this system working stock (no Iatkos) with decent battery life. Alternatively, we could also disable the nvidia card (which would give us mega battery life in OSX, since it also supports the HD4000). Either way we will see this system working once HP stops being dicks.

@Montag, try just CPUS=1 GraphicsEnabler=No -x. That should get you into safemode just fine. We only need the PCIRootUID if we have the HD4000 disabled as it points OSX to the nvidia card, however I suspect that we won't even need that. Note that when you isntall this (if your using a vanilla installer) use just CPUS=1 GraphicsEnabler=No (no -x) it doesn't need it and it seems to cause some issue after the install is done.

Also, for those of you using Iatkos ML2, I'd suggest you just try and use a clean install dmg and go from there. Iatkos uses a lot of "universal drivers" that don't seem to do our systems justice. ALso, it seems you all have fixed the HDD problem. I can try to track down where i got the original driver but if you've found somethign that works good for you.

Also a word of warning. If you make a change and boot normall (no safemode) and get a kernel panic IMMEDIATELY restart. If you let the system hang for a bit it seems to break even safe mode (had to re-install 4 times before I figured that out). Also if you keep getting kernel panics you should just reinstall, this also goes if you can't seem to get it to boot into safemode again (after it has booted once).

All this being said, please give me a week or so to get back into this so I can figure out where I was. I have to re-make my flash drive but that's not an issue. If any of you have gotten further please feel free to update me here or via PM. I also apologize for just disappearing and leaving you all high and dry but I am here to help again.

Share this post


Link to post
Share on other sites
  • 0

Sorry for your loss man, that is a terrible thing to happen to anybody. I'll send you a pm with all the information, then we can figuere out what way we can best get this to work. I do already have a partial guide up but this does need to be updated.

Share this post


Link to post
Share on other sites
  • 0

We have HD4000 working already so we dont need to disable it. I can boot without any boot flags. I have installed a new mach_kernel as per the guide to get rid of the cpus=1 boot flag, i just need to fix wifi (need to get a new card) and then its just trivial things, like being able to change system volume and screen brightness

Share this post


Link to post
Share on other sites
  • 0
We have HD4000 working already so we dont need to disable it. I can boot without any boot flags. I have installed a new mach_kernel as per the guide to get rid of the cpus=1 boot flag, i just need to fix wifi (need to get a new card) and then its just trivial things, like being able to change system volume and screen brightness

This is partly true, we don't need flags that is correct, but there are still some bigger problems which we should be able to fix soon.

Share this post


Link to post
Share on other sites
  • 0

I am working on the DSDT (and trying to patch) as this *should* fix the ethernet and USB issues (it has for me in the past). However, a caveat of this is that everyone will need to make their own (it's not tooo difficult) as it is specific to the bios (HP curse you) and graphics cards.

However, I think we might be ok if we are disabling the nvidia cards (since optimus WONT work on these laptops). Currently I am backing up my OS (windows 8, yes I have a start menu, haven't seen teh start screen for 3 months (since install).) and then I'll be trying to install OSX 10.8.3 (lets aim high here).

WIth the LAPIC (spell?) does imessage/ichat/facetime/whatever work?

Thanks,

AJ

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.