Jump to content
  • 0
Sign in to follow this  

Mountain Lion HD5650 won´t work.. . :(



After my laptop with 10.7.3 Lion yes to sleep on clean runs, I try to install the Mountain Lion. The installation runs smoothly by U{censored}. But now listen. Once I "Chameleon 2034" install I get a black screen source or it hangs when booting. wowevent ... = 2 (1) ....

I unfortunately do not get the graphics card (5650) .. to run! When booting, it is properly recognized by OSX / Chameleon, but OSX itself .. 3 MB graphics card .. : (

Camera videos and run!

I hope you can help me :)


Share this post

Link to post
Share on other sites

Recommended Posts

  • 0

Add your Device ID in AMDRadeonAccelerator.

It's in /System/Library/Extensions.

  1. Copy AMDRadeonAccelerator.kext to Desktop
  2. Select it and "Show Package Contents"
  3. Open Contents > Info.plist with Textedit
  4. Find the key IOPCIMatch and add your Device ID
    <string>0x68f91002 0x67381002 0x67391002 0x67201002 0x67221002</string>
  5. Save the file

Device ID (mine is 0x68f9)

Vendor ID (1002) is ATI

Device ID can be found with System Information > Graphics/Displays > Device ID.

System Information is in /Applications/Utilities.

Give the kext a label color so you know its the edited one.

Install the modified AMDRadeonAccelerator.kext with Kexts Wizard or Kext Utilities

(backup the kext first, it will be overwritten)

Share this post

Link to post
Share on other sites
  • 0


first thanks for your help! Unfortunately, the graphics card is still not recognized. :(

The fault with the black screen with the boot flags PCIRoot=1 NPCI=0x2000 get attacked.

Audio does not work either. With VoodooHDA (2.2, 2.52, 2.7.2), despite KP AppleHDAdisabler ..:( AppleHDA driver with dsdt patch is not ..:( voice over only AppleTV.

I think I'll go back again to Lion first and wait until the appropriate kexts are at disposal.

Thank you again! I love this forum! :)

Share this post

Link to post
Share on other sites
  • 0

Hey macnoob,

I have nearly the same specification as you but i don't get my graphicscard working (also 5650m)

How did you manage to get it work?

When i want to edit the AMDRadeonAccelerator.kext i only see that my ID already exists -> 0x68C11002 (Well there are many IOPCIMatch, but in the Redwood family i found my entry)

Did you put your ID anywhere other?

Or did you get it work by the EDID Force?

Hopefully you can explain me how you got it working :( tried for days...

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.