Jump to content
  • 0
Sign in to follow this  
jimmyco2008

ACPI related kernel panic?

Question

Hey all,

I made a U{censored} USB drive via OSX 10.8 in VirtualBox, and my laptop boots from it fine, except during the boot process with the white background and the apple in the middle, I get a kernel panic! Using a bootflag I was able to view the boot status as it happened, with all the text (you know what I'm talking about), and the kernel panic has something to do with ACPI.

I can definitely give a screenshot, just not yet, I have to remake the U{censored} flash drive. In the meantime, I was hoping a screenshot wasn't necessary, perhaps we can narrow it down without it.

It's a laptop based on an Ivy Bridge i5, Intel HD Audio, Intel SSD, Intel Chipset obviously... But I don't think any of that matters, ACPI has to do with the laptop's power system.

Thanks in advance!

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Okay myHack now boots, but it gave me an error couldn't find mach_kernel, so I downloaded one for HP i5 laptops... now it boots to the white Apple splash but USB activity stops... So I -v boot flagged and I get... well I'll upload the pic here...

I'm not uploading a pic, but here's the error:

couldn't find symbol __ZNBIOMapper18_RESERVEDIOMAPPER3Ev

and it gives me this error for a plethora of items, AppleUSBComposite, ApplePS2, I mean a lot of things... And then it stops listing those and starts listing

Still waiting for root device

Still waiting for root device

Still waiting for root device

And it just adds one of those lines of Still waiting for root device every minute or so...

Edited by jimmyco2008

Share this post


Link to post
Share on other sites
  • 0

Well we already established that those flags do not work...

Turns out VirtualBox ejected the myHack USB drive before it was done, that explains the errors on Page 4, I made it again and now I'm back where I was- Kernel Panic from ACPI.

On a POS AMD machine I have laying around, it wouldn't even make it to the Apple splash screen before rebooting, if that helps at all, but really I think all that means is that it's a POS AMD machine...lol

I can edit the crap out of this myHack USB drive, if I have to modify the chameleon.boot.plist or anything in Extra, maybe insert a fakeSMC.kext (which should already be on) I CAN DO IT, so if there's some kind of ACPI patch, I'd appreciate a link to it...

Share this post


Link to post
Share on other sites
  • 0

Got it with cpus=1

Of course now my hard drive and SSD are not being detected.

I think we can mark this thread as solved. Thanks for all the help, now to go create a thread for this new issue...

Oh and it's actually ACIP, not ACPI..... Apologies but I don't think we'd have made it to cpus=1 any sooner.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.