Jump to content
  • 0
Sign in to follow this  
nicolasboisvert

Need help with G74Sx ML Hackintosh

Question

Hi everybody, hope y'all good! Today I installed Mountain Lion using a kit made for my laptop. Before I installed ML, i had Lion perfectly running, wifi, bluetooth, sleep, ethernet, graphics, usb, hdmi etc... everything was working. But now, I get some issues with the Bluetooth, the Sleep, and a bit with WiFi.

For the bluetooth, I tried a kext called IOBluetoothFamily, a version supposed to support Mountain Lion, it worked one time.

The Sleep, i tried a 10.8 compatible version of SleepEnabler, but even with or not, the system falls in sleep, but at wake I got artefacts and nothing work except mouse.

Here are the Kext I installed :

AHCIPortInjector.kext

AppleIntelCPUPowerManagement.kext

FakeSMC.kext

IONetworkingFamily.kext

IOUSBMassStorageClass.kext

VoodooHDA.kext

AppleACPIPS2Nub.kext

ApplePS2Controller.kext

IO80211Family.kext

IOPlatformPluginFamily.kext

PXHCD.kext

AppleACPIPlatform.kext

AppleSmartBatteryManager.kext

IOAHCIBlockStorageInjector.kext

IOUSBFamily.kext

RealtekRTL81xx.kext

They were all in a kit I downloaded

I checked for NullCPUPM because I heard that he prevented system from sleep

For the wifi it's simple it found my network but I connect he give a random adress that doesn't match my dhcp, in ethernet it's ok

If anyone of you had similar issues or hint it will be helpful, here's my configuration

Asus G74Sx

750gb HDD

Intel i7 2630QM

8Gb Ram

nVidia GTX 560M

Thank you so much everybody!

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

I have a similar Laptop., G74SX with 3D. I never installed Lion. But I installed 10.8 and then combo pack 10.8.2 . I installed Voodoo wizard for my sound , patched Atheros kext for wifi, and realtek RTL81XX-0_0_90 for my ethernet. Of couse Fake SMC and NullCPUPowermanagement kext. only sleep, backlight and bluetooth is not working. I have a strange problem. If I install chameleon or chimera bootloader to the hard disk it gives me Kernal panic. But if I boot from OS x install USB (which has chameleon boot loader) it boot without problem.

I am booting with win7, win8 ,ml and ubuntu. (ReHabmans guide). I have i7 2670 QM 16 GB ram 256GB SSD Geforce GTX 560M.

Can you share your Kexts kit what you downloaded? And can anybody help me with this problem.

I patched my DSDT with and without sleep is the problem. With DSDT it gives Kernal Panic with the Darvin ISO.

Thank you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.