Jump to content
Sign in to follow this  
StevenLaFrance

ASUS P9X79 bios 3009 INTEL I7 3820 Full Guide

Recommended Posts

Do to some problems that ppl are bringing up ill be doing a updated ver of this Build with latest bios and with a video?

?

?

ASUS P9X79 bios 3009 INTEL I7 3820 Fully Installed Step By step


Items Needed for the install a working mac 2 USB Drives and a copy of ML and a lot of time


Getting the USB drive ready
Step 1. Get a USB drive that is 8GB or over
Step 2. Download or buy a copy of Osx ML Here
Step 3. Download U{censored} here You will need a account to download
Step 4. plug the usb into a working Mac or HAckintsoh
Step 5. Open /Applications/Utilities/Disk Utility
Step 6. Click on the usb drive and click on partition
Step 7. Click current and choose 1 partition
Step 8. Click Options and choose Master boot Record and click ok
Step 9. Name the Drive (Hackintosh ML) Without ()
Step 10. Under Format chosse (Mac OS Extended Journaled )
Step 11. Click Apply this can take up to 5 min
Step 12. If using the Install Mac OS X Lion Application, it must be in Applications folder and if you are using the USB from apple plug it into a usb port and mount it
Step 13. Run U{censored} and Click Continue, Continue, Continue, Agree
Step 14. when it ask you the Destination Choose the USB Drive called (Hackintosh ML)
Step 15. Click Contiune
Step 16. Now if it popups Installation Type Choose the one you are using USB or app then click continue
Step 17. Enter Your password and install this can take up to 30 min. depends on the USB drive

Getting the Asus P9X79 Ready

Go into the bios and set SATA to AHCI
F10 and save

Time To boot into the USB Drive (If you get a boot0 error off the USB redo Steps Above)

Step 1. restart the computer and Press F8 till you get the boot menu
Step 2. Choose the USB Drive (note it will come up as the brand not the Name we gave it)
Step 3. once the boot screen shows up press F8 again
Step 4. Type this in " -v -x Cpus=1 Npci=0x2000" type without ""
If you get a PCI config lockup Try PCIRootUID=0 instead of Npci=0x2000
If you get Still waiting on Root Device Type in the drive like this ( rd=diskYsZ ) Y being the port Z being the Sector

Time to install

Step 1. click on the Lang you want and click the arrow
Step 2. go to utilities and open disk Utility
Step 3. Format the HD that the Hackintosh will be installed on make sure its (Mac OS Extended Journaled )
Step 4. Close Disk Utility
Step 5. Click next choose your drive and then click customize

Step 6. find the Audio Driver
-audio
--realtekalc8XX
---Without DSDT
----check mark alc898

Step 7. network drivers
-network
--hnak's appleintele1000e Ethernet

Step 8. Click next and install

Getting it to boot

Step 1. boot off the USB again and when the bootloader loads find the HD with Hackintosh installed on it (NOT THE USB DRIVE)
Step 2. Type this in " -v Cpus=1 Npci=0x2000" or whatever codes you used for the install
Now let it load and boot into the setup screen and choose user pass you know the drill

Getting the Cpus=1 error fixed

Step 1. Download VoodooTSCsync.kext Here

Step 2. you have to edit it heres a video i made on the how to


Step 3. Now install the VoodooTSCsync with ur fav Kext installer I used Kext Wizard (if your USB drivers stop working use KEXT Utility

Step 4. Restart

Step 5. boot off the USB again and when the bootloader loads find the HD with Hackintosh installed on it
Step 6. Type this in " -v Npci=0x2000" or whatever codes you used for the install Without Cpus=1

Time to Fix the Bootloader so that we no longer need the USB Drive

Step 1. boot into the hackintosh and install Chimera 1.11.1 from here

Step 2. now extract the Chimera .pgk and under /usr/standalone/ you will find a file called Boot1h
Step 3. Copy that to the Desktop and find a NEW USB DRIVE. yes you will need a 2nd one for this. copy that Boot1h to the new usb drive and thats it

Step 4. reboot and boot the usb drive with Hackintosh ML from U{censored} on it

Step 5. now type in what you did to install it and yes with the Cpus=1

Step 6. when you get to he install screen open disk utility and unmound the Hackintosh HD that you just installed
Step 7. now open the terminal AKA CMD lol
Step 8. Now type in

diskutil list

Step 9. Now find the HD with the Hackintsoh installed on it. in my case it was Disk0s2

Step 10. close the terminal and reopen it and type this in

cd /Volumes/"USB Drive "USB Drive" being the name of the Usb drive that the Boot1h is on

Then hit enter and then type in

dd if=boot1h of=/dev/identifier
-Idenitier being the Disk so it would look like this dd if=boot1h of=/dev/disk0s2

Now it will install - Reboot now and boot off the HD and now type in

-v Npci=0x2000 or whatever worked to install

Time to fix the Npci=0x2000 Error

Step 1. go to /Library/Preferences/SystemConfiguration/ and copy the Com.apple.boot.plist to the desktop
Step 2. now open it and edit the <key>Kernel Flags</key> to look like this

<key>Kernel Flags</key>
<string>Npci=0x2000</string>

now save and close

Step 3. now copy the file to the same place you found it and hit yes when you want to replace it

step 4. reboot now the os should load without any problems

This was a Team effort
Thank you for all your help

kyndder , christ1111 Edited by StevenLaFrance

Share this post


Link to post
Share on other sites

Hi. I bougth this mother board (so p9x79 LE) and same CPU. I had OS X 10.6.8 installed and working on my old PC. But don't boot in this new PC, only if I put "-v -x cpus=1 npci=0x2000". I want to solve all problems, but I don't see anything on the video that are showing how to edit voodoo kext, and my english it is not to good to understand he.

I tried to download the VoodooTSCsync.kext from the link you posted ( Download VoodooTSCSync.kext 32/64 compiled on 10.7.3 w/ xcode 4.3 - TSC Syncing Kext ) but it is not a .kext file it is a .tgz, I don't know what to do with it.

Can you post your modified kext here? Thank you

Share this post


Link to post
Share on other sites

After some try and error, I have working boot OS X 10.6.8 without verbose mode.

Now only I left one problem. I have no ethernet, I tried to install the kext from MB{censored} but don't work, what can I do? I google it but I see everybody can repair it with MB{censored}, but to me don't work.

Edited by NapalmCandy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.