Jump to content
  • 0
Sign in to follow this  
akamaths

Hp 550 Intel x3100 Lion 10.7.5

Question

Ok i have an Hp 550 notebook pc with Lion 10.7.5 installed running in 32bit, i got everything to work except VGA

This is the Device info :

00:00.0 Host bridge [0600]: Intel Corporation Mobile GME965/GLE960 Memory Controller Hub [8086:2a10] (rev 0c)

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile GME965/GLE960 Integrated Graphics Controller [8086:2a12] (rev 0c)

00:02.1 Display controller [0380]: Intel Corporation Mobile GME965/GLE960 Integrated Graphics Controller [8086:2a13] (rev 0c)

I tried almost everthing i cant get it to work,if anyone can help in any way please do,Thanx in advance

Edited by akamaths

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

So i edited the AppleIntelGMAX3100.kext & AppleIntelGMAX3100FB.kext Info.plist from a fresh 10.7.5 Lion install to match my Device ID:2a12 and i managed to get my pc to see the Vga as Intel GMA X3100 But i have no OpenGL acceleration nor Quartz Extreme acceleration, please any ideas ???

Share this post


Link to post
Share on other sites
  • 0

For Start thank you so much for taking the time and make this guide,its very good even dumies can follow this guide i felt like 5 year old kid watching this and thats the way guides should be,thats why they called Guides ;) Now in respond to the guide i should tell you that the files you propose are for the 0x2A02 Device ID mine is the X3100 with 0x2A12.I could go and give it a try if i Hex/Edit AppleIntelGMAX3100FB.kext But will this be enough ? Thank you again for your response

Share this post


Link to post
Share on other sites
  • 0

would try it first without modifying kexts. al least 3 times.

if not then modify them all ID's.

since you've been testing different methods, make sure you install all the kext, download all and install all. 3 links. 6 files all

together.

have fun.

Share this post


Link to post
Share on other sites
  • 0

So i took AppleIntelGMAX3100.kext & AppleIntelGMAX3100FB.kext from the Files you told me and Hex/Edit all IDs to meet my Device ID,Edit also includes the Info.plist Files.I made a fresh install of the Lion 10.7.5 (11G63) and Installed all the Kexts.On normal boot i get stuck at loading white Apple Logo and i have the mouse cursor at the up Left of the screen which i can move it appears and disappears,on a boot with -v -f flags i get a black screen with a steady white cursor(not mouse) and i can write with keyboard,still no boot.Its Black so i dont have any info to troubleshoot.With -x flag i can boot normaly in Safe mode still no accelaretion of any kind.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.