Jump to content
Sign in to follow this  
Rytz

Triple Boot: Dell Inspiron 17R N7110: OSX 10.8, WIN 7x64 Ultimate, Vector Linux x64

Recommended Posts

Hi:

This is a guide for triple-booting a Dell Inspiron 17R N7110 with OSX 10.8 (Mountain Lion), Windows 7x64 Ultimate, and Vector Linux VLocity (x64).

I use this laptop for DJ'ing every weekend and frequently throughout the week. Interestingly enough, I've tried running my DJ software on both Windows and Mac on this laptop, and Mac runs my DJ Software way better. The latency for MIDI USB devices (controller turntables) is almost nothing with Mac, where with Windows there is a significant latency issue which makes Windows unusable for me in terms of DJ'ing. It probably doesn't help that the vendor only provides generic USB drivers for Windows, though (Numark).

What doesn't work:

> Sleep (don't care). Using a low-timer screensaver and InsomniaX to disable sleep.

> Never tested HDMI or E-SATA (USB on that connector works though)

> Function key brightness (brightness slider fix in guide)

My DSDT is attached. I also attached a geekbench score screenshot. I subscribed to the thread so I can answer any questions.

Begin Guide:

****************************

****************************

* NOTE: this laptop's BIOS only boots from MBR drives:

Re: Inspirion 17R (N7110) - UEFI (Phoenix SecureCore Tiano) firmware alway boots in BIOS Mode - Linux Forum - Software & Operating Systems - Dell Community

* NOTE: Booting from USB: the system is finicky about seeing some usb sticks at boot time. I recommend using the boot menu (F12) instead of just waiting. Keep spamming F12 until you see it in the list - may take a few times.

-------------------------------

Changed Hardware

-------------------------------

HD: Seagate 500g 5200rpm *TO* Seagate 750g 7200rpm SS hybrid hard drive (Momentus XT): Seagate ST750LX003 Momentus XT 750GB Solid State Hybrid Drive - 750GB, SATA 6Gb/s, 7200RPM, 32M, 2.5 at TigerDirect.com

WLAN / Bluetooth (Mini PCI-E): Intel *TO* Atheros AR5B195: AR5B195 | eBay

RAM: 6g *TO* 8g (1x2g *TO 1x4g): Crucial CT51264BC1339 4GB Laptop Memory Upgrade - PC10600, DDR3, SODIMM, 1333MHz, Non-ECC, Unbuffered at TigerDirect.com

LCD: 17" 1600x900 Glossy *TO* 17" 1920x1080 Matte: http://www.laptopscreen.com/English/section/search/index.php?section=products&model=INSPIRON+17R+N7110&brand=Dell

------------------

BIOS

------------------

BIOS version: A12. Dell support page has it. Process may work on other versions.

------------------

Things-To-Have

------------------

Retail OSX Snow Leopard 10.6.3 - may work with other SL versions.

OSX Mountain Lion 10.8.0 update from Apple Store (10.8.GM).

Bootable Nawcom OSX CD (required for allowing OSX to install on MBR type drive)

OSX Mountain Lion MBR installer patcher ("2815-OSInstall(MBR)+OSInstall.mpkg(10.8.GM)"): Hackintosh OSInstall(MBR)+OSInstall.mpkg 10.8.x - Downloads - OSx86.net

USB Stick #1: ML Installer: at least 8GB (you'll want to keep this in-case future problems - handy for booting in the OS without safe mode)

USB Stick #2: transfering files to/from systems (I'm assuming you have another working computer of some sort)

Bootloader: using latest Chameleon: Chameleon-2.1-r2069.pkg

{censored}: MB{censored}

{censored}: U{censored}

------------------------

Drivers / Hacks

------------------------

FakeSMC / IntelCPUMonitor / ACPISensors (+HWMonitor App): "FakeSMC_r615.zip": Hackintosh FakeSMC r615 (10.6 or 10.7/10.8) - Downloads - OSx86.net

System Definition: {censored} MB{censored}: MacBook Pro 8,1 (REQUIRED for video to work)

DSDT: Custom / User (use my DSDT at your own risk).

SSDT: {censored} MB{censored}: Customization > Boot Options / SSDT > Core i5/i7 Overclocked (up to 4.2ghz).

Video (QE/CI): If vanilla DSDT not working, try using DSDT HD3000 video hack: {censored} Forum ? Information

Power Management: AppleIntelCPUPowerManagement Patched for 10.8:

Patched AppleIntelCPUPowerManagement.kext for 10.8

PS2 Key/Trackpad:

AppleACPIPS2Nub.kext & ApplePS2Controller.kext

USB3:

Primary method (100% working):

http://www.osx86.net/view/3745-genericusbxhci_usb_3.0.html

NEC / Renesas USB 3.0 Controller (Laptop Internal)

Secondary method: LaCie USB3 Kext: MB{censored} 5.1.3 (mostly stable - might require reboots for USB3 devices to show up)

Alternate method: "PXHCD" (LaCie) kext: Hackintosh PXHCD.kext - Downloads - OSx86.net

You shouldn't have to use the DP3 kexts. Also available on MB{censored} 4.6.1 .

MB{censored} 5.1.3 CalDigit drivers do not work and make the usb3 ports dead.

LaCie Driver notes:

> All USB2 devices work but the only USB3 drives that will mount in USB3 ports are USB3 compatible LaCie External Drives.

> (I can't get other USB3 drives to mount in USB3 ports)

> USB3 devices work fine in USB2 ports.

> If USB2 drives aren't mounting in USB3 ports, try rebooting. Usually works for me.

> You can also try using the DP3 kexts from same thread above which fixed drive-based problems for me -

however I lost detection of my audio midi USB devices, so I had to go back to originals.

Audio/Mic: 2786-AppleHDA + Enabler for ALC269(.zip):

Hackintosh Asus K53SD with AppleHDA ALC269 & USB3 ASM1042 - Downloads - OSx86.net

DELL N3010 aka 13R_Hackintosh DUAL BOOT TUTORIAL LION + WIN

WLAN / Bluetooth (Mini PCI-E):

Intel: not supported. just spend $10-$15 on ebay/amazon and just buy an internal atheros card (see top for link) or buy a USB eqivelent.

Qualcomm Atheros AR5B195 (AR9285 Wifi + AR3011 Bluetooth):

osx driver: simple edit of info.plist required for bluetooth (vendor/product id). read notes on page:

Hackintosh Atheros AR5B195( AR9285 Wifi + AR3011 Bluetooth) - Downloads - OSx86.net

win drivers:

WLAN: ATHEROS drivers for Microsoft Windows (Atheros?????)

BT: HP ProBook 4530s Notebook PC*-* Atheros Bluetooth Driver - HP Business Support Center

** NOTE: some bluetooth devices act strange if connected when WIFI is in-use. My bluetooth mouse movement became erractic. Disable / enable WIFI to fix the problem.

LAN: RealTek 8101E/8136 FE (Fast Ethernet) 100MB:

** NOTE: lnx2mac drivers did not work for me. The device never gets found.

Used Realtek RTGNIC install package for 10.7 (RTGNICv2.0.6For10.7.zip):

Realtek

** NOTE: Ethernet adapter must be manually configured on order to work:

Yes, speed goes from 100MB to 10MB. Something is better than nothing.

If you find a better solution let me know.

[system Configuration -> Network -> Ethernet -> Advanced -> Hardware]:

> Configuration: manual

> Speed: 10baseT/UTP

> Duplex: Fullduplex

> MTU: Standard (1500)

Backlight Brightness: slider works vanilla but only ends up at half-brightness:

Install "ACPIBacklight.kext" and remove "AppleBacklight.kext" & "AppleBacklightExpert.kext" (no DSDT edit required):

ACPI Backlight Driver - Other Peripheral Devices - InsanelyMac Forum

Sleep (sleeps but doesn't wake): SleepEnabler does NOT work. probably needs a DSDT fix. not working yet.

Sleep on Lid Close (disabler): NoSleep or InsomniaX (both work)

Card Reader: "AnyCardReader.kext":

Hackintosh Dell Inspiron 15R N5110 Lion 10.7.2 PACK - Downloads - OSx86.net

WebCam: vanilla

Battery: VoodooBattery + AppleACPIPlatform:

http://www.osx86.net/view/2648-appleacpiplatform_amp;__voodoobattery.html

VGA Port (Post #185 -WITHOUT- DSDT edit):

Editing Custom connector info for Intel HD 3000 Graphics (sandy bridge, OSX Lion) - Page 10 - Intel - InsanelyMac Forum

Editing Custom connector info for Intel HD 3000 Graphics (sandy bridge, OSX Lion) - Page 9 - Intel - InsanelyMac Forum

How to reset hackintosh notebook external display settings? - Notebooks - InsanelyMac Forum

Editing Custom connector info for Intel HD 3000 Graphics (sandy bridge, OSX Lion) - Page 7 - Intel - InsanelyMac Forum

** Note1: Must boot OSX with monitor plugged in -OR- do a sleep/wake refresh to get monitor to display.

** Note2: Changing resolutions on the external monitor will cause the display to go black.

** Note3: If external display stops working, reset display configurations and reboot:

How to reset hackintosh notebook external display settings? - Notebooks - InsanelyMac Forum

rm -f /Library/Preferences/com.apple.window*

rm -f /Users/"USERNAME"/Library/Preferences/ByHost/com.apple.window*

rm -f /Users/"USERNAME"/Library/Preferences/ByHost/com.apple.pref*

** Note4: If your display files above don't get regenerated on a reboot, you can

force a regeneration by changing your display resolution.

HDMI Port: untested

E-SATA+USB Port: USB works - haven't tested E-SATA

Display Sleep on Lid Close Bug: using disabler for now - no fix yet

Function Keys Brightness: not working - VoodooPS2Controller doesn't work.

---------------

Part 1a: Create Partitions

---------------

1> Boot from "Nawcom ModCD 0.3.2" so we can boot from the retail 10.6.3 (snow leopard) DVD.

2> Use "Disk Utility" from retail DVD menu to create 4 primary partitions (MBR style partition):

> OSX (350gb) (Mac OS Extended (Journaled))

> Windows (165gb) (FAT)

> Linux (125gb) (FAT)

> OSXBACKUP (remaining space) (FAT)

> used for time machine backups and, if you want, a mountain lion installer partition for emergency situations.

**NOTE: MBR only supports up to 4 primary partitions. Chameleon doesn't see linux on the 4th partition.

Therefore, all OS'es must be on partitions 1-3. That's why the OSXBACKUP partition will be on partition 4.

---------------

Part 1b: Installing OSX From Snow Leopard (10.6.3)

---------------

1> install OSX 10.6.3 on OSX parition. finish to setup process as well.

a> If you have "CUSTOM OPTIONS" available on the main install screen, the -ONLY- option I enabled was the PS2 option.

If you don't have "CUSTOM OPTIONS", after the install is finished, try MB{censored} "PS2" controller drivers.

If those don't work, check osx86.net and try drivers from there.

Voodoo PS2 drivers did NOT work for me.

b> these PS2 drivers should work in SL and ML.

2> After install is complete, boot with nawcom boot CD. boot into new OSX install and complete the setup process.

---------------

Part 1c: Install Windows (Partition #2)

---------------

1> Install Windows 7: Boot into Windows 7 setup from DVD. Install Windows 7 on "WIN" partition. Windows partition must be formatted first (do it from Windows Setup advanced disk options).

2> On Win7 install compeltion, reboot without any bootloaders or CD's. finish windows setup process. if you can boot into windows OK, move on to next steps.

---------------

Part 1d: Install VLocity Vector Linux (Partition #3)

---------------

[1] Boot from setup CD

[2] When setup asks for "partition drives" vs "use existing partitions", select "use existing partitions".

[3] Select the partition using for Linux, mount to "/" and format as "ext2".

[4] Do install.

[5] When install is complete, do NOT install any bootloaders ("none" option).

[6] Finish config - reboot on complete.

[7] Must boot from Vector install CD to boot into system.

At first boot prompt, run command "linux root=/dev/sda3" (sda3 being the new installed partition). Ignore read-only warning.

[8] Go through VL configuration stuff. Reboot when finished.

[9] Same as above, use VL CD to boot into system.

[10] Install GRUB bootloader:

> At user login screen for VL, jump to a terminal instance and log in as root.

> Run grub install command: "grub-install --force /dev/sda3".

For info on "--force": https://wiki.archlinux.org/index.php/GRUB2

> Run grub config generator: "grub-mkconfig > /boot/grub/grub.cfg"

[11] Reboot. Grub should boot into linux and have a menu screen now that includes linux and windows (added by default).

---------------

Part 1e: Set Active MBR Partition

---------------

1> Make sure the OSX (Partition 1) is the active partition in order for Chameleon to work right.

> I used windows "diskpart" to set the active partition.

---------------

Part 1f: Install Chameleon (Bootloader)

---------------

1> Restart and boot into OSX (Snow Leopard) again with nawcom CD to ensure everything works. Make sure you can get into OSX without crashes / freezes / hangs.

2> Install the chameleon bootloader. Make sure chameleon can see all three partitions on bootup (OSX, WIN, LIN). OSX probably won't boot from chameleon yet.

--------------------------------------------

Part 2: Copy / Transfer Important Software

--------------------------------------------

At this point, you should copy / transfer over any important software that you will need post ML install.

Once ML is installed, you will only be able to boot by doing safe mode, which will restrict access to external drives that are only HFS/+.

If you have a way to write to a USB HFS drive (special software / another mac), then you can skip this section and do it after ML is installed.

If you don't or aren't sure, you should just get software onto the system now so you don't have problems later.

1> Create a temp "software" folder on your OSX desktop.

2> Copy / transfer important software over to that folder:

a> Chameleon (or your bootloader).

b> a DSDT editor: DSDT - OSx86

c> a Kext installer like Kext Wizard

d> drivers / hacks / MB{censored} / etc

e> anything else you want

-----------------------

Part 3: Create installer USB drive for OSX Mountain Lion

-----------------------

1> format your 8GB USB stick as default mac type filesystem (Mac OS Extended (Journaled)). creation single partition as Master Boot Record.

** NOTE: USB3.0 ports won't work right now - use a USB2.0 port.

2> Make folder in "/Applications" called "Install OS X Mountain Lion.app" (app package).

3> Mount mountain lion image (was named "InstallESD.dmg").

4> Mount "BaseSystem.dmg" from inside newly mounted mountain lion image "Mac OS X Install ESD" ("InstallESD.dmg").

5> 2 images should be mounted: "Mac OS X Install ESD" and "Mac OS X Base System".

6> run {censored} U{censored} - make sure to check "Laptop Support" or keyboard won't work on ML setup (next step).

-----------------------

Part 4: Install Mountain Lion

-----------------------

1> after U{censored} is finished, patch the usb drive with nawcom "2815-OSInstall(MBR)+OSInstall.mpkg(10.8.GM)" files so that the install will work on MBR drive (2 files to overwrite - see instructions in zip).

2> reboot system using the new bootable ML USB.

3> select the USB drive from iB{censored} and enter command line options: "busratio=17 -x".

a> if you get a black screen (no actual setup windows come up), reboot and try again. Sometimes I had to try a few times.

4> Press space-bar when bluetooth keyboard window comes up. Do the install. Install took about 45 minutes to an hour for me.

a> screen may go wacky during install progress screen. hit an arrow key and it came back to see the install progress.

-----------------------

Part 5: Fixing Mountain Lion

-----------------------

After the ML install finishes, we're going to have the biggest hurdles.

The video (Intel HD3000) is a pain in the ass and makes it almost impossible to boot into the system (black screen after load).

I could only figure one way out to boot into the system:

1> Boot from the U{censored} USB into OSX using with options "busratio=17 -x GraphicsEnabler=no".

b> **NOTE: if you installed the "legacy_kernal", you will have to boot with option "mach_kernel". I experienced immediate reboots after bootloader without specificing mach_kernel. If so, change "legacy_kernel" to "mach_kernel" in "org.chameleon.Boot.plist" "Kernel" option.

2> Move "AppleACPIPS2Nub.kext" & "ApplePS2Controller.kext" out of E/E to the Desktop.

3> Delete remaining kexts in E/E.

4> Install "AppleACPIPS2Nub.kext" & "ApplePS2Controller.kext" drivers to S/L/E.

5> Repair E/E permissions and rebuild caches.

6> Install FakeSMC + Intel drivers (listed above).

7> Install "AppleIntelCPUPowerManagement" driver (listed above).

8> Open MB{censored}: Install system definition for MacBook Pro 8.1 and Core i5/i7 SSDT boot option (see above).

9> Extract / create / add custom DSDT file.

10> **IF USING 1920x1080 LAPTOP SCREEN**: add "Graphics Mode"="1920x1080x32" to "org.chameleon.boot.plist".

---------------------------------------------

Part 6: 4K Advanced Sector Fix for Chameleon

** SKIP THIS IF YOU DON'T HAVE A 4K SECTOR DRIVE **

---------------------------------------------

1> The Chameleon boot loader doesn't get installed properly by itself on "4K Advanced Sector" drives.

You will see "boot0: done" and will go straight to Windows 7 (no chameleon menu).

2> The Seagate Momentus XT Hybrid SSD is a 4K Advanced Sector drive. This fix is required for chameleon to work right.

3> Follow the instructions in the post below (page 1, post #6).

The post refers to "OSX Lion" but you can use your U{censored} OSX ML USB stick:

Chimera and 4k HDD boot issues

(I also saved the instructions to a text file with this file called "4k_advanced_sector_fix")

----------------------------------

Part 7: Install Remaining Drivers (any order)

----------------------------------

> Install "ACPIBacklight.kext" (above).

> Install Audio drivers (above).

> Install Battery drivers (above).

> Install LAN / WAN drivers (above).

> Install USB 3.0 kext

> External VGA hack (above).

> Any other drivers...

----------------------------------

Part 8: Create Moutain Lion Installer (Recovery) Partition

----------------------------------

Use Moutain Lion 10.8 and xMove for Mountain Lion to install the ML installer onto the OSXBACKUP partition.

This will help for emergency recover situations.

> Format OSXBACKUP as "Mac OS Extended (Journaled)" through mac DiskUtility

> Mac will set OSXBACKUP as the primary partition. Use windows "DiskPart" command utility to set partition OSX (#1) to the active partition again.

> Make folder in "/Applications" called "Install OS X Mountain Lion.app" (app package) - should still exist from above.

> Mount mountain lion image (was named "InstallESD.dmg").

> Mount "BaseSystem.dmg" from inside newly mounted mountain lion image "Mac OS X Install ESD" ("InstallESD.dmg").

> 2 images should be mounted: "Mac OS X Install ESD" and "Mac OS X Base System".

> run {censored} xMove for Mountain Lion. Install to OSXBACKUP.

> Boot into OSXBACKUP from chameleon. Make sure it works.

post-185363-137746161872_thumb.jpg

4k_advanced_sector_fix.txt

geekbench 2013-05-05 at 3.04.14 PM.png.zip

Edited by Rytz
Added zip file for PNG

Share this post


Link to post
Share on other sites

For touchpad sensitivity issues (pointer / cursor jumping around), I'm working with RehabMan with his Voodoo drivers on the tony mac forums.? Do a google search for "dell inspiron n7110 alps touchpad hackintosh" and it should come up.? Not sure if I can link to there from this site.

?

External USB mouse users can enable the option to "disable the trackpad on USB mouse" but I use a bluetooth mouse (not the same for the driver).? Still working on that.

Share this post


Link to post
Share on other sites

Can you go into detail about how you got the system to boot from the USB? I can't get it to work. Even tried Plop, it doesn't see a boot image on the USB drive!

Share this post


Link to post
Share on other sites

For my Dell N7110, I managed to OSX 10.9 Mavericks to install by creating a USB installer via U{censored} from {censored} (create with laptop support AND apply MBR patch as I've read that this system does NOT support GPT parititions, although I didn't actually try installing to a GPT partition myself), then I found that I actually had to remove all NVDA*.kexts from /System/Library/Extensions on the actual USB installer and boot with GraphicsEnabler=No -f -v?or it wouldn't actually load with graphics support and make it to the installation screen.

?

After install, I booted via the USB but selected my newly installed OSX partition instead and booted this with?GraphicsEnabler=No -f -v and OSX loaded!

?

Then I had to do a TON more stuff just to be able to get the damn thing working properly from here!!

?

Right now, I've got Full Graphics with QE/CI acceleration on the HD 3000 with both internal LCD and HDMI, Audio (possible by using latest Chameleon 2.2svn and boot flags of GraphicsEnabler=Yes IntelCapriFB=4?along with Mac8,3 smbios and DSDT patch for DualLink support, which fixes the internal LCD from being blank and only having HDMI output working; Also note that I was getting a boot0 error?after installing Chameleon, which I fixed by ​manually applying?boot1h to the partition), Wireless (replaced intel wimax card with another for native wireless support), Ethernet (although only at 10baseT). ?SD card reader and webcam worked natively as well.

?

Still a work in progress, but I will post back here eventually with a complete guide on how I managed to get this system fully functional (or at least as close to fully functional as I possibly can). ?Until then, I hope this helps!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.