Jump to content
  • 0
Sign in to follow this  
gillyns

Realtek ALC1200

Question

Hello,

Can someone help me getting my sound to work on Mavericks ? My sound card is a "Rekaltek ALC1200" integrated on my Asus P6T SE motherboard. I tried downloading the appropriate driver, but it is not recognized... I also tried using the working driver from OSX Lion, but it doesn't work on Mavericks.

Thanks

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

i modified the code to match the patches given with the app... i end up having the same code in my dsdt.aml as the one that is posted in the link above which is that :
?


? ? ? ? ? ?Device (HDEF)
? ? ? ? ? ? {
? ? ? ? ? ? ? ? Name (_ADR, 0x001B0000) ?// _ADR: Address
? ? ? ? ? ? ? ? Method (_PRW, 0, NotSerialized) ?// _PRW: Power Resources for Wake
? ? ? ? ? ? ? ? {
? ? ? ? ? ? ? ? ? ? Return (Package (0x02)
? ? ? ? ? ? ? ? ? ? {
? ? ? ? ? ? ? ? ? ? ? ? 0x0D,
? ? ? ? ? ? ? ? ? ? ? ? 0x05
? ? ? ? ? ? ? ? ? ? })
? ? ? ? ? ? ? ? }
? ? ? ? ? ? ? ? Method (_DSM, 4, NotSerialized) ?// _DSM: Device-Specific Method
? ? ? ? ? ? ? ? {
? ? ? ? ? ? ? ? ? ? Store (Package (0x06)
? ? ? ? ? ? ? ? ? ? ? ? {
? ? ? ? ? ? ? ? ? ? ? ? ? ? "layout-id",?
? ? ? ? ? ? ? ? ? ? ? ? ? ? Buffer (0x04)
? ? ? ? ? ? ? ? ? ? ? ? ? ? {
? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? 0x0C, 0x00, 0x00, 0x00
? ? ? ? ? ? ? ? ? ? ? ? ? ? },?
? ? ? ? ? ? ? ? ? ? ? ? ? ? "platformFamily",?
? ? ? ? ? ? ? ? ? ? ? ? ? ? Buffer (One)
? ? ? ? ? ? ? ? ? ? ? ? ? ? {
? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ?0x00
? ? ? ? ? ? ? ? ? ? ? ? ? ? },
? ? ? ? ? ? ? ? ? ? ? ? ? ? "PinConfigurations",?
? ? ? ? ? ? ? ? ? ? ? ? ? ? Buffer (Zero) {}
? ? ? ? ? ? ? ? ? ? ? ? }, Local0)
? ? ? ? ? ? ? ? ? ? DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
? ? ? ? ? ? ? ? ? ? Return (Local0)
? ? ? ? ? ? ? ? }
? ? ? ? ? ? }
? ? ? ? }

?

but when i compile it, dsdt editor gives me the error "object does not exist (DTGP) on that line :

? ? ? ? ? ? ? ? ? ? DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

Share this post


Link to post
Share on other sites
  • 0

I finally got it to work after modifying the patch and applying another, i posted my work here?if anyone of you needs it wink.png

thanks for all the help guys, take care

?

Here your work:

?

?

I got it working on my Asus P6T SE, but it was a bit of a pain, so i'll post my work for the others...

- I installed OS X Mavericks with MyHack (CPU, GPU and RAM are recognized already)

- Using?#####?6.0.0 i installed the Ethernet driver and the fix to make the computer shutdown completely (Ev0reboot.kext) and some others (such as SATA,...)

- using?this video?i got icloud working (with every app except iMessage, but i don't use it so i don't care)

- finally for the sound card : I installed DSDT editor and did the following :

1.open DSDT editor

2.file -> extract DSDT

3.patch -> open : open the HDEF file in my link (http://www.2shared.c...tion_files.html)

4.click apply

5.patch -> open : open the DTGP file in my link (http://www.2shared.c...tion_files.html)

6.click apply

7.IASL -> compile (you should get no errors)

8.IASL -> save aml : save it as "DSDT.aml" in /extra

9.install?AppleHDA.kext?from the first post using kext utility (it will rebuild cache automatically)

10.reboot and enjoy?smile.png

?

I do not like references to other sites?tongue.png

?

You can also write an tutorial for this.

?

This is under the problem section not guides!

?

Good work, I'm happy for you

Share this post


Link to post
Share on other sites
  • 0

Привет в?ем! Там какое-то недоразумение, не auio. ML 10.8.5 (12F45) Мы у?танавливаем now.Mother до?ка Asus P5Q Realtek ALC1200.Help решить ?ту проблему, е?ли possible.Clover при ?тарте.

Share this post


Link to post
Share on other sites
  • 0

Hi, I delivered all this assembly, flight normal, the loader was used by a multibist 5.4.3 it is possible 5.5.5, a configuration - Asus P5Q, C2D E 8600 3,33 Ghz, GeForce GTS-250-512Мb, HDD Samsung 250Gb, RAM 4Gb, former everything is normal, but there is no sound, tried to change keksta, anything doesn't help, someone can knows as it it is possible to correct, the sound costs Realtek ALC 1200, I thank in advance.......ML 10.8.5 (12F45)

Share this post


Link to post
Share on other sites
  • 0

Hi, I delivered all this assembly, flight normal, the loader was used by a multibist 5.4.3 it is possible 5.5.5, a configuration - Asus P5Q, C2D E 8600 3,33 Ghz, GeForce GTS-250-512Мb, HDD Samsung 250Gb, RAM 4Gb, former everything is normal, but there is no sound, tried to change keksta, anything doesn't help, someone can knows as it it is possible to correct, the sound costs Realtek ALC 1200, I thank in advance.......ML 10.8.5 (12F45)

Buy cheap usb sound card for no trouble?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.