Jump to content
m.gbt

[GUIDE] UEFI Mavericks 10.9.x & El Capitan 10.11.2+ on Samsung NP530U3B

Recommended Posts

I have 4 options only: terminal, options, reboot and exit.

I'm out for the weekend and I don't have Clover here to test it, but I see from your picture you have 5 options instead of 4, there's an "i" button there, what is it?

Didn't get what you mean "installed on your 2236".

In the guide I give you all the files needed for the 2236 which is used only for the installation. After it, I recommend to install an updated Clover and it should be from scratch, you're not going to keep a single file from 2236.

I found a very very bad video where the user shows the "Clover boot options":?https://www.youtube.com/watch?feature=player_detailpage&v=2zAShw23sJI#t=163

I've already set the link very next to the part where he shows it... However he uses a different theme.

Anyway it seems that the "Clover boot options" icon usually comes before the "Options" icon (which should be named Settings!!!)

?

So your case is looking like you have some kind of corrupted theme... As you may be using a theme from 2236 together with an updated Clover...

I really recommend that you install Clover from scratch in a fully-erased USB drive and during the installation you can check the "iClover theme", or a different theme if you feel safe to update the config.plist for that theme.

Share this post


Link to post
Share on other sites

I've tried to install clover on a formatted usb key now, but that icon is still missing :devilish:?(the "i" button you asked me before is "about")

?

So I solved by installing clover directly on the hard disk drive (first partition) instead of usb key, following your steps from 3 to 8. Now mavericks boots directly without usb, and that icon is there! thanks a lot for your support m.gbt!

Edited by lou112

Share this post


Link to post
Share on other sites

Hey guys, only now I've decided to investigate further on WHY wasn't I able to boot the installation from an external drive when using a Clover version other than 2236.

Well, obviously it was very silly. It turns out that the 2236 version I once downloaded had the HFSPlus driver included, which solves that particular problem, while the Clover installers don't have an option for it, you always get VBoxHfs which simply doesn't work on this machine for booting external devices...

So now we're able to boot the installation using the most recent Clover :) and this is specially great because there are some very valuable patches on the recent Clovers that make our hacking easier...

And of course, I gave the Yosemite installation a try, and it works just the same, without any different setting. Not even the "kext-dev-mode=1" flag, it seems. It just booted flawlessly.

?

So, this is already a very good indication that Yosemite will work without additional steps - of course, you will need to test each of your hardware and some of them may need special treatment other than those pointed by this guide.

I'm really not willing to try the new OS, at least until Apple obligates me to do so. I don't need any of its new features and every single report states that the UI is slower than it used to be on Mavericks.

Well... IMO we're already running the best we can for this machine, specially considering the UI because of its integrated graphics card weakness.

?

If anyone is really willing to try Yosemite, check out the new Clover_3193.zip and create an install media by following one of the methods described here.

Share this post


Link to post
Share on other sites

Found solution for HDMI audio:

Just applied the kext patches from?https://github.com/toleda/audio_CloverHDMI/blob/master/config-hdmi_hd3000-90.plist.zip to AppleIntelSNBGraphicsFB.

Sound goes to the HDMI device when HDMI cable is connected, and comes back to the internal speakers when disconnected.

Also I noticed that we need one less DSDT patch. The Method (_DSM) in the device HDEF can be completely added by Clover. Now we only need 2 patches: display and battery.

Guide is updated.

Sound.png

iMessage and FaceTime are working here. I don't know if this is due to some recent modifications I've made or something Apple has made. Are these services working for you?

?

edit: more people claiming to have iMessage suddenly working in the last days?http://www.reddit.com/r/hackintosh/comments/2zyg1x/imessage_randomly_started_to_work_after/

Share this post


Link to post
Share on other sites

just take a look at the new config.plist included in post-install.zip

there are two new patches to AppleIntelSNBGraphicsFB (there are three now, before there was only one)

these are the new ones:

			<dict>				<key>Comment</key>				<string>10.9/SNB/Port 05/DP>HDMI</string>				<key>Find</key>				<data>				AgUAAAAEAAAHAAAA				</data>				<key>Name</key>				<string>AppleIntelSNBGraphicsFB</string>				<key>Replace</key>				<data>				AgUAAAAIAAAGAAAA				</data>			</dict>			<dict>				<key>Comment</key>				<string>10.9/SNB/Port 06/DP>HDMI</string>				<key>Find</key>				<data>				AwQAAAAEAAAJAAAA				</data>				<key>Name</key>				<string>AppleIntelSNBGraphicsFB</string>				<key>Replace</key>				<data>				AwQAAAAIAAAGAAAA				</data>			</dict>

if you have any remaining doubts, just ask again ok? :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.