Jump to content
  • 0
JuninhoDG

XFX HD 6850 not working after update to 10.9.3

Question

Hi everyone. I had to update my Hackintosh to Mavericks 10.9.3 because the XCode6 Beta just run on this version or newer.

The problem: After the update I installed the VoodooHDA2.8.4 cause my audio was not working (I use HDMI cable, but the audio cable is pluggled in the PC's jack, not in TV), and after the installation of VoodooHDA2.8.4 and restarting of my system, my AMD HD6850 didn't work in the OS. I've seen something about install the Kext AMD6000Controller.kext which is [not in my case] inside the /System/Library/Extensions folder, but when I search in this folder it's not there. I don't know what happened.

?

I you help me to make onboard video work on it, will also be helpfull, I don't mind about it, just want video working.

?

Thanks for the help!

?

My configuration:

GPU: AMD 6850 XFX

4gb RAM

SSD Kingston 120gb (OS X is installed in here)

Core i3

Motherboard H61MXV Foxconn

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Don't know how you updated, but without AMD6000Controller.kext your card is not going to work.

With Pacifist you can open your OS X update file and copy AMD6000Controller.kext

If you want onboard video to work you've to tell us which i3 you have. It had to be HD3000.

Something like this: http://ark.intel.com/products/59080/Intel-Core-i3-2125-Processor-3M-Cache-3_30-GHz

Type in terminal:

kextstat | grep AMD
Output should be:

com.apple.kext.AMDSupportcom.apple.kext.AMD6000Controllercom.apple.AMDRadeonAcceleratorcom.apple.kext.AMDFramebuffer
For a HD3000 try this: http://www.osx86.net/files/file/3568-new-109-intel-hd-3000-hd-4000-driver/

Share this post


Link to post
Share on other sites
  • 0

Hi Rene. Well, after try really hard to recover my installation, I decided to reinstall over again. I suppose that the problem was something with the boot loader (in my previous installation I used Chimera / Chamaleon, in the new one I boot via USB using Clover). By the way, I posted some minutes ago about how to "copy the USB boot options to the hard drive" cause I don't like the idea of booting your system just with an USB stick.

?

Anyway, thank you very much for the help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.