Jump to content
  • 0
lcxplay

nVidia GTX Titan and VBIOS - Chameleon

Question

Hi guys!

My name is Luca and I'm new to the forum. Before I ask you something, I'll make a little introduction to my hackintosh.

In september I bought the pieces to asseble a new computer and this is the result:

?

?

- CM Strom Stryker case

- Intel core i7 4930k six-core cpu

- Asus Rampage IV Formula motherboard

- Zalman air cooler

- 1000w Thermaltake power supply

- 32gb (8 gb x 4) GSKILL DDR3 1600 mhz ram running at 1333mhz as I suppose, is the standard frequency of the mobo (one bank doesn't work -- I'm going to send it to the vendor soon -- so I installed only 24gb)

- nVidia GTX Titan 6gb DDR5

- Samsung EVO Pro 256gb ssd

- 1Tb western digital hdd

- 20in1 card reader

- intel based wifi card

- Windows 7 pro 64bit

- 2xAsus 24" LED monitors

?

The last week I decided to transform it into an hackintosh..........

I was very excited. So I spent the last three days and... uh... nights studying (computer architecture for the exam), installing OS X Mavericks into a 320gb 5400rpm hard drive and configuring it to make it perfect... and now it is... but... not the boot loader screen (as the bios screen).

I tried everything but I can't set the boot loader at full screen... I've googled a lot to find a solution. Actually there is: most people solve this issue using nvflash. I found a guide to used it at this link http://www.{censored}.com/graphics/106000-achieving-native-resolution-startup-edit-your-vesa-tables-amd-nvidia.html .

When I was booting into Windows I remembered that Chameleon Wizard (v4.3.3) has an option called VBIOS so I decided to ask you what should I do.

So these are my questions:

- what does VBIOS=Yes do in boot.plist? does it solve my problem without flashing the graphics card?

- should I also do what that guide says?

Remember that I configured boot.plist with Graphics Mode 1920x1080x32 and both width and height in theme.plist

?

Thank you for your help

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

For X79 systems you can better use rampagedev's DMG. He has complete DSDT with Graphics:

http://rampagedev.wordpress.com/guides/

?

Thank you for the reply. I followed their guide and istalled all kext for my mobo... my graphics card works well... the only thing I did differently was the dsdt. The x79.dmg package contains a file called ssdt.aml which caused me a kernel panic... after that I reinstalled all... I'm using a different dsdt... shall I retry using it? Do you know which is the default resolution of GTX Titan? I mean the resolution of the bootloader which seems to be the same of bios. If I know it, I can convert the numbers to hex and search them into vbios file. I tried every possible resolution but I didn't find the right one?

Share this post


Link to post
Share on other sites
  • 0

You can better ask Rampagedev on his site, he's the creator.

?

Default resolution depend on your monitor not the graphic card, but for boot I can use what I like..

With Chameleon Wizard you can use some default "Graphics Mode". I didn't tried them all, but they did work for me. Not that it is of any importants. I don't think this is the problem.

?

Did you tried his?Nvidia’s Retail Driver?

http://rampagedev.wordpress.com/kext-editing/nvidias-retail-driver/

?

[Edit]

Maybe this will/can answer your question about VBIOS:?https://github.com/Conti/Chameleon/blob/master/doc/BootHelp.txt

Share this post


Link to post
Share on other sites
  • 0

Sure, I installed retail and cuda drivers. I've also read the boot help but it isn't very detailed. Graphics Mode, theme width and height are set properly... but nothing changes... do you have other solutions? I hope Rampagedev and someone else join this discussion to solve this problem... I changed boot loader theme but nothing. I'll post some screenshots to show you how it is

Share this post


Link to post
Share on other sites
  • 0

Sure, I installed retail and cuda drivers. I've also read the boot help but it isn't very detailed. Graphics Mode, theme width and height are set properly... but nothing changes... do you have other solutions? I hope Rampagedev and someone else join this discussion to solve this problem... I changed boot loader theme but nothing. I'll post some screenshots to show you how it is

Do yo mean? your boot screen is not full screen. This nothing to do with GPU or cable,Its your PC Monitor. i have one ?23" no matter what you do its always has 1024x1024 .so i use same regulation for Boot screen.

?The link rene gave is boot flags and tweaks for boot loader ,you can try that .

?

or?

VBIOS for Titan ( not recommended )

http://forum.techinferno.com/nvidia-video-cards/3454-nvidia-gtx-titan-modified-vbios-more-control-better-overclocking.html

Share this post


Link to post
Share on other sites
  • 0

Get a look at the attachments... you can see what I get... but the question is: which is the resolution at which my monitor shows these windows? What resolution in Graphics Mode should I set?

post-633189-0-13421800-1402994273_thumb.

post-633189-0-10855500-1402994294_thumb.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.