Jump to content
Rene

Clover Fake ID HD5450 Yosemite, El Capitan

Recommended Posts

To use FakeID with Clover, you must have the following information in your config.plist.

ACPI > DSDT > Fixes > Fix_Display_0100=TRUE
Devices > FakeID > ATI=0xDeviceIDVendorID (for example 0x68E01002)
Graphics > Inject > ATI=TRUE
For El Capitan you should not use "Inject ATI" because that will give you a black screen after Sleep.

The card will show in System Info as "ATI Radeon HD 5000 1024 MB" but who cares :P

 

Spoiler


FXc.png
DXc.png
GXc.png

 

For El Capitan you should not use "Inject ATI" because that will give you a black screen after Sleep.

The card will show in System Info as "ATI Radeon HD 5000 1024 MB" but who cares :P



I had to set the frame buffer to “Shrike??? to get it working right.
Graphics > FB Name > Shrike

zWc.png

As you can see my Fake ID is 0x68e0. My real ID is 0x68F9.

This should work for every HD5450 with Device ID 68F9 68E5 68e1

Working on a clean install without editing/patching kexts.
No problems with sleep.
 

renes-Mac-Pro:~ rene$ kextstat | grep AMD
com.apple.kext.AMDSupport (1.3.0) <60 59 12 11 7 5 4 3 1>
com.apple.kext.AMD5000Controller (1.3.0) <61 59 12 11 5 4 3 1>
com.apple.AMDRadeonX3000 (1.3.0) <80 59 12 7 5 4 3 1>
com.apple.kext.AMDFramebuffer (1.3.0) <61 59 12 11 7 5 4 3 1>

More tests with other frame buffers:

renes-Mac-Pro:~ rene$ ioreg | grep ATY
    | |   |   | +-o ATY,Hoolock@0  <class AtiFbStub, id 0x1000002b6, registered, matched, active, busy 0 (5 ms), retain 8>    | |   |   | | +-o ATY_Hoolock  <class AMDFramebuffer, id 0x1000002b9, registered, matched, active, busy 0 (4 ms), retain 18>    | |   |   | +-o ATY,Hoolock@1  <class AtiFbStub, id 0x1000002b7, registered, matched, active, busy 0 (0 ms), retain 8>    | |   |   | | +-o ATY_Hoolock  <class AMDFramebuffer, id 0x1000002bf, registered, matched, active, busy 0 (0 ms), retain 15>    | |   |   | +-o ATY,Hoolock@2  <class AtiFbStub, id 0x1000002b8, registered, matched, active, busy 0 (0 ms), retain 8>    | |   |   | | +-o ATY_Hoolock  <class AMDFramebuffer, id 0x1000002c5, registered, matched, active, busy 0 (0 ms), retain 15>

GWc.png

 

 

Last login: Fri Jun  5 12:06:50 on consolerenes-Mac-Pro:~ rene$ ioreg | grep ATY
    | |   |   | +-o ATY,Langur@0  <class AtiFbStub, id 0x1000002b2, registered, matched, active, busy 0 (4 ms), retain 8>    | |   |   | | +-o ATY_Langur  <class AMDFramebuffer, id 0x1000002b5, registered, matched, active, busy 0 (3 ms), retain 18>    | |   |   | +-o ATY,Langur@1  <class AtiFbStub, id 0x1000002b3, registered, matched, active, busy 0 (0 ms), retain 8>    | |   |   | | +-o ATY_Langur  <class AMDFramebuffer, id 0x1000002bb, registered, matched, active, busy 0 (0 ms), retain 15>    | |   |   | +-o ATY,Langur@2  <class AtiFbStub, id 0x1000002b4, registered, matched, active, busy 0 (0 ms), retain 8>    | |   |   | | +-o ATY_Langur  <class AMDFramebuffer, id 0x1000002c1, registered, matched, active, busy 0 (0 ms), retain 15>

FWc.png

 

 

Shrike:Last login: Fri Jun  5 12:20:45 on consolerenes-Mac-Pro:~ rene$ ioreg | grep ATY
    | |   |   | +-o ATY,ATY,RadeonFramebuffer@0  <class AtiFbStub, id 0x1000002b0, registered, matched, active, busy 0 (5 ms), retain 8>    | |   |   | | +-o ATY_ATY,RadeonFramebuffer  <class AMDFramebuffer, id 0x1000002b3, registered, matched, active, busy 0 (4 ms), retain 18>    | |   |   | +-o ATY,ATY,RadeonFramebuffer@1  <class AtiFbStub, id 0x1000002b1, registered, matched, active, busy 0 (0 ms), retain 8>    | |   |   | | +-o ATY_ATY,RadeonFramebuffer  <class AMDFramebuffer, id 0x1000002ba, registered, matched, active, busy 0 (0 ms), retain 15>    | |   |   | +-o ATY,ATY,RadeonFramebuffer@2  <class AtiFbStub, id 0x1000002b2, registered, matched, active, busy 0 (0 ms), retain 8>    | |   |   | | +-o ATY_ATY,RadeonFramebuffer  <class AMDFramebuffer, id 0x1000002c0, registered, matched, active, busy 0 (0 ms), retain 15>

DWc.png

As always big thanks and credits to kyndder for teaching me this.

 

[Edit]          

For El Capitan you should not use "Inject ATI" because that will give you a black screen after Sleep.
The card will show in System Info as "ATI Radeon HD 5000 1024 MB" but who cares 

Share this post


Link to post
Share on other sites

?

?

As always big thanks and credits to?kyndder?for teaching me this.

Yeah always teaches very well , i also have some unforgettable experiences?

Lets Cheers :very_drunk:? :very_drunk:? :very_drunk:? :very_drunk: ?for @Kynnder?

Edited by InsanelyDeepak

Share this post


Link to post
Share on other sites

To use FakeID with Clover, you must have the following information in your config.plist.

?

I update the config.plist (and not used the .kext files, see other thread :) but the machine hangs at reboot now (and then crashes and tries to reboot); there seems to be a kernel panic or something like that.

Without the fakeID it worked.

Any idea how to debug this?

Thanks again.

Share this post


Link to post
Share on other sites

Don't forget to set RtVariables for El Capitan:

 

<key>RtVariables</key>

<dict>

<key>BooterConfig</key>

<string>0x28</string>

<key>CsrActiveConfig</key>

<string>0x67</string>

</dict>

 

And after cache update remove them or set to "0"

<key>RtVariables</key>

<dict>

<key>BooterConfig</key>

<string>0x0</string>

<key>CsrActiveConfig</key>

<string>0x0</string>

</dict>

Share this post


Link to post
Share on other sites

Works for?0x68f9 for El Capitan 10.11.2.. Followed your Clover config pix and it did the trick!?

?

Many many maaany thanks!! :)

Edited by brandur

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.