Jump to content

[SOLVED] OsxAptioFixDrv: Error - requested memory exceeds our allocated relocation block

Recommended Posts

So, today I was going to install El Capitan GM over a Public Beta 6 installation I have in a secondary partition, and usually I would do that by booting an USB installer, but this time unfortunately I decided to try a new thing. I've just opened the .app downloaded from the App Store and clicked to install to that drive. After about a minute, the system restarted and then it wouldn't boot anymore from Clover... I'm using v3259 both on my SSD's EFI partition and my USB drive.
Tried many things like adding slide=0 and booting without caches, but nothing would work, neither the installation contained in the USB drive, nor my current stable Mavericks main partition. When booting verbose, it always presented the error in the title of this topic.

Ended up solving it by replacing the following files in my USB Clover with a just downloaded Clover v3259 ISO from a Linux Live USB:
Also replaced EFI/CLOVER/Drivers64Uefi/OsxAptioFixDrv by OsxAptioFix2Drv and deleted the folder EFI/APPLE.
Probably the most important was using OsxAptioFix2, remains to be tested... If someone ever gets this error, please try just replacing OsxAptioFix and report if successful :)

Once I did that, I booted into USB's Clover and it booted fine the El Capitan installation. It automatically proceeded the installation that I had begun before.


edit: this issue could have been corrected by Clover v3264, also remains to be tested!

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.