Jump to content
theconsumer1

[GUIDE] GA-Z97-D3H - Core i5 - GTX650 - EL CAPITAN

Recommended Posts

[GUIDE] GA-Z97-D3H - Core i5 - GTX650 - EL CAPITAN

 

UPDATE:  Now on MacOS Sierra - Build is Flawless! (see guide on osx86.net)

 

 

desktop.jpg

Specs:

  • GA Z97-D3H (rev 1.1, I am using F9, have used F7 and F8. F7 booted fastest)
  • Core i5 4430 Haswell 3.0 GHz
  • EVGA GTX650 1024mb
  • 8GB G.Skill 1333MHz
  • ASUS USBN13 Wireless Adapter
  • 120GB SSD
  • 750GB HDD
  • 160GB HDD
  • 10.11.1 OSX El Capitan

Working:

  • App store
  • Wifi (USB)
  • Audio (ALC1150 - Onboard)
  • Ethernet (via kext)
  • Power Mangement
  • Wake/Sleep
  • Graphics
  • Probably one of the most functional hacks out there.

Issues:

  • Random KP very rarely every (Once per 2 weeks- system restarts)... Could be related to failing hardware, not sure.

Notes:

  •  Onboard ALC1150 is used for this system
  • If struggling with enabling Audio, I recommend the    Syba USB 2.0 External Virtual 7.1 Surround Sound Card Adapter Sound Cards SD-CM-UAUD71    for a cheap solution ($9.00USD) - Works perfect (I Have two).
  • This build uses an SSDT and DSDT - (Optional)

Installation:

The best way to create a USB installer is with the tool made by an InsanelyMac user that automates the manual actions. Heres the link, otherwise there are tons of other tutorials for a USB.

http://www.insanelymac.com/forum/topic/307003-clover-os-x-el-capitan-usb/

Note:  The Installation for El Capitan requires no removing of Ram or any BS like that. Simply plug and play.

Bios Settings:

  • Disable VT-d
  • Set XHCI to Auto mode
  • Disable IGFX
  • Enable XHCI and EHCI handoff
  • Set SATA Configuration to AHCI
  • Important: Set memory mode to Enhanced Stability

Post Installation:

Follow the directions in specific, precise order for best results:

 

  1. After initial installation, boot into El Capitan with the Clover USB Installer.
  2. Install all network related kexts (For Ethernet, Download here:  AppleIntelE1000e.kext.zip) - Reboot.
  3. Install Clover Bootloader to MAC SSD (r3270 works nice)

           Settings for Clover Bootloader:

 

 

Screen Shot 2015-10-03 at 1.31.21 PM.pngScreen Shot 2015-10-03 at 1.31.42 PM.png

     4.  Do not reboot yet. Mount the EFI Partition that corresponds to your Mac SSD (the drive you just installed clover to). Navigate to EFI/EFI/Clover/Kexts/10.11 folder   and place the latest version of FakeSMC there. Do not reboot yet

 

     5.  Open Config.plist in Clover Configuration. Make sure that Rootles=0, -XCPM flags are checked. Make darkwake=no. Also make sure that SMBIOS is set to iMac 14,2. Make sure that if using the GTX650, uncheck inject nvidia or intel under graphics.

 

     6.  Optional: For maximum compatibility. I recommend using a DSDT and SSDT. SSDTs can be generated with Pike's tool found here:  http://www.rampagedev.com/ page_id=197  

         However, if you have the same board, you can download my personal DSDT and Config file. BUT no guarantees that it will work. Should be harmless though.

 

          theconsumer1 - El Capitan files.zip

         DSDT and SSDT, for clover, are to be installed at EFI/Clover/ACPI/Patched folder.

 

    7.  If you skipped 6, then the next thing you need to install is Trim Patch in Clover Configuration (already patched in my DSDT).

          See guide here: http://www.insanelymac.com/forum/topic/298507-enable-trim-on-non-apple-ssd/

 

    8.   Enable onboard audio ALC1150 with this guide ONLY : https://github.com/toleda/audio_RealtekALC

         Requirements:

              - Must have NATIVE AppleHDA.kext in S/L/E

              - Must remove any HDAEnabler kexts in S/L/E

  - If using your a DSDT make sure you edit and navigate to HDEF/LayoutID/0x01, 0x00, 0x00, 0x00 and make sure that I.D. is 0x01. If not, change it to 0x01.

              - To edit/check DSDT.aml files use DPCIManger app

              - Note: My DSDT on this thread is not updated for the 0x01 edit.

FAQ:

Do i need to update bios version

   No. Many advise that you do, but if you are behind 1 version, it is not big deal.

What about NVIDIA Web Drivers   

  The web drivers are just a pain that offers no performance increase. They will give you headaches. Ignore them for now.

How do I know if CPU Power management is working  

  Download Intel Power Gadget from Intel's website. If you can see that CPU Freq and Power is changing, you got it.

Appreciation:

Thanks for hackintoshosx.com, insanelymac.com, and the many other contributing members of the community, for all their hard work, research, and time. Also, a special thanks to hackintoshosx user/mod/admin Dmos and Kyndder for really helping me out with my build!

 

For any question, please address this thread.

 

gb.png

Edited by theconsumer1

Share this post


Link to post
Share on other sites

Also:

?

If you have success with this board and want to share, please do on this post. I really want to learn a lot more about this board with hackintoshing. Please post your experiences below! Thanks

Share this post


Link to post
Share on other sites

post-595578-0-60521300-1444310121_thumb.

?

?

GA B75M-D3H

Core i3 3.0 GHz

Gigabyte GTX650 1024mb

4GB Corsair Vengeance 1333MHz

500GB HDD

10.11(Final) OSX El Capitan

?

?

?

Bootloader Enoch r2773

?

<key>GraphicsEnabler</key>

<string>No</string>
?
<key>Kernel Flags</key>
<string>-v kext-dev-mode=1 npci=0x2000 dart=0 rootless=0</string>
?
?

Share this post


Link to post
Share on other sites

?

attachicon.gifCaptura de Tela 2015-10-08 às 10.13.04.png

?

?

GA B75M-D3H

Core i3 3.0 GHz

Gigabyte GTX650 1024mb

4GB Corsair Vengeance 1333MHz

500GB HDD

10.11(Final) OSX El Capitan

?

?

?

Bootloader Enoch r2773

?

<key>GraphicsEnabler</key>

<string>No</string>
?
<key>Kernel Flags</key>
<string>-v kext-dev-mode=1 npci=0x2000 dart=0 rootless=0</string>

?

?

Nice. But you have a completely different chipset and board so I don't know how this applies to the thread.

Share this post


Link to post
Share on other sites

This guide worked beautifully! I initially tried to follow this guide with the exception of upgrading a previous Mavericks install to El Capitan and it would install but never boot after that. I then tried doing a clean install, which worked, and then use migration assistant to move my old setting and stuff off of a Time Machine volume. After that, the machine, again, wouldn't boot. So, the third time, I stopped being stubborn and just did a clean install as this guide suggests and the machine is running great! Better than it did with Mavericks (El Capitan's performance improvements really shine here).

?

I just manually configured the machine like it was before and then manually migrated some of my preferences from ~/Library and /Library/Server (This is a rack mount server) and everything is working great like it was before, except now it runs faster, seems more stable, and I can finally use the newer Server.app versions.

?

Thanks a lot for this!

Share this post


Link to post
Share on other sites

I have this same motherboard but I can't get Clover to boot into OSX Installation because of a KP.

Here are the relevant error lines from a verbose boot:

AppleACPIPlatformExpert::start failedpanic(cpu0 caller 0xffffff80008d1bc4): "Unable to find driver for this platform: \"ACPI\".\n"@/Library/Caches/com.apple.xbs/Sources/xnu/xnu-3247.1.106/iokit/Kernel/IOPlatformExpert.cpp: 1665Debugger called: <panic>Backtrace (CPU0), Frame : Return Address0xffffff81e592bdf0 : 0xfffffff80002e53570xffffff81e592be70 : 0xfffffff80008d1bc40xffffff81e592be80 : 0xfffffff800089405d0xffffff81e592bec0 : 0xfffffff8000893b660xffffff81e592bf30 : 0xfffffff800088e81a0xffffff81e592bf70 : 0xfffffff80008947fc0xffffff81e592bfb0 : 0xfffffff80003d14b7BSD process name corresponding to current thread: UnknownBoot args: kext-dev-mode=1 rootless=0 -v slide=0 container-dmg=file:///Install%20OS%20X%20El%20Capitan.app/Contents/SharedSupport/InstallESD.dmg root-dmg=file:///BaseSystem.dmgMac OS version:Not yet setKernel version:Darwin Kernel Version 15.0.0: Wed Aug 26 16:57:32 PDT 2015; root:xnu-3247.1.106-1/RELEASE_X86_64?

Tried both the linked "Clover OS X El Capitan-v6" app and the generic Clover with the settings showed in the pics.

Thanks in advance for your help

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.