Jump to content
  • 0
Sign in to follow this  
jamiezotts

QE/CI on AMD

Question

Hello

 

I have iAtkos snow leopard 10.6.7 installed and working on an HP Probook 6545b AMD ATI HD 4200, 8GB memory. Native resolution works too at 1366x768. Can only get 4GB to boot with "maxmem=4096". Everything works minus CI/QE. Has anyone got this to work on the same machine?

 

Thanks!

jamie

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

You have to use 64 bit patch for to use 8 gb ram.

At first try to use flags : -force64

You can try to update to 10.6.8 with patched kernel( not recom.).

Try change kernel 10.6.8 V2 to fix.

https://www.dropbox.com/sh/0vrdxplx1k7v7t1/AADWbQX8KbV1EANFwiHrjTuxa?dl=0

Make sure u know what u doing. if the flags is working no need to try others.Update to 10.6.8 be good idea.

Share this post


Link to post
Share on other sites
  • 0

Thanks for this.
-force64 boots with full 8GB. Works!
Installed the legacy kernel 10.6.8.v2, updated to 10.6.8 with 10.6.8.v1.1 combo updater successfully.
acceleration QE and CI not fully functional. Decently plays mp4 file in quicktime 7 quicktime 10. though uses almost entire processor power. VLC returns an error when I play an .MTS file:
"OpenGL acceleration is not supported on your Mac" , "Your Mac lacks Quartz Extreme acceleration, which is required for video output. It will still work, but much slower".

Downloaded the amd patcher amd_insn_patcher to boot with 8GB but did not use since the "-force64" flag worked.
Will the AMD_patcher fix the QE/CI acceleration issue or did I understand you correctly that it was only needed if the "-force64" flag didn't work?
If not, Is there a solution for the lack of QE?

Again, thanks!

jamie

Share this post


Link to post
Share on other sites
  • 0

Thanks for the link. Installed Dong's RadeonHD.kext mentioned in this thread. At least for this machine no change, no QE.

Thanks again. I really appreciate your input.

jamie

Share this post


Link to post
Share on other sites
  • 0
5 hours ago, jamiezotts said:

Thanks for the link. Installed Dong's RadeonHD.kext mentioned in this thread. At least for this machine no change, no QE.
Thanks again. I really appreciate your input.
jamie

if your 10.6.7 kext are working before try use them

Share this post


Link to post
Share on other sites
  • 0

Went back and installed 10.6.7 from backup on new drive. In the ATIRadeonX2000.kext I added my device ID (Contents > info.plist) which is 0x97120x1002. Then I also added it to the ATIRadeonX3000.kext. Still nothing.

Next installed QE_CI_Exotic patch for 10.6.7.pkg. It installed the ATIRAdeonX3000.kext into the System Library rather than System Library Extensions folder. I assume this was intentional using his installer. Added the device number to his ATIRadeonX3000.kext and to the ATIRadeonX2000.kext of his that was installed to the S/L/E folder. Booted up with these flags: CPUS=1 GraphicsEnabler=Y PCIRootUID=1 NPCI=0x2000. Still no luck.

According to this post (http://netkas.org/?p=685#comments) comment, "The HD 4200 and HD 4250 with device id 0x97XX1002 will not work. The HD 4250 and 4200 actually are the same of HD 3450..." This is what my device ID appears to be.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.