Jump to content
  • 0

wifi is not working for atheros ar8161 pci-e gigabit


Successfully install all the kexts and ethernet is working like a charm but wifi is not detected..

I've already tried atherosI08211family.kext and wifiinjector.kext

But neither wifi nor bluetooth is working.

this is my toshiba satellite pro laptop's ethernet card details :


Qualcomm Atheros AR8161 PCI Express Gigabit Ethernet:


  Name:    ethernet

  Type:    Ethernet Controller

  Bus:    PCI

  Vendor ID:    0x1969

  Device ID:    0x1091

  Subsystem Vendor ID:    0x1179

  Subsystem ID:    0xff1e

  Revision ID:    0x0010

  Link Width:    x1

  BSD name:    en0

  Kext name:    AtherosE2200Ethernet.kext

  Location:    /System/Library/Extensions/AtherosE2200Ethernet.kext

  Version:    1.0.0


this is the wifi details : 


  Software Versions:

  CoreWLAN:    5.0 (500.35.2)

  CoreWLANKit:    4.0 (400.35)

  Menu Extra:    10.0 (1000.33.2)

  System Information:    9.0 (900.9)

  IO80211 Family:    7.0 (700.52)

  Diagnostics:    4.0 (400.68)

  AirPort Utility:    6.3.4 (634.17)


for bluetooth : no info found.


so my question is : how can i enable wifi and bluetooth in my hackintosh ???


please help.


thank you.

Share this post

Link to post
Share on other sites

1 answer to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.