Jump to content
Sign in to follow this  
berlindude

"Can't find mach_kernel" at startup

Recommended Posts

I have a small problem when I want to boot automaticly my Mac HD (I have chameleon on usb stick). when I put the string "Default partition" for my Mac HD in the com.apple.Boot.plist I get the error: "Can't find mach_kernel" and I have to choose manually. I tried HD(1,2) or the UUID of the Harddrive. If anybody has a solution, would be great.:)

Share this post


Link to post
Share on other sites

Is your Mac HD partitioned in any way? When you're booted into Mac OS X, what does the output of "mount" in the terminal say?

Share this post


Link to post
Share on other sites

Hi Mike,

my Mac HD (10.5) has two partitions but I get the same problem with my SL HD which I installed on an other physical HD and which has only one partition.

Terminal gives me:

Applebox:~ Admin$ mount

/dev/disk2s2 on / (hfs, local, journaled)

devfs on /dev (devfs, local)

fdesc on /dev (fdesc, union)

map -hosts on /net (autofs, automounted)

map auto_home on /home (autofs, automounted)

/dev/disk0s2 on /Volumes/Snow Leo HD (hfs, local, journaled)

/dev/disk3s2 on /Volumes/TM (hfs, local, journaled)

/dev/disk1s2 on /Volumes/HD 3 (hfs, local, journaled)

/dev/disk1s3 on /Volumes/HD 4 (hfs, local, journaled)

/dev/disk2s3 on /Volumes/HD 2 (hfs, local, journaled)

/dev/disk5s1 on /Volumes/EFiB{censored}2 (hfs, local, nodev, nosuid, journaled, noowners)

/dev/disk4s1 on /Volumes/EFiB{censored} (hfs, local, nodev, nosuid, journaled, noowners)

If you have an idea Mike, would be great!

Regards

berlindude

Share this post


Link to post
Share on other sites

Hey mike I attached my com.apple.boot.plist. This is the one I use for 10.5.8, the one for 10.6 has different hex code for video card.

If you or anybody could help me, this would be great!

regards

berlindude

Share this post


Link to post
Share on other sites

i am having the same problem.

I am using the modified DSDT for my motherboard, but i kept disabler.kext, just in case it wouldn't start

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.