Jump to content
  • 0
Sign in to follow this  
aae55555

App Store - "Your device or computer could not be verified".

Question

Hi guys

I have a Marvell 88E8056 Kext for my ethernet which works fine. But app store doesn't work and gives me this error message.

I have tried everything to fix it!

Removing all adapters in network,

deleting library>preferences>system configuration> NetworkInterfaces.plist

Rebooting

Adding adapters (en0) first..

Also tried adding this to boot.plist..

<key>PCIRootUID</key>

<string>1</string>

<key>EthernetBuiltIn</key>

<string>Yes</string>

No luck..

Please help! :(

Error message:

appstore.jpg

Adapters:

adapters.jpg

Thanks!!

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
I Found my solution here. If you have to generate an EFI string for your GFX card then the above method doesn't work. You have to splice the Ethernet and GFX codes together to make one STRING. Here is the link.

{censored} Forum ? Information

I also added this key to my apple.boot.plist in /Extra/ folder (not sure if it works without it)

EthernetBuiltIn

Yes

this worked for me !!!

Share this post


Link to post
Share on other sites
  • 0
I tried reinstalling and using another kext too.. Hmmm..

I'm trying to add EFI string (device ID) to boot plist now..

Ok i just fixed this one myself!! (well by researching the net)..

For anyone else with similar symptoms, the ONLY way to fix this (in my case anyways) was to add the EFI string for ethernet card to the boot.plist..

To do this i:

- downloaded EFI Studio, selected Ethernet, selected Add Device. Then clicked write to com.apple.boot.plist.

- Then went to /Library/Preferences/SystemConfiguration/apple.com.boot.plist and selected the new key and string it added.

- Then coped this string and pasted into the /Extra/apple.com.boot.plist file and saved.

Then important STEP!

- Remove all network devices from System Preferences/Network.

- Delete deleting library>preferences>system configuration> NetworkInterfaces.plist file.

* Finally, Reboot.

After reboot, go to System Preferences/Network add add devices. Click (Ethernet) FIRST!! Then add the other adapters you use to connect to the internet.

Voila. App Store now works :D :cool:

Hope this helps someone somewhere

so i followed this to a T and it worked successfully.... However now after reboot app store is no longer working and i am back to square one. Would be nice to have a permanent fix. Anyone have anymore insight to this?

Share this post


Link to post
Share on other sites
  • 0

I followed the original instructions from aae55555 but had no plist in my Extra's folder. Not sure why but followed it line by line minus the last plist edit and now I'm golden. The A Store now works!!

Many thanks!

mr

Share this post


Link to post
Share on other sites
  • 0

Hi there,

at first thanks for your solution. Unfortunately it won't work for me. At first i should mention, that i am completely new to the whole OSX86 stuff so a few things are way over my knowledge.

I am using a wi-fi Adapter to connect to the Internet, driver is from Ralink.

Here's what i did:

Generated a key through EFI Studio, added the string to com.apple.Boot.plist

Weird part is that it only writes 0x01 as string instead of using the long HEX String.

Anyways, i edited the org.chameleon.Boot.plist myself, now it looks like this:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>npci=0x2000 darkwake=0</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Timeout</key>
<string>2</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>PCIRootUID</key>
<string>0</string>
<key>device-properties</key>
<key>PciRoot(0x0)/Pci(0x19,0x0)</key>
<dict>
<key>built-in</key>
<string>450000000100000001000000390000000100000002010c00d041030a000000000101060000197fff0400160000006200750069006c0074002d0069006e0000000500000001</string>
</dict>
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>UseKernelCache</key>
<string>Yes</string>
</dict>
</plist>

Then i deleted all my network adapters which were exactly one (the WiFi), deleted the whatever named file and restarted.

When i try to add a network adapter like Ethernet, it simply isn't there. I can not select any ethernet adapters, all i got is Bluetooth, Firewire, WiFi and some other stuff.

So the result of all that is clear, i can't login to the app store .. still =(

Any hints what i could do are really appreciated.

Cheers,

Tom

P.S. Sorry for my weird english ;)

Edited by subsonic

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.